# Elasticsearch-6.1.1 failed to load plugin class \[org.elasticsearch.xpack.XPackPlugin\]

**URL:** <https://discuss.elastic.co/t/elasticsearch-6-1-1-failed-to-load-plugin-class-org-elasticsearch-xpack-xpackplugin/114667>\
**Category:** Elasticsearch\
**Created:** [January 9, 2018, 9:00am UTC](https://discuss.elastic.co/t/elasticsearch-6-1-1-failed-to-load-plugin-class-org-elasticsearch-xpack-xpackplugin/114667 "2018-01-09T09:00:39Z")\
**Posts on this page:** 5\
**Page:** 1

<div class="post-metadata">

**Author:** ![shaonbean](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/shaonbean/32/14416_2.png) [@shaonbean](https://discuss.elastic.co/u/shaonbean)\
**Post date:** [January 9, 2018, 9:00am UTC](https://discuss.elastic.co/t/elasticsearch-6-1-1-failed-to-load-plugin-class-org-elasticsearch-xpack-xpackplugin/114667/1 "2018-01-09T09:00:39Z")

</div>

1、env：centos6.9 + elastic stask 6.1.x

yum install elasticsearch/filebeat/kibana is ok,  
but I follow  
[https://www.elastic.co/guide/en/elasticsearch/reference/6.1/installing-xpack-es.html](https://www.elastic.co/guide/en/elasticsearch/reference/6.1/installing-xpack-es.html) install x-pack

restart elasticsearch errors...

 ![TIM截图20180109165959](https://us1.discourse-cdn.com/elastic/original/3X/b/6/b635263afdb84bdc15ad2acc0d16b0049533f4b1.png)

---

<div class="post-metadata">

**Author:** ![warkolm](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/warkolm/32/39224_2.png) [@warkolm](https://discuss.elastic.co/u/warkolm)\
**Post date:** [January 9, 2018, 9:01am UTC](https://discuss.elastic.co/t/elasticsearch-6-1-1-failed-to-load-plugin-class-org-elasticsearch-xpack-xpackplugin/114667/2 "2018-01-09T09:01:57Z")

</div>

Please don't post pictures of text, they are difficult to read and some people may not be even able to see them.

---

<div class="post-metadata">

**Author:** ![shaonbean](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/shaonbean/32/14416_2.png) [@shaonbean](https://discuss.elastic.co/u/shaonbean)\
**Post date:** [January 9, 2018, 9:04am UTC](https://discuss.elastic.co/t/elasticsearch-6-1-1-failed-to-load-plugin-class-org-elasticsearch-xpack-xpackplugin/114667/3 "2018-01-09T09:04:20Z")

</div>

ok,i will be change next.

---

<div class="post-metadata">

**Author:** ![dorinand](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/dorinand/32/70521_2.png) [@dorinand](https://discuss.elastic.co/u/dorinand)\
**Post date:** [January 11, 2018, 1:50pm UTC](https://discuss.elastic.co/t/elasticsearch-6-1-1-failed-to-load-plugin-class-org-elasticsearch-xpack-xpackplugin/114667/4 "2018-01-11T13:50:12Z")

</div>

Hello,

I did the same guide. In logs there is line like this:  
`Caused by: java.nio.file.AccessDeniedException: /etc/elasticsearch/elastic-certificates.p12`

I assumed that there is problem with permissions of cert file. In my case there was only rw permissions for owner, and nothing for group and others. So I changed it with `chmod +r` and the ES cluster now running.

I hope I helped you.

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [February 8, 2018, 1:50pm UTC](https://discuss.elastic.co/t/elasticsearch-6-1-1-failed-to-load-plugin-class-org-elasticsearch-xpack-xpackplugin/114667/5 "2018-02-08T13:50:16Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
