# Elasticsearch 6.2 service failed to start

**URL:** <https://discuss.elastic.co/t/elasticsearch-6-2-service-failed-to-start/216898>\
**Category:** Elasticsearch\
**Created:** [January 28, 2020, 6:01pm UTC](https://discuss.elastic.co/t/elasticsearch-6-2-service-failed-to-start/216898 "2020-01-28T18:01:30Z")\
**Posts on this page:** 4\
**Page:** 1

<div class="post-metadata">

**Author:** ![csrowell](https://avatars.discourse-cdn.com/v4/letter/c/c77e96/32.png) [@csrowell](https://discuss.elastic.co/u/csrowell)\
**Post date:** [January 28, 2020, 6:01pm UTC](https://discuss.elastic.co/t/elasticsearch-6-2-service-failed-to-start/216898/1 "2020-01-28T18:01:30Z")

</div>

We did Windows updates this month and are now getting these errors:

Windows Event Log:

The Elasticsearch 6.2.4 (elasticsearch-service-x64) service terminated with the following service-specific error:  
Incorrect function.

And in the log files:

java.lang.IllegalArgumentException: unable to parse policy file `file:/D:/Program%20Files/ElasticSearch/elasticsearchv6.2/modules/lang-expression/plugin-security.policy`  
at org.elasticsearch.bootstrap.Security.readPolicy(Security.java:254) ~[elasticsearch-6.2.4.jar:6.2.4]  
at org.elasticsearch.bootstrap.Security.getPluginPermissions(Security.java:194) ~[elasticsearch-6.2.4.jar:6.2.4]  
at org.elasticsearch.bootstrap.Security.configure(Security.java:123) ~[elasticsearch-6.2.4.jar:6.2.4]  
at org.elasticsearch.bootstrap.Bootstrap.setup(Bootstrap.java:208) ~[elasticsearch-6.2.4.jar:6.2.4]  
at org.elasticsearch.bootstrap.Bootstrap.init(Bootstrap.java:323) [elasticsearch-6.2.4.jar:6.2.4]  
at org.elasticsearch.bootstrap.Elasticsearch.init(Elasticsearch.java:121) [elasticsearch-6.2.4.jar:6.2.4]  
at org.elasticsearch.bootstrap.Elasticsearch.execute(Elasticsearch.java:112) [elasticsearch-6.2.4.jar:6.2.4]  
at org.elasticsearch.cli.EnvironmentAwareCommand.execute(EnvironmentAwareCommand.java:86) [elasticsearch-6.2.4.jar:6.2.4]  
at org.elasticsearch.cli.Command.mainWithoutErrorHandling(Command.java:124) [elasticsearch-cli-6.2.4.jar:6.2.4]  
at org.elasticsearch.cli.Command.main(Command.java:90) [elasticsearch-cli-6.2.4.jar:6.2.4]  
at org.elasticsearch.bootstrap.Elasticsearch.main(Elasticsearch.java:92) [elasticsearch-6.2.4.jar:6.2.4]  
at org.elasticsearch.bootstrap.Elasticsearch.main(Elasticsearch.java:85) [elasticsearch-6.2.4.jar:6.2.4]  
Caused by: java.security.NoSuchAlgorithmException: JavaPolicy Policy not available  
at sun.security.jca.GetInstance.getInstance(GetInstance.java:198) ~[?:1.8.0\_242]  
at java.security.Policy.getInstance(Policy.java:386) ~[?:1.8.0\_242]  
at org.elasticsearch.bootstrap.Security.readPolicy(Security.java:246) ~[elasticsearch-6.2.4.jar:6.2.4]  
... 11 more

any ideas?

This is for an Azure DevOps Server installation.

---

<div class="post-metadata">

**Author:** ![csrowell](https://avatars.discourse-cdn.com/v4/letter/c/c77e96/32.png) [@csrowell](https://discuss.elastic.co/u/csrowell)\
**Post date:** [January 28, 2020, 7:56pm UTC](https://discuss.elastic.co/t/elasticsearch-6-2-service-failed-to-start/216898/2 "2020-01-28T19:56:05Z")

</div>

We eventually tracked this down to an update to Zulu JRE on the machine. We had zulu8.44.0.11-ca-jre8.0.242-win\_x64.msi installed. Rolling that back to what we previously had, zulu8.40.0.25-ca-jre8.0.222-win\_x64.msi, fixed this issue for us.

---

<div class="post-metadata">

**Author:** ![csrowell](https://avatars.discourse-cdn.com/v4/letter/c/c77e96/32.png) [@csrowell](https://discuss.elastic.co/u/csrowell)\
**Post date:** [January 31, 2020, 2:40pm UTC](https://discuss.elastic.co/t/elasticsearch-6-2-service-failed-to-start/216898/3 "2020-01-31T14:40:27Z")

</div>

My coworker took a look at this more in depth and found:

> To upgrade Azul Zulu, the Elasticsearch service first has to be stopped. Once the Azul Zulu upgrade has completed, the Elasticsearch service can be started again.
> 
> This was accomplished using the elasticsearch-service.bat file, using the stop and start parameters.
> 
> After upgrading to Azul Zulu JRE 8.44.0.11 (8u242), the service started back up just fine.
> 
> Apparently upgrading while Elasticsearch is currently running breaks things, but upgrading after Elasticsearch stops works just fine. No upgrade of Elasticsearch itself was required.

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [February 28, 2020, 2:40pm UTC](https://discuss.elastic.co/t/elasticsearch-6-2-service-failed-to-start/216898/4 "2020-02-28T14:40:35Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
