# Elasticsearch 6.3.1 xpack password enabling shows error

**URL:** <https://discuss.elastic.co/t/elasticsearch-6-3-1-xpack-password-enabling-shows-error/140999>\
**Category:** Elasticsearch\
**Created:** [July 21, 2018, 3:35pm UTC](https://discuss.elastic.co/t/elasticsearch-6-3-1-xpack-password-enabling-shows-error/140999 "2018-07-21T15:35:27Z")\
**Posts on this page:** 3\
**Page:** 1

<div class="post-metadata">

**Author:** ![rijinmp](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/rijinmp/32/24634_2.png) [@rijinmp](https://discuss.elastic.co/u/rijinmp)\
**Post date:** [July 21, 2018, 3:35pm UTC](https://discuss.elastic.co/t/elasticsearch-6-3-1-xpack-password-enabling-shows-error/140999/1 "2018-07-21T15:35:27Z")

</div>

My ELK 6.3.1 working well logs indexed to elasticsearch and these logs are vailable in kibana.

Then i am added this line in elasticsearch.yml as last line

xpack.security.enabled: true

Then tried to create passwords for ELK

./bin/elasticsearch-setup-passwords interactive

Then error message showing

[elastic@localhost elasticsearch-6.3.1]$ ./bin/elasticsearch-setup-passwords interactive

Unexpected response code [403] from calling GET [http://192.168.1.15:9200/\_xpack/security/\_authenticate?pretty](http://192.168.1.15:9200/_xpack/security/_authenticate?pretty)  
It doesn't look like the X-Pack security feature is available on this Elasticsearch node.  
Please check if you have installed a license that allows access to X-Pack Security feature.

---

<div class="post-metadata">

**Author:** ![rijinmp](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/rijinmp/32/24634_2.png) [@rijinmp](https://discuss.elastic.co/u/rijinmp)\
**Post date:** [July 21, 2018, 3:55pm UTC](https://discuss.elastic.co/t/elasticsearch-6-3-1-xpack-password-enabling-shows-error/140999/2 "2018-07-21T15:55:10Z")

</div>

Hi It is solved.

In kibana Management-\> License Management -\> Trail licence selected and enabled.

After that tried this command : ./bin/elasticsearch-setup-passwords interactive

Then its worked and created passwords for ELK

🙂

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [August 18, 2018, 4:05pm UTC](https://discuss.elastic.co/t/elasticsearch-6-3-1-xpack-password-enabling-shows-error/140999/3 "2018-08-18T16:05:29Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
