# ElasticSearch 6.3.2 Could not create JVM when start

**URL:** <https://discuss.elastic.co/t/elasticsearch-6-3-2-could-not-create-jvm-when-start/144856>\
**Category:** Elasticsearch\
**Created:** [August 17, 2018, 8:59am UTC](https://discuss.elastic.co/t/elasticsearch-6-3-2-could-not-create-jvm-when-start/144856 "2018-08-17T08:59:35Z")\
**Posts on this page:** 3\
**Page:** 1

<div class="post-metadata">

**Author:** ![zhuzixiao](https://avatars.discourse-cdn.com/v4/letter/z/9e8a1a/32.png) [@zhuzixiao](https://discuss.elastic.co/u/zhuzixiao)\
**Post date:** [August 17, 2018, 8:59am UTC](https://discuss.elastic.co/t/elasticsearch-6-3-2-could-not-create-jvm-when-start/144856/1 "2018-08-17T08:59:35Z")

</div>

I have just installed elastic search 6.3.2 on my win 10 pc from msi package. But when I tried to start the elasticsearch.exe in the command line, I was promted some issues related to JVM version.

The error messages are:

```
Java HotSpot(TM) 64-Bit Server VM warning: Option UseConcMarkSweepGC was deprecated in version 9.0 and will likely be removed in a future release.
Invalid -Xlog option '-Xlog:gc*,gc+age=trace,safepoint:file=logs/gc.log:utctime,pid,tags:filecount=32,filesize=64m'
[0.003sError: Could not create the Java Virtual Machine.
]Error: A fatal exception has occurred. Program will exit.

[error][logging] [] Error opening log file 'logs/gc.log': No such file or directory

```

I found there is a similar issue: [Setting up elasticsearch 6.0.1](https://discuss.elastic.co/t/setting-up-elasticsearch-6-0-1/111280)

But it is said that elastic 6.0+ could support java 10. ([https://www.elastic.co/guide/en/elasticsearch/reference/current/setup.html](https://www.elastic.co/guide/en/elasticsearch/reference/current/setup.html) )

Also I have tried to download the zip installation package. When run the elasticsearch.bat, I also got the deprecated warning message, but the engine is started successfully.

```
D:\Software\elasticsearch-6.3.2\bin>elasticsearch.bat
Java HotSpot(TM) 64-Bit Server VM warning: Option UseConcMarkSweepGC was deprecated in version 9.0 and will likely be removed in a future release.
[2018-08-17T16:55:29,761][INFO][o.e.n.Node] [ZHUZIXIAO-IBM] initializing ...
[2018-08-17T16:55:29,828][INFO][o.e.e.NodeEnvironment] [ZHUZIXIAO-IBM] using [1] data paths, mounts [[Windows (C:)]], net usable_space [8.2gb], net total_space [80gb], types [NTFS]
[2018-08-17T16:55:29,829][INFO][o.e.e.NodeEnvironment] [ZHUZIXIAO-IBM] heap size [1.9gb], compressed ordinary object pointers [true]

```

It seems a little awkard to me. Could anyone please help me with this problem?

Thanks very much!

=======

**Update:**

ElasticSearch can run properly after I installed java 8u181. So is it still a version incompatible issue?

---

<div class="post-metadata">

**Author:** ![warkolm](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/warkolm/32/39224_2.png) [@warkolm](https://discuss.elastic.co/u/warkolm)\
**Post date:** [August 17, 2018, 10:23am UTC](https://discuss.elastic.co/t/elasticsearch-6-3-2-could-not-create-jvm-when-start/144856/2 "2018-08-17T10:23:51Z")

</div>

That should work between the JVM + Elasticsearch versions - [https://www.elastic.co/support/matrix#matrix\_jvm](https://www.elastic.co/support/matrix#matrix_jvm)

But we don't explicitly support Windows 10 sorry to say.

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [September 14, 2018, 10:23am UTC](https://discuss.elastic.co/t/elasticsearch-6-3-2-could-not-create-jvm-when-start/144856/3 "2018-09-14T10:23:53Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
