# Elasticsearch 6.\* still not running on rhel7.5

**URL:** <https://discuss.elastic.co/t/elasticsearch-6-still-not-running-on-rhel7-5/149095>\
**Category:** Elasticsearch\
**Created:** [September 19, 2018, 9:47am UTC](https://discuss.elastic.co/t/elasticsearch-6-still-not-running-on-rhel7-5/149095 "2018-09-19T09:47:29Z")\
**Posts on this page:** 12\
**Page:** 1

<div class="post-metadata">

**Author:** ![adrwer](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/adrwer/32/35629_2.png) [@adrwer](https://discuss.elastic.co/u/adrwer)\
**Post date:** [September 19, 2018, 9:47am UTC](https://discuss.elastic.co/t/elasticsearch-6-still-not-running-on-rhel7-5/149095/1 "2018-09-19T09:47:29Z")

</div>

Blocked by another huddle....I installed Elasticsearch as adviced here:

> [@Elasticsearch refuses to run](https://discuss.elastic.co/t/elasticsearch-refuses-to-run/148945/13):
>
> Also, ideally, you should setup the repo, not just download the RPM. That way you are setup to allow easy upgrades as well.

but it sends this error when i try checking if it runs  
`curl: (7) Failed connect to localhost:9200; Connection refused`

i checked if the service was runnning and i found out that it wasn't so i started it then it sent me this response

```
    ● elasticsearch.service - Elasticsearch
       Loaded: loaded (/usr/lib/systemd/system/elasticsearch.service; enabled; vendor preset: disabled)
       Active: active (running) since Wed 2018-09-19 07:21:43 UTC; 32s ago
         Docs: http://www.elastic.co
     Main PID: 5798 (java)
       CGroup: /system.slice/elasticsearch.service
               └─5798 /bin/java -Xms512m -Xmx512m -XX:+UseConcMarkSweepGC -XX:CMSInitiatingOccupancyFraction=75 -XX:+UseCMSInitiatingOccupancyOnly -XX:+AlwaysPreTouch -Xss1m -Djava.awt.headl...

    Sep 19 07:21:43 ip-172-31-7-139.us-east-2.compute.internal systemd[1]: Started Elasticsearch.
    Sep 19 07:21:43 ip-172-31-7-139.us-east-2.compute.internal systemd[1]: Starting Elasticsearch...

```

but on trying to test the Elasticsearch node it still sent me this error  
`curl: (7) Failed connect to localhost:9200; Connection refused`  
and on checking the status of the service, this is what it said

```
● elasticsearch.service - Elasticsearch
   Loaded: loaded (/usr/lib/systemd/system/elasticsearch.service; enabled; vendor preset: disabled)
   Active: failed (Result: signal) since Wed 2018-09-19 07:23:52 UTC; 9s ago
     Docs: http://www.elastic.co
  Process: 5798 ExecStart=/usr/share/elasticsearch/bin/elasticsearch -p ${PID_DIR}/elasticsearch.pid --quiet (code=killed, signal=KILL)
 Main PID: 5798 (code=killed, signal=KILL)

Sep 19 07:21:43 ip-172-31-7-139.us-east-2.compute.internal systemd[1]: Started Elasticsearch.
Sep 19 07:21:43 ip-172-31-7-139.us-east-2.compute.internal systemd[1]: Starting Elasticsearch...
Sep 19 07:23:52 ip-172-31-7-139.us-east-2.compute.internal systemd[1]: elasticsearch.service: main process exited, code=killed, status=9/KILL
Sep 19 07:23:52 ip-172-31-7-139.us-east-2.compute.internal systemd[1]: Unit elasticsearch.service entered failed state.
Sep 19 07:23:52 ip-172-31-7-139.us-east-2.compute.internal systemd[1]: elasticsearch.service failed.

```

Please help

---

<div class="post-metadata">

**Author:** ![Christian\_Dahlqvist](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/christian_dahlqvist/32/4617_2.png) [@Christian\_Dahlqvist](https://discuss.elastic.co/u/Christian_Dahlqvist)\
**Post date:** [September 19, 2018, 9:48am UTC](https://discuss.elastic.co/t/elasticsearch-6-still-not-running-on-rhel7-5/149095/2 "2018-09-19T09:48:52Z")

</div>

What is in the the Elasticsearch logs?

---

<div class="post-metadata">

**Author:** ![adrwer](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/adrwer/32/35629_2.png) [@adrwer](https://discuss.elastic.co/u/adrwer)\
**Post date:** [September 19, 2018, 9:50am UTC](https://discuss.elastic.co/t/elasticsearch-6-still-not-running-on-rhel7-5/149095/3 "2018-09-19T09:50:26Z")

</div>

I checked `/var/log/elasticsearch` but there are no logs

---

<div class="post-metadata">

**Author:** ![adrwer](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/adrwer/32/35629_2.png) [@adrwer](https://discuss.elastic.co/u/adrwer)\
**Post date:** [September 19, 2018, 9:51am UTC](https://discuss.elastic.co/t/elasticsearch-6-still-not-running-on-rhel7-5/149095/4 "2018-09-19T09:51:36Z")

</div>

this is the only file that is there: `gc.log.0.current`

---

<div class="post-metadata">

**Author:** ![Christian\_Dahlqvist](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/christian_dahlqvist/32/4617_2.png) [@Christian\_Dahlqvist](https://discuss.elastic.co/u/Christian_Dahlqvist)\
**Post date:** [September 19, 2018, 9:56am UTC](https://discuss.elastic.co/t/elasticsearch-6-still-not-running-on-rhel7-5/149095/5 "2018-09-19T09:56:08Z")

</div>

How much RAM do you have on the host? Do you have anything else running on it?

---

<div class="post-metadata">

**Author:** ![adrwer](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/adrwer/32/35629_2.png) [@adrwer](https://discuss.elastic.co/u/adrwer)\
**Post date:** [September 19, 2018, 9:58am UTC](https://discuss.elastic.co/t/elasticsearch-6-still-not-running-on-rhel7-5/149095/6 "2018-09-19T09:58:11Z")

</div>

I have 1Gb RAM and 10Gb Volume. I have the LAMP stack running of it too.

I reduced the heap size to 512Mbs though!🤷‍♂️

---

<div class="post-metadata">

**Author:** ![Christian\_Dahlqvist](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/christian_dahlqvist/32/4617_2.png) [@Christian\_Dahlqvist](https://discuss.elastic.co/u/Christian_Dahlqvist)\
**Post date:** [September 19, 2018, 10:04am UTC](https://discuss.elastic.co/t/elasticsearch-6-still-not-running-on-rhel7-5/149095/7 "2018-09-19T10:04:28Z")

</div>

Elasticsearch also requires off-heap storage, so you may need to reduce it even more. I am however not sure what the minimum heap size is to get it to work. How much free RAM do you have when the LAMP stack is running?

---

<div class="post-metadata">

**Author:** ![adrwer](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/adrwer/32/35629_2.png) [@adrwer](https://discuss.elastic.co/u/adrwer)\
**Post date:** [September 19, 2018, 10:11am UTC](https://discuss.elastic.co/t/elasticsearch-6-still-not-running-on-rhel7-5/149095/8 "2018-09-19T10:11:10Z")

</div>

552Mbs free and 533Mbs available

---

<div class="post-metadata">

**Author:** ![Christian\_Dahlqvist](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/christian_dahlqvist/32/4617_2.png) [@Christian\_Dahlqvist](https://discuss.elastic.co/u/Christian_Dahlqvist)\
**Post date:** [September 19, 2018, 10:13am UTC](https://discuss.elastic.co/t/elasticsearch-6-still-not-running-on-rhel7-5/149095/9 "2018-09-19T10:13:19Z")

</div>

That is unlikely to be enough due to the off-heap storage, so you will either need to reduce heap further (not sure how useful a node with that little heap will be), add RAM or install Elasticsearch on a separate host.

---

<div class="post-metadata">

**Author:** ![adrwer](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/adrwer/32/35629_2.png) [@adrwer](https://discuss.elastic.co/u/adrwer)\
**Post date:** [September 19, 2018, 10:19am UTC](https://discuss.elastic.co/t/elasticsearch-6-still-not-running-on-rhel7-5/149095/10 "2018-09-19T10:19:06Z")

</div>

Will weigh my options. Thanks Christian.

---

<div class="post-metadata">

**Author:** ![adrwer](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/adrwer/32/35629_2.png) [@adrwer](https://discuss.elastic.co/u/adrwer)\
**Post date:** [September 19, 2018, 12:10pm UTC](https://discuss.elastic.co/t/elasticsearch-6-still-not-running-on-rhel7-5/149095/11 "2018-09-19T12:10:47Z")

</div>

Reduced my heap size to 256Mbs. It works now.

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [October 17, 2018, 12:10pm UTC](https://discuss.elastic.co/t/elasticsearch-6-still-not-running-on-rhel7-5/149095/12 "2018-10-17T12:10:52Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
