# Elasticsearch 7.3.0 Enable Security - Windows System

**URL:** https://discuss.elastic.co/t/elasticsearch-7-3-0-enable-security-windows-system/194206
**Category:** Elasticsearch
**Created:** [August 7, 2019, 10:07am UTC](https://discuss.elastic.co/t/elasticsearch-7-3-0-enable-security-windows-system/194206 "2019-08-07T10:07:45Z")
**Posts on this page:** 2
**Page:** 1

<div class="post-metadata">

### Author: ![pramod.kumar2](https://avatars.discourse-cdn.com/v4/letter/p/977dab/32.png) [@pramod.kumar2](https://discuss.elastic.co/u/pramod.kumar2)
#### Post date: [August 7, 2019, 10:07am UTC](https://discuss.elastic.co/t/elasticsearch-7-3-0-enable-security-windows-system/194206/1 "2019-08-07T10:07:45Z")

</div>

Hi Team,

I have installed Elasticsearch 7.3.0 on windows machine. And I am able to use elastic url using IP. Below are configuration which I have used -

cluster.name: "my-app"  
node.name: "master\_node"  
network.host: 192.168.2.106  
http.port: 9202  
node.master: true  
node.data: true  
node.ingest: false  
cluster.initial\_master\_nodes: ["master\_node"]  
discovery.zen.ping.unicast.hosts: ["192.168.2.106", "127.0.0.1"]  
reindex.remote.whitelist: "localhost:_,192.168.2.106:_"

Now I want to enable basic username/password authentication. For that I have added below lines in yml file -

xpack.security.enabled: true  
xpack.security.transport.ssl.enabled: true

But now when I am trying to hit elastic, then it is asking me for entering username and password. I tried default username as per the document available on elastic site -

\_es\_anonymous\_user

but not able to either login and/or create user.

I also tried to set passwords using below command -

bin\> elasticsearch-setup-passwords interactive

But this also fails with below error -

Enter password for [elastic]:  
Reenter password for [elastic]:  
Enter password for [apm\_system]:  
Reenter password for [apm\_system]:  
Enter password for [kibana]:  
Reenter password for [kibana]:  
Enter password for [logstash\_system]:  
Reenter password for [logstash\_system]:  
Enter password for [beats\_system]:  
Reenter password for [beats\_system]:  
Enter password for [remote\_monitoring\_user]:  
Reenter password for [remote\_monitoring\_user]:  
Passwords do not match.  
Try again.  
Enter password for [remote\_monitoring\_user]:  
Reenter password for [remote\_monitoring\_user]:

**Connection failure to: [http://192.168.2.106:9202/\_security/user/apm\_system/\_password?pretty](http://192.168.2.106:9202/_security/user/apm_system/_password?pretty) failed: Read timed out**

**ERROR: Failed to set password for user [apm\_system].**

Can anyone please help me to figure it out what step i need to follow to enable security in elasticsearch?

---

<div class="post-metadata">

### Author: ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)
#### Post date: [September 4, 2019, 10:07am UTC](https://discuss.elastic.co/t/elasticsearch-7-3-0-enable-security-windows-system/194206/2 "2019-09-04T10:07:53Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
