# Elasticsearch(7.5) error of Connection refused when curl http request with real IP address

**URL:** <https://discuss.elastic.co/t/elasticsearch-7-5-error-of-connection-refused-when-curl-http-request-with-real-ip-address/214948>\
**Category:** Elasticsearch\
**Created:** [January 14, 2020, 8:26am UTC](https://discuss.elastic.co/t/elasticsearch-7-5-error-of-connection-refused-when-curl-http-request-with-real-ip-address/214948 "2020-01-14T08:26:34Z")\
**Posts on this page:** 4\
**Page:** 1

<div class="post-metadata">

**Author:** ![longfei.li](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/longfei.li/32/60757_2.png) [@longfei.li](https://discuss.elastic.co/u/longfei.li)\
**Post date:** [January 14, 2020, 8:26am UTC](https://discuss.elastic.co/t/elasticsearch-7-5-error-of-connection-refused-when-curl-http-request-with-real-ip-address/214948/1 "2020-01-14T08:26:34Z")

</div>

After installing the elasticserach(7.5) on ubuntu 18.04 successfully, I try to send the curl request but get error message.  
|- curl [http://10.13.2.111:9200](http://10.13.2.111:9200)  
curl: (7) Failed to connect to 10.13.2.111 port 9200: Connection refused

It does work when I send the command with localhost.  
|- curl localost:9200

How can I fix this issue?

The elasticsearch config file is shown as below:

# =========== Elasticsearch Configuration =========================

# 

# NOTE: Elasticsearch comes with reasonable defaults for most settings.

# Before you set out to tweak and tune the configuration, make sure you

# understand what are you trying to accomplish and the consequences.

# 

# The primary way of configuring a node is via this file. This template lists

# the most important settings you may want to configure for a production cluster.

# 

# Please consult the documentation for further information on configuration options:

# [https://www.elastic.co/guide/en/elasticsearch/reference/index.html](https://www.elastic.co/guide/en/elasticsearch/reference/index.html)

# 

# ---------------------------------- Cluster -----------------------------------

# 

# Use a descriptive name for your cluster:

# 

cluster.name: labcar02

# 

# ------------------------------------ Node ------------------------------------

# 

# Use a descriptive name for the node:

# 

#node.name: node-1

# 

# Add custom attributes to the node:

# 

#node.attr.rack: r1

# 

# ----------------------------------- Paths ------------------------------------

# 

# Path to directory where to store the data (separate multiple locations by comma):

# 

path.data: /var/lib/elasticsearch

# 

# Path to log files:

# 

path.logs: /var/log/elasticsearch

# 

# ----------------------------------- Memory -----------------------------------

# 

# Lock the memory on startup:

# 

#bootstrap.memory\_lock: true

# 

# Make sure that the heap size is set to about half the memory available

# on the system and that the owner of the process is allowed to use this

# limit.

# 

# Elasticsearch performs poorly when the system is swapping the memory.

# 

# ---------------------------------- Network -----------------------------------

# 

# Set the bind address to a specific IP (IPv4 or IPv6):

# 

network.host: 0.0.0.0

# 

# Set a custom port for HTTP:

# 

http.port: 9200

# 

# For more information, consult the network module documentation.

# 

# --------------------------------- Discovery ----------------------------------

# 

# Pass an initial list of hosts to perform discovery when this node is started:

# The default list of hosts is ["127.0.0.1", "[::1]"]

# 

#discovery.seed\_hosts: ["host1", "host2"]

# 

# Bootstrap the cluster using an initial set of master-eligible nodes:

# 

cluster.initial\_master\_nodes: ["node-1", "node-2"]

# 

# For more information, consult the discovery and cluster formation module documentation.

# 

# ---------------------------------- Gateway -----------------------------------

# 

# Block initial recovery after a full cluster restart until N nodes are started:

# 

#gateway.recover\_after\_nodes: 3

# 

# For more information, consult the gateway module documentation.

# 

# ---------------------------------- Various -----------------------------------

# 

# Require explicit names when deleting indices:

# 

#action.destructive\_requires\_name: true  
http.cors.enabled: true  
http.cors.allow-origin: "\*"

---

<div class="post-metadata">

**Author:** ![spinscale](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/spinscale/32/25011_2.png) [@spinscale](https://discuss.elastic.co/u/spinscale)\
**Post date:** [January 14, 2020, 8:33am UTC](https://discuss.elastic.co/t/elasticsearch-7-5-error-of-connection-refused-when-curl-http-request-with-real-ip-address/214948/2 "2020-01-14T08:33:07Z")

</div>

by default elasticsearch is bound to localhost only. If you want to listen to other ip addresses, this needs to be configured.

See [https://www.elastic.co/guide/en/elasticsearch/reference/7.5/modules-network.html](https://www.elastic.co/guide/en/elasticsearch/reference/7.5/modules-network.html)

---

<div class="post-metadata">

**Author:** ![longfei.li](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/longfei.li/32/60757_2.png) [@longfei.li](https://discuss.elastic.co/u/longfei.li)\
**Post date:** [January 14, 2020, 9:00am UTC](https://discuss.elastic.co/t/elasticsearch-7-5-error-of-connection-refused-when-curl-http-request-with-real-ip-address/214948/3 "2020-01-14T09:00:14Z")

</div>

Hi Alexander, thanks a lot for your quick reply. I have fixed this issue according to the elasticsearch reference. Thanks again.

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [February 11, 2020, 9:00am UTC](https://discuss.elastic.co/t/elasticsearch-7-5-error-of-connection-refused-when-curl-http-request-with-real-ip-address/214948/4 "2020-02-11T09:00:19Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
