# Elasticsearch 7.9.3 fail to start

**URL:** <https://discuss.elastic.co/t/elasticsearch-7-9-3-fail-to-start/269463>\
**Category:** Elasticsearch\
**Created:** [April 7, 2021, 12:39pm UTC](https://discuss.elastic.co/t/elasticsearch-7-9-3-fail-to-start/269463 "2021-04-07T12:39:12Z")\
**Posts on this page:** 3\
**Page:** 1

<div class="post-metadata">

**Author:** ![FOMihai](https://avatars.discourse-cdn.com/v4/letter/f/43a26b/32.png) [@FOMihai](https://discuss.elastic.co/u/FOMihai)\
**Post date:** [April 7, 2021, 12:39pm UTC](https://discuss.elastic.co/t/elasticsearch-7-9-3-fail-to-start/269463/1 "2021-04-07T12:39:12Z")

</div>

Hello,

I'm trying to install Elasticsearch 7.9.3 but when I'm trying to start elasticsearch I get this error:

```auto
[2021-04-07T14:31:59,501][ERROR][o.e.b.Bootstrap] [node-inopvdn23i] Exception
java.lang.IllegalStateException: node does not have the data and master roles but has index metadata: [/data/dnc/data/nodes/0/indices/bU9mQ2ZmRB2oO9dEhOJGEA/_state, /data/dnc/data/nodes/0/indices/t3VRAgcrSWuMooXEqFukWw/_state, /data/dnc/data/nodes/0/indices/IKJWh65wQ4aKD9K6Qpv-CQ/_state, /data/dnc/data/nodes/0/indices/B3aG8wRuSdmWAOxupDpsLQ/_state, /data/dnc/data/nodes/0/indices/eQdNiKiOQvatGe6dCAiAFw/_state, /data/dnc/data/nodes/0/indices/SYGpzWynRnezeW5zebmXCA/_state, /data/dnc/data/nodes/0/indices/0pies4NwTraTulYup98SRQ/_state, /data/dnc/data/nodes/0/indices/hZsJSbYeR2CvshqUnTeLkQ/_state, /data/dnc/data/nodes/0/indices/yF-Jk4G3Tp6PUX6c7F5r9w/_state, /data/dnc/data/nodes/0/indices/SnjN7XMgSMCgL0ZZ4RfAZg/_state, /data/dnc/data/nodes/0/indices/ur6vvaraR22Zo1OeGuOd0g/_state, /data/dnc/data/nodes/0/indices/kfy7RjZ1SJKKDjvpqRrzmw/_state, /data/dnc/data/nodes/0/indices/quuTzp3rS-ONOh3TtvcVSg/_state, /data/dnc/data/nodes/0/indices/Oj7r8xGPQ7e6qh-6oSSeNw/_state, /data/dnc/data/nodes/0/indices/oq8KE-fYT2u4jPM7t2xwvw/_state, /data/dnc/data/nodes/0/indices/on_EhE6vS8SP6BLHkviGVw/_state, /data/dnc/data/nodes/0/indices/ujDZX9UsSiWbq60x9loDMQ/_state]. Use 'elasticsearch-node repurpose' tool to clean up
        at org.elasticsearch.env.NodeEnvironment.ensureNoIndexMetadata(NodeEnvironment.java:1093) ~[elasticsearch-7.9.3.jar:7.9.3]
        at org.elasticsearch.env.NodeEnvironment.<init>(NodeEnvironment.java:323) ~[elasticsearch-7.9.3.jar:7.9.3]
        at org.elasticsearch.node.Node.<init>(Node.java:344) ~[elasticsearch-7.9.3.jar:7.9.3]
        at org.elasticsearch.node.Node.<init>(Node.java:277) ~[elasticsearch-7.9.3.jar:7.9.3]
        at org.elasticsearch.bootstrap.Bootstrap$5.<init>(Bootstrap.java:227) ~[elasticsearch-7.9.3.jar:7.9.3]
        at org.elasticsearch.bootstrap.Bootstrap.setup(Bootstrap.java:227) ~[elasticsearch-7.9.3.jar:7.9.3]
        at org.elasticsearch.bootstrap.Bootstrap.init(Bootstrap.java:393) [elasticsearch-7.9.3.jar:7.9.3]
        at org.elasticsearch.bootstrap.Elasticsearch.init(Elasticsearch.java:170) [elasticsearch-7.9.3.jar:7.9.3]
        at org.elasticsearch.bootstrap.Elasticsearch.execute(Elasticsearch.java:161) [elasticsearch-7.9.3.jar:7.9.3]
        at org.elasticsearch.cli.EnvironmentAwareCommand.execute(EnvironmentAwareCommand.java:86) [elasticsearch-7.9.3.jar:7.9.3]
        at org.elasticsearch.cli.Command.mainWithoutErrorHandling(Command.java:127) [elasticsearch-cli-7.9.3.jar:7.9.3]
        at org.elasticsearch.cli.Command.main(Command.java:90) [elasticsearch-cli-7.9.3.jar:7.9.3]
        at org.elasticsearch.bootstrap.Elasticsearch.main(Elasticsearch.java:126) [elasticsearch-7.9.3.jar:7.9.3]
        at org.elasticsearch.bootstrap.Elasticsearch.main(Elasticsearch.java:92) [elasticsearch-7.9.3.jar:7.9.3]

```

Can someone help me debug this issue?  
DO you know if this path should be clear **/data/dnc/data** /nodes/0/indices before I install the elasticsearch (I have some old files that are from the other elasticsearch version, maybe I have to clear the /data path in and install it again)?  
**I mention that on this path /data/dnc/ was another elasticsearch version running but I wanted to uninstall it and try to install here version 7.9.3**

---

<div class="post-metadata">

**Author:** ![warkolm](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/warkolm/32/39224_2.png) [@warkolm](https://discuss.elastic.co/u/warkolm)\
**Post date:** [April 7, 2021, 10:07pm UTC](https://discuss.elastic.co/t/elasticsearch-7-9-3-fail-to-start/269463/2 "2021-04-07T22:07:26Z")

</div>

> [@FOMihai](#):
>
> DO you know if this path should be clear **/data/dnc/data** /nodes/0/indices before I install the elasticsearch

Yes it does.

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [May 5, 2021, 10:07pm UTC](https://discuss.elastic.co/t/elasticsearch-7-9-3-fail-to-start/269463/3 "2021-05-05T22:07:47Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
