# ElasticSearch 7 start up error - the default discovery settings are unsuitable for production use

**URL:** <https://discuss.elastic.co/t/elasticsearch-7-start-up-error-the-default-discovery-settings-are-unsuitable-for-production-use/249222>\
**Category:** Elasticsearch\
**Created:** [September 19, 2020, 7:26pm UTC](https://discuss.elastic.co/t/elasticsearch-7-start-up-error-the-default-discovery-settings-are-unsuitable-for-production-use/249222 "2020-09-19T19:26:07Z")\
**Posts on this page:** 5\
**Page:** 1

<div class="post-metadata">

**Author:** ![linfordwoode](https://avatars.discourse-cdn.com/v4/letter/l/5fc32e/32.png) [@linfordwoode](https://discuss.elastic.co/u/linfordwoode)\
**Post date:** [September 19, 2020, 7:26pm UTC](https://discuss.elastic.co/t/elasticsearch-7-start-up-error-the-default-discovery-settings-are-unsuitable-for-production-use/249222/1 "2020-09-19T19:26:08Z")

</div>

```auto
I am having this issue( the default discovery settings are unsuitable for production use: at least one of [discovery.seed_hosts, discovery.seed_providers, cluster.initial_master_nodes] must be configured) with my Elasticsearch. 
I did some googling and found a solution to add the node in the discovery.seed_hosts in the Elasticsearch.yml
The solution worked for a short time an it started happening again. 
I had it set up as this discovery.seed_hosts: ["n1"] since I am using only a single node. 

Is there anything I am missing? Kindly help?
Thanks

```

---

<div class="post-metadata">

**Author:** ![DavidTurner](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/davidturner/32/22453_2.png) [@DavidTurner](https://discuss.elastic.co/u/DavidTurner)\
**Post date:** [September 20, 2020, 7:39am UTC](https://discuss.elastic.co/t/elasticsearch-7-start-up-error-the-default-discovery-settings-are-unsuitable-for-production-use/249222/2 "2020-09-20T07:39:51Z")

</div>

> [@linfordwoode](#):
>
> found a solution to add the node in the `discovery.seed_hosts` in the `elasticsearch.yml`

That sounds right to me. If you're seeing this message then `discovery.seed_hosts` is not set, and the solution is to set it.

---

<div class="post-metadata">

**Author:** ![warkolm](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/warkolm/32/39224_2.png) [@warkolm](https://discuss.elastic.co/u/warkolm)\
**Post date:** [September 20, 2020, 9:52pm UTC](https://discuss.elastic.co/t/elasticsearch-7-start-up-error-the-default-discovery-settings-are-unsuitable-for-production-use/249222/3 "2020-09-20T21:52:47Z")

</div>

Welcome to our community! 😃  
FYI your post is quite difficult to read with that formatting, you may want to consider editing it to make it easier to read, as that will help others help you.

---

<div class="post-metadata">

**Author:** ![linfordwoode](https://avatars.discourse-cdn.com/v4/letter/l/5fc32e/32.png) [@linfordwoode](https://discuss.elastic.co/u/linfordwoode)\
**Post date:** [September 23, 2020, 1:07am UTC](https://discuss.elastic.co/t/elasticsearch-7-start-up-error-the-default-discovery-settings-are-unsuitable-for-production-use/249222/4 "2020-09-23T01:07:40Z")

</div>

Issue solved. Thanks

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [October 21, 2020, 1:07am UTC](https://discuss.elastic.co/t/elasticsearch-7-start-up-error-the-default-discovery-settings-are-unsuitable-for-production-use/249222/5 "2020-10-21T01:07:41Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
