# Elasticsearch 8.2.0 doesn't start in centos 8

**URL:** <https://discuss.elastic.co/t/elasticsearch-8-2-0-doesnt-start-in-centos-8/329322>\
**Category:** Elasticsearch\
**Created:** [April 4, 2023, 1:00pm UTC](https://discuss.elastic.co/t/elasticsearch-8-2-0-doesnt-start-in-centos-8/329322 "2023-04-04T13:00:41Z")\
**Posts on this page:** 4\
**Page:** 1

<div class="post-metadata">

**Author:** ![dhrchatt](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/dhrchatt/32/46374_2.png) [@dhrchatt](https://discuss.elastic.co/u/dhrchatt)\
**Post date:** [April 4, 2023, 1:00pm UTC](https://discuss.elastic.co/t/elasticsearch-8-2-0-doesnt-start-in-centos-8/329322/1 "2023-04-04T13:00:41Z")

</div>

When I start elasticsearch-8.2.0 version in Linux Centos8, it is giving following error:

```auto
0.000s][warning][os,container] Duplicate cpuset controllers detected. Picking /sys/fs/cgroup/cpuset, skipping /scratch/chroot/OL_70_x86_64/sys/fs/cgroup/cpuset.
[0.001s][warning][os,container] Duplicate cpuset controllers detected. Picking /sys/fs/cgroup/cpuset, skipping /scratch/chroot/OL_70_x86_64/sys/fs/cgroup/cpuset.
[0.000s][warning][os,container] Duplicate cpuset controllers detected. Picking /sys/fs/cgroup/cpuset, skipping /scratch/chroot/OL_70_x86_64/sys/fs/cgroup/cpuset.
Error: Could not find or load main class [0.000s][warning][os,container]
Caused by: java.lang.ClassNotFoundException: [0/000s][warning][os,container]

```

...  
I see the warning about duplicate cpuset but file system is read-only, so cannot modify anything there. I ran fine with same warning for elasticsearch-7.17.9.

Is there a workaround for this issue, so that I can use 8.2.0 ?

---

<div class="post-metadata">

**Author:** ![warkolm](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/warkolm/32/39224_2.png) [@warkolm](https://discuss.elastic.co/u/warkolm)\
**Post date:** [April 4, 2023, 10:03pm UTC](https://discuss.elastic.co/t/elasticsearch-8-2-0-doesnt-start-in-centos-8/329322/2 "2023-04-04T22:03:10Z")

</div>

What do the Elasticsearch lots show?

---

<div class="post-metadata">

**Author:** ![dhrchatt](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/dhrchatt/32/46374_2.png) [@dhrchatt](https://discuss.elastic.co/u/dhrchatt)\
**Post date:** [April 5, 2023, 3:30pm UTC](https://discuss.elastic.co/t/elasticsearch-8-2-0-doesnt-start-in-centos-8/329322/3 "2023-04-05T15:30:53Z")

</div>

There us no logs generated in logs folder except gc.log file which doesn't have any error message. I found a solution to this in another post which says:

```auto
This issue has been resolved. If anyone might run into this as well, the problem was identified to be multiple mounts of the /sys/fs/cgroup folder. Done both in the build and execution phase, removing it from either resolves this issue!

```

But these file systems are readonly for me. So, is there any other solution for this issue ?

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [May 3, 2023, 3:31pm UTC](https://discuss.elastic.co/t/elasticsearch-8-2-0-doesnt-start-in-centos-8/329322/4 "2023-05-03T15:31:50Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
