# Elasticsearch:8.5.2 docker "access denied (\\"java.lang.RuntimePermission\\" \\"modifyThread\\")"

**URL:** <https://discuss.elastic.co/t/elasticsearch-8-5-2-docker-access-denied-java-lang-runtimepermission-modifythread/320409>\
**Category:** Elasticsearch\
**Tags:** docker\
**Created:** [December 3, 2022, 9:26am UTC](https://discuss.elastic.co/t/elasticsearch-8-5-2-docker-access-denied-java-lang-runtimepermission-modifythread/320409 "2022-12-03T09:26:28Z")\
**Posts on this page:** 8\
**Page:** 1

<div class="post-metadata">

**Author:** ![khteh](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/khteh/32/147573_2.png) [@khteh](https://discuss.elastic.co/u/khteh)\
**Post date:** [December 3, 2022, 9:26am UTC](https://discuss.elastic.co/t/elasticsearch-8-5-2-docker-access-denied-java-lang-runtimepermission-modifythread/320409/1 "2022-12-03T09:26:28Z")

</div>

{"@timestamp":"2022-12-03T09:13:59.279Z", "log.level":"ERROR", "message":"uncaught exception in thread [process reaper (pid 117)]", "ecs.version": "1.2.0","service.name":"ES\_ECS","event.dataset":"elasticsearch.server","process.thread.name":"process reaper (pid 117)","log.logger":"org.elasticsearch.bootstrap.ElasticsearchUncaughtExceptionHandler","elasticsearch.node.name":"elasticsearch-master-0","error.type":"java.security.AccessControlException","error.message":"access denied ("java.lang.RuntimePermission" "modifyThread")","error.stack\_trace":"java.security.AccessControlException: access denied ("java.lang.RuntimePermission" "modifyThread")\n\tat java.base/java.security.AccessControlContext.checkPermission(AccessControlContext.java:485)\n\tat java.base/java.security.AccessController.checkPermission(AccessController.java:1068)\n\tat java.base/java.lang.SecurityManager.checkPermission(SecurityManager.java:411)\n\tat org.elasticsearch.securesm@8.5.2/org.elasticsearch.secure\_sm.SecureSM.checkThreadAccess(SecureSM.java:166)\n\tat org.elasticsearch.securesm@8.5.2/org.elasticsearch.secure\_sm.SecureSM.checkAccess(SecureSM.java:120)\n\tat java.base/java.lang.Thread.checkAccess(Thread.java:2360)\n\tat java.base/java.lang.Thread.setDaemon(Thread.java:2308)\n\tat java.base/java.lang.ProcessHandleImpl.lambda$static$0(ProcessHandleImpl.java:103)\n\tat java.base/java.util.concurrent.ThreadPoolExecutor$Worker.(ThreadPoolExecutor.java:637)\n\tat java.base/java.util.concurrent.ThreadPoolExecutor.addWorker(ThreadPoolExecutor.java:928)\n\tat java.base/java.util.concurrent.ThreadPoolExecutor.processWorkerExit(ThreadPoolExecutor.java:1021)\n\tat java.base/java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1158)\n\tat java.base/java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:642)\n\tat java.base/java.lang.Thread.run(Thread.java:1589)\n\tat java.base/jdk.internal.misc.InnocuousThread.run(InnocuousThread.java:186)\n"}

---

<div class="post-metadata">

**Author:** ![DavidTurner](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/davidturner/32/22453_2.png) [@DavidTurner](https://discuss.elastic.co/u/DavidTurner)\
**Post date:** [December 3, 2022, 11:29am UTC](https://discuss.elastic.co/t/elasticsearch-8-5-2-docker-access-denied-java-lang-runtimepermission-modifythread/320409/2 "2022-12-03T11:29:19Z")

</div>

This is just log noise, fixed by [https://github.com/elastic/elasticsearch/pull/91704](https://github.com/elastic/elasticsearch/pull/91704) in 8.5.3. Please upgrade.

---

<div class="post-metadata">

**Author:** ![khteh](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/khteh/32/147573_2.png) [@khteh](https://discuss.elastic.co/u/khteh)\
**Post date:** [December 4, 2022, 4:44am UTC](https://discuss.elastic.co/t/elasticsearch-8-5-2-docker-access-denied-java-lang-runtimepermission-modifythread/320409/3 "2022-12-04T04:44:54Z")

</div>

manifest for elasticsearch:8.5.3 not found: manifest unknown: manifest unknown

---

<div class="post-metadata">

**Author:** ![elasticforme](https://avatars.discourse-cdn.com/v4/letter/e/f05b48/32.png) [@elasticforme](https://discuss.elastic.co/u/elasticforme)\
**Post date:** [December 6, 2022, 2:12am UTC](https://discuss.elastic.co/t/elasticsearch-8-5-2-docker-access-denied-java-lang-runtimepermission-modifythread/320409/4 "2022-12-06T02:12:39Z")

</div>

how do you download 8.5.3?

my cluster is stuck as I try to upgrade it to 8.5.2 and won't start with this error

---

<div class="post-metadata">

**Author:** ![DavidTurner](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/davidturner/32/22453_2.png) [@DavidTurner](https://discuss.elastic.co/u/DavidTurner)\
**Post date:** [December 6, 2022, 12:55pm UTC](https://discuss.elastic.co/t/elasticsearch-8-5-2-docker-access-denied-java-lang-runtimepermission-modifythread/320409/5 "2022-12-06T12:55:35Z")

</div>

Apologies, my message was unclear. 8.5.3 is not yet released, but when it is you should upgrade. Until then, this is just log noise and you can ignore it.

> won't start with this error

Look for other messages that explain why the node isn't starting.

---

<div class="post-metadata">

**Author:** ![elasticforme](https://avatars.discourse-cdn.com/v4/letter/e/f05b48/32.png) [@elasticforme](https://discuss.elastic.co/u/elasticforme)\
**Post date:** [December 6, 2022, 1:22pm UTC](https://discuss.elastic.co/t/elasticsearch-8-5-2-docker-access-denied-java-lang-runtimepermission-modifythread/320409/6 "2022-12-06T13:22:54Z")

</div>

ohhh ok. I thought this is the error. still can't figure out why it won't start. let me check other places

---

<div class="post-metadata">

**Author:** ![khteh](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/khteh/32/147573_2.png) [@khteh](https://discuss.elastic.co/u/khteh)\
**Post date:** [December 7, 2022, 3:16am UTC](https://discuss.elastic.co/t/elasticsearch-8-5-2-docker-access-denied-java-lang-runtimepermission-modifythread/320409/7 "2022-12-07T03:16:20Z")

</div>

No other error except [Elasticsearch docker container 8.5.2 startup ERROR: Elasticsearch did not exit normally](https://discuss.elastic.co/t/elasticsearch-docker-container-8-5-2-startup-error-elasticsearch-did-not-exit-normally/320634)

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [January 4, 2023, 3:16am UTC](https://discuss.elastic.co/t/elasticsearch-8-5-2-docker-access-denied-java-lang-runtimepermission-modifythread/320409/8 "2023-01-04T03:16:53Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
