# Elasticsearch Active-Directory: Native User Authentication Failure

**URL:** <https://discuss.elastic.co/t/elasticsearch-active-directory-native-user-authentication-failure/241010>\
**Category:** Elasticsearch\
**Tags:** elastic-stack-security\
**Created:** [July 13, 2020, 4:20pm UTC](https://discuss.elastic.co/t/elasticsearch-active-directory-native-user-authentication-failure/241010 "2020-07-13T16:20:14Z")\
**Posts on this page:** 4\
**Page:** 1

<div class="post-metadata">

**Author:** ![vishakh](https://avatars.discourse-cdn.com/v4/letter/v/c89c15/32.png) [@vishakh](https://discuss.elastic.co/u/vishakh)\
**Post date:** [July 13, 2020, 4:20pm UTC](https://discuss.elastic.co/t/elasticsearch-active-directory-native-user-authentication-failure/241010/1 "2020-07-13T16:20:14Z")

</div>

Elasticsearch: 7.8  
I'm trying to enable X-Pack Active-Directory Realm authentication along with Native user authentication feature but after the .yml config update/change I'm unable to start the elasticsearch service:  
Below is the error:

```auto
systemd-entrypoint: Caused by: mapping values are not allowed here
systemd-entrypoint: in 'reader', line 49, column 18:
systemd-entrypoint: order: 0
systemd-entrypoint: ^
systemd-entrypoint: at org.yaml.snakeyaml.scanner.ScannerImpl.fetchValue(ScannerImpl.java:870)
systemd: elasticsearch.service: main process exited, code=exited, status=1/FAILURE

```

Below is my X-Pack Config:

```auto
xpack:
  security:
    authc:
      realms:
        active_directory:
          corp_ad:
            order: 0
            domain_name: <Domain-Name>
            follow_referrals: false
            url: ldaps://<AD-Hostname>:636
            bind_dn: <username>
            bind_password: <password>
            ssl:
              certificate_authorities: ["/etc/elasticsearch/certs/ca-cert.pem"]
        native:
          native1
            order: 0

```

Referred this link for configuration: [Native User Authentication](https://www.elastic.co/guide/en/elasticsearch/reference/current/native-realm.html)

Can anyone please review & suggest

---

<div class="post-metadata">

**Author:** ![Yang\_Wang](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/yang_wang/32/48857_2.png) [@Yang\_Wang](https://discuss.elastic.co/u/Yang_Wang)\
**Post date:** [July 14, 2020, 3:21am UTC](https://discuss.elastic.co/t/elasticsearch-active-directory-native-user-authentication-failure/241010/2 "2020-07-14T03:21:57Z")

</div>

I think you missed a colon after `native1`.

---

<div class="post-metadata">

**Author:** ![vishakh](https://avatars.discourse-cdn.com/v4/letter/v/c89c15/32.png) [@vishakh](https://discuss.elastic.co/u/vishakh)\
**Post date:** [July 14, 2020, 3:41am UTC](https://discuss.elastic.co/t/elasticsearch-active-directory-native-user-authentication-failure/241010/3 "2020-07-14T03:41:11Z")

</div>

Actually that was a typo while pasting and editing in the chat/thread. Actual config file has the colon after native1 🙃

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [August 11, 2020, 3:48am UTC](https://discuss.elastic.co/t/elasticsearch-active-directory-native-user-authentication-failure/241010/4 "2020-08-11T03:48:38Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
