# Elasticsearch-analysis-phonetic installs correctly but fails when creating an index

**URL:** <https://discuss.elastic.co/t/elasticsearch-analysis-phonetic-installs-correctly-but-fails-when-creating-an-index/16306>\
**Category:** Elasticsearch\
**Created:** [March 12, 2014, 1:07am UTC](https://discuss.elastic.co/t/elasticsearch-analysis-phonetic-installs-correctly-but-fails-when-creating-an-index/16306 "2014-03-12T01:07:56Z")\
**Posts on this page:** 7\
**Page:** 1

<div class="post-metadata">

**Author:** ![Thiago\_Valverde](https://avatars.discourse-cdn.com/v4/letter/t/e274bd/32.png) [@Thiago\_Valverde](https://discuss.elastic.co/u/Thiago_Valverde)\
**Post date:** [March 12, 2014, 1:07am UTC](https://discuss.elastic.co/t/elasticsearch-analysis-phonetic-installs-correctly-but-fails-when-creating-an-index/16306/1 "2014-03-12T01:07:56Z")

</div>

Plugin installation seems to succeed.

```
[root@host elasticsearch-1.0.1]# bin/plugin -install 

```

elasticsearch/elasticsearch-analysis-phonetic/2.0.0  
-\> Installing elasticsearch/elasticsearch-analysis-phonetic/2.0.0...  
Trying  
[http://download.elasticsearch.org/elasticsearch/elasticsearch-analysis-phonetic/elasticsearch-analysis-phonetic-2.0.0.zip](http://download.elasticsearch.org/elasticsearch/elasticsearch-analysis-phonetic/elasticsearch-analysis-phonetic-2.0.0.zip)...  
Downloading ............................DONE  
Installed elasticsearch/elasticsearch-analysis-phonetic/2.0.0 into  
/root/elasticsearch-1.0.1/plugins/analysis-phonetic  
[root@host elasticsearch-1.0.1]# bin/elasticsearch  
[2014-03-12 00:58:59,782][INFO][node] [Jack  
Kirby] version[1.0.1], pid[6456], build[5c03844/2014-02-25T15:52:53Z]  
[2014-03-12 00:58:59,783][INFO][node] [Jack  
Kirby] initializing ...  
[2014-03-12 00:58:59,817][INFO][plugins] [Jack  
Kirby] loaded [cloud-aws, analysis-phonetic], sites [head]  
[2014-03-12 00:59:04,523][INFO][node] [Jack  
Kirby] initialized  
[2014-03-12 00:59:04,523][INFO][node] [Jack  
Kirby] starting ...  
[2014-03-12 00:59:04,650][INFO][transport] [Jack  
Kirby] bound\_address {inet[/0:0:0:0:0:0:0:0:9300]}, publish\_address  
{inet[/172.31.27.225:9300]}  
[2014-03-12 00:59:07,706][INFO][cluster.service] [Jack  
Kirby] new\_master [Jack  
Kirby][fhpzKNmcRLKc208DuuXRrA][host][inet[/172.31.27.225:9300]], reason:  
zen-disco-join (elected\_as\_master)  
[2014-03-12 00:59:07,762][INFO][discovery] [Jack  
Kirby] elasticsearch/fhpzKNmcRLKc208DuuXRrA  
[2014-03-12 00:59:07,903][INFO][http] [Jack  
Kirby] bound\_address {inet[/0:0:0:0:0:0:0:0:9200]}, publish\_address  
{inet[/172.31.27.225:9200]}  
[2014-03-12 00:59:09,079][INFO][gateway] [Jack  
Kirby] recovered [1] indices into cluster\_state  
[2014-03-12 00:59:09,276][INFO][node] [Jack  
Kirby] started

But attempting to create an index with a phonetic filter yields:

```
400 : {"error":"IndexCreationException[[asdf] failed to create index]; 

```

nested: ElasticsearchIllegalArgumentException[failed to find token filter  
type [phonetic] for [phonetic]]; nested: NoClassSettingsException[Failed to  
load class setting [type] with value [phonetic]]; nested:  
ClassNotFoundException[org.elasticsearch.index.analysis.phonetic.PhoneticTokenFilterFactory];  
","status":400}

With nothing logged to the console. Here's some more information about the  
host:

```
[root@host elasticsearch-1.0.1]# uname -a
Linux host 3.4.73-64.112.amzn1.x86_64 #1 SMP Tue Dec 10 01:50:05 UTC 

```

2013 x86\_64 x86\_64 x86\_64 GNU/Linux  
[root@host elasticsearch-1.0.1]# java -version  
java version "1.7.0\_51"  
OpenJDK Runtime Environment (amzn-2.4.4.1.34.amzn1-x86\_64 u51-b02)  
OpenJDK 64-Bit Server VM (build 24.45-b08, mixed mode)

For some reason, the same steps work on my local workstation:

```
$ uname -a
Darwin Valverde.local 13.1.0 Darwin Kernel Version 13.1.0: Thu Jan 16 

```

19:40:37 PST 2014; root:xnu-2422.90.20~2/RELEASE\_X86\_64 x86\_64  
$ java -version  
java version "1.6.0\_65"  
Java(TM) SE Runtime Environment (build 1.6.0\_65-b14-462-11M4609)  
Java HotSpot(TM) 64-Bit Server VM (build 20.65-b04-462, mixed mode)

I have tried OpenJDK 6 and 7, Oracle JDK 7, ElasticSearch 1.0.0 and 1.0.1.  
None of those worked on the server. Any help is appreciated.

--  
You received this message because you are subscribed to the Google Groups "elasticsearch" group.  
To unsubscribe from this group and stop receiving emails from it, send an email to [elasticsearch+unsubscribe@googlegroups.com](mailto:elasticsearch+unsubscribe@googlegroups.com).  
To view this discussion on the web visit [https://groups.google.com/d/msgid/elasticsearch/9be47e6e-69fc-47c9-a4b8-c170300ffaf9%40googlegroups.com](https://groups.google.com/d/msgid/elasticsearch/9be47e6e-69fc-47c9-a4b8-c170300ffaf9%40googlegroups.com).  
For more options, visit [https://groups.google.com/d/optout](https://groups.google.com/d/optout).

---

<div class="post-metadata">

**Author:** ![dadoonet](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/dadoonet/32/137187_2.png) [@dadoonet](https://discuss.elastic.co/u/dadoonet)\
**Post date:** [March 12, 2014, 6:30am UTC](https://discuss.elastic.co/t/elasticsearch-analysis-phonetic-installs-correctly-but-fails-when-creating-an-index/16306/2 "2014-03-12T06:30:29Z")

</div>

Which command do you run to create your index?

--  
David 😉  
Twitter : @dadoonet / @elasticsearchfr / @scrutmydocs

Le 12 mars 2014 à 02:07, Thiago Valverde [tc.valverde@gmail.com](mailto:tc.valverde@gmail.com) a écrit :

Plugin installation seems to succeed.

```
[root@host elasticsearch-1.0.1]# bin/plugin -install elasticsearch/elasticsearch-analysis-phonetic/2.0.0
-> Installing elasticsearch/elasticsearch-analysis-phonetic/2.0.0...
Trying http://download.elasticsearch.org/elasticsearch/elasticsearch-analysis-phonetic/elasticsearch-analysis-phonetic-2.0.0.zip...
Downloading ............................DONE
Installed elasticsearch/elasticsearch-analysis-phonetic/2.0.0 into /root/elasticsearch-1.0.1/plugins/analysis-phonetic
[root@host elasticsearch-1.0.1]# bin/elasticsearch
[2014-03-12 00:58:59,782][INFO][node] [Jack Kirby] version[1.0.1], pid[6456], build[5c03844/2014-02-25T15:52:53Z]
[2014-03-12 00:58:59,783][INFO][node] [Jack Kirby] initializing ...
[2014-03-12 00:58:59,817][INFO][plugins] [Jack Kirby] loaded [cloud-aws, analysis-phonetic], sites [head]
[2014-03-12 00:59:04,523][INFO][node] [Jack Kirby] initialized
[2014-03-12 00:59:04,523][INFO][node] [Jack Kirby] starting ...
[2014-03-12 00:59:04,650][INFO][transport] [Jack Kirby] bound_address {inet[/0:0:0:0:0:0:0:0:9300]}, publish_address {inet[/172.31.27.225:9300]}
[2014-03-12 00:59:07,706][INFO][cluster.service] [Jack Kirby] new_master [Jack Kirby][fhpzKNmcRLKc208DuuXRrA][host][inet[/172.31.27.225:9300]], reason: zen-disco-join (elected_as_master)
[2014-03-12 00:59:07,762][INFO][discovery] [Jack Kirby] elasticsearch/fhpzKNmcRLKc208DuuXRrA
[2014-03-12 00:59:07,903][INFO][http] [Jack Kirby] bound_address {inet[/0:0:0:0:0:0:0:0:9200]}, publish_address {inet[/172.31.27.225:9200]}
[2014-03-12 00:59:09,079][INFO][gateway] [Jack Kirby] recovered [1] indices into cluster_state
[2014-03-12 00:59:09,276][INFO][node] [Jack Kirby] started

```

But attempting to create an index with a phonetic filter yields:

```
400 : {"error":"IndexCreationException[[asdf] failed to create index]; nested: ElasticsearchIllegalArgumentException[failed to find token filter type [phonetic] for [phonetic]]; nested: NoClassSettingsException[Failed to load class setting [type] with value [phonetic]]; nested: ClassNotFoundException[org.elasticsearch.index.analysis.phonetic.PhoneticTokenFilterFactory]; ","status":400} 

```

With nothing logged to the console. Here's some more information about the host:

```
[root@host elasticsearch-1.0.1]# uname -a
Linux host 3.4.73-64.112.amzn1.x86_64 #1 SMP Tue Dec 10 01:50:05 UTC 2013 x86_64 x86_64 x86_64 GNU/Linux
[root@host elasticsearch-1.0.1]# java -version
java version "1.7.0_51"
OpenJDK Runtime Environment (amzn-2.4.4.1.34.amzn1-x86_64 u51-b02)
OpenJDK 64-Bit Server VM (build 24.45-b08, mixed mode)

```

For some reason, the same steps work on my local workstation:

```
$ uname -a
Darwin Valverde.local 13.1.0 Darwin Kernel Version 13.1.0: Thu Jan 16 19:40:37 PST 2014; root:xnu-2422.90.20~2/RELEASE_X86_64 x86_64
$ java -version
java version "1.6.0_65"
Java(TM) SE Runtime Environment (build 1.6.0_65-b14-462-11M4609)
Java HotSpot(TM) 64-Bit Server VM (build 20.65-b04-462, mixed mode)

```

## I have tried OpenJDK 6 and 7, Oracle JDK 7, ElasticSearch 1.0.0 and 1.0.1. None of those worked on the server. Any help is appreciated.

You received this message because you are subscribed to the Google Groups "elasticsearch" group.  
To unsubscribe from this group and stop receiving emails from it, send an email to [elasticsearch+unsubscribe@googlegroups.com](mailto:elasticsearch+unsubscribe@googlegroups.com).  
To view this discussion on the web visit [https://groups.google.com/d/msgid/elasticsearch/9be47e6e-69fc-47c9-a4b8-c170300ffaf9%40googlegroups.com](https://groups.google.com/d/msgid/elasticsearch/9be47e6e-69fc-47c9-a4b8-c170300ffaf9%40googlegroups.com).  
For more options, visit [https://groups.google.com/d/optout](https://groups.google.com/d/optout).

--  
You received this message because you are subscribed to the Google Groups "elasticsearch" group.  
To unsubscribe from this group and stop receiving emails from it, send an email to [elasticsearch+unsubscribe@googlegroups.com](mailto:elasticsearch+unsubscribe@googlegroups.com).  
To view this discussion on the web visit [https://groups.google.com/d/msgid/elasticsearch/0FB3DA7A-8503-4895-96EC-84F3214BBB84%40pilato.fr](https://groups.google.com/d/msgid/elasticsearch/0FB3DA7A-8503-4895-96EC-84F3214BBB84%40pilato.fr).  
For more options, visit [https://groups.google.com/d/optout](https://groups.google.com/d/optout).

---

<div class="post-metadata">

**Author:** ![Thiago\_Valverde](https://avatars.discourse-cdn.com/v4/letter/t/e274bd/32.png) [@Thiago\_Valverde](https://discuss.elastic.co/u/Thiago_Valverde)\
**Post date:** [March 12, 2014, 3:35pm UTC](https://discuss.elastic.co/t/elasticsearch-analysis-phonetic-installs-correctly-but-fails-when-creating-an-index/16306/3 "2014-03-12T15:35:49Z")

</div>

Thanks for asking the right question, haha. While putting together a  
sample, I realized I was POSTing to the wrong server after all.

Cheers!

On Wednesday, March 12, 2014 3:30:29 AM UTC-3, David Pilato wrote:

> Which command do you run to create your index?
> 
> --  
> David 😉  
> Twitter : @dadoonet / @elasticsearchfr / @scrutmydocs
> 
> Le 12 mars 2014 à 02:07, Thiago Valverde \<[tc.va...@gmail.com](mailto:tc.va...@gmail.com) \<javascript:\>\>  
> a écrit :
> 
> Plugin installation seems to succeed.
> 
> ```
> [root@host elasticsearch-1.0.1]# bin/plugin -install 
> 
> ```
> 
> elasticsearch/elasticsearch-analysis-phonetic/2.0.0  
> -\> Installing elasticsearch/elasticsearch-analysis-phonetic/2.0.0...  
> Trying  
> [http://download.elasticsearch.org/elasticsearch/elasticsearch-analysis-phonetic/elasticsearch-analysis-phonetic-2.0.0.zip](http://download.elasticsearch.org/elasticsearch/elasticsearch-analysis-phonetic/elasticsearch-analysis-phonetic-2.0.0.zip)  
> ...  
> Downloading ............................DONE  
> Installed elasticsearch/elasticsearch-analysis-phonetic/2.0.0 into  
> /root/elasticsearch-1.0.1/plugins/analysis-phonetic  
> [root@host elasticsearch-1.0.1]# bin/elasticsearch  
> [2014-03-12 00:58:59,782][INFO][node] [Jack  
> Kirby] version[1.0.1], pid[6456], build[5c03844/2014-02-25T15:52:53Z]  
> [2014-03-12 00:58:59,783][INFO][node] [Jack  
> Kirby] initializing ...  
> [2014-03-12 00:58:59,817][INFO][plugins] [Jack  
> Kirby] loaded [cloud-aws, analysis-phonetic], sites [head]  
> [2014-03-12 00:59:04,523][INFO][node] [Jack  
> Kirby] initialized  
> [2014-03-12 00:59:04,523][INFO][node] [Jack  
> Kirby] starting ...  
> [2014-03-12 00:59:04,650][INFO][transport] [Jack  
> Kirby] bound\_address {inet[/0:0:0:0:0:0:0:0:9300]}, publish\_address {inet[/  
> 172.31.27.225:9300]}  
> [2014-03-12 00:59:07,706][INFO][cluster.service] [Jack  
> Kirby] new\_master [Jack  
> Kirby][fhpzKNmcRLKc208DuuXRrA][host][inet[/172.31.27.225:9300]], reason:  
> zen-disco-join (elected\_as\_master)  
> [2014-03-12 00:59:07,762][INFO][discovery] [Jack  
> Kirby] elasticsearch/fhpzKNmcRLKc208DuuXRrA  
> [2014-03-12 00:59:07,903][INFO][http] [Jack  
> Kirby] bound\_address {inet[/0:0:0:0:0:0:0:0:9200]}, publish\_address {inet[/  
> 172.31.27.225:9200]}  
> [2014-03-12 00:59:09,079][INFO][gateway] [Jack  
> Kirby] recovered [1] indices into cluster\_state  
> [2014-03-12 00:59:09,276][INFO][node] [Jack  
> Kirby] started
> 
> But attempting to create an index with a phonetic filter yields:
> 
> ```
> 400 : {"error":"IndexCreationException[[asdf] failed to create index]; 
> 
> ```
> 
> nested: ElasticsearchIllegalArgumentException[failed to find token filter  
> type [phonetic] for [phonetic]]; nested: NoClassSettingsException[Failed to  
> load class setting [type] with value [phonetic]]; nested:  
> ClassNotFoundException[org.elasticsearch.index.analysis.phonetic.PhoneticTokenFilterFactory];  
> ","status":400}
> 
> With nothing logged to the console. Here's some more information about the  
> host:
> 
> ```
> [root@host elasticsearch-1.0.1]# uname -a
> Linux host 3.4.73-64.112.amzn1.x86_64 #1 SMP Tue Dec 10 01:50:05 UTC 
> 
> ```
> 
> 2013 x86\_64 x86\_64 x86\_64 GNU/Linux  
> [root@host elasticsearch-1.0.1]# java -version  
> java version "1.7.0\_51"  
> OpenJDK Runtime Environment (amzn-2.4.4.1.34.amzn1-x86\_64 u51-b02)  
> OpenJDK 64-Bit Server VM (build 24.45-b08, mixed mode)
> 
> For some reason, the same steps work on my local workstation:
> 
> ```
> $ uname -a
> Darwin Valverde.local 13.1.0 Darwin Kernel Version 13.1.0: Thu Jan 16 
> 
> ```
> 
> 19:40:37 PST 2014; root:xnu-2422.90.20~2/RELEASE\_X86\_64 x86\_64  
> $ java -version  
> java version "1.6.0\_65"  
> Java(TM) SE Runtime Environment (build 1.6.0\_65-b14-462-11M4609)  
> Java HotSpot(TM) 64-Bit Server VM (build 20.65-b04-462, mixed mode)
> 
> I have tried OpenJDK 6 and 7, Oracle JDK 7, Elasticsearch 1.0.0 and 1.0.1.  
> None of those worked on the server. Any help is appreciated.
> 
> --  
> You received this message because you are subscribed to the Google Groups  
> "elasticsearch" group.  
> To unsubscribe from this group and stop receiving emails from it, send an  
> email to [elasticsearc...@googlegroups.com](mailto:elasticsearc...@googlegroups.com) \<javascript:\>.  
> To view this discussion on the web visit  
> [https://groups.google.com/d/msgid/elasticsearch/9be47e6e-69fc-47c9-a4b8-c170300ffaf9%40googlegroups.com](https://groups.google.com/d/msgid/elasticsearch/9be47e6e-69fc-47c9-a4b8-c170300ffaf9%40googlegroups.com)[https://groups.google.com/d/msgid/elasticsearch/9be47e6e-69fc-47c9-a4b8-c170300ffaf9%40googlegroups.com?utm\_medium=email&utm\_source=footer](https://groups.google.com/d/msgid/elasticsearch/9be47e6e-69fc-47c9-a4b8-c170300ffaf9%40googlegroups.com?utm_medium=email&utm_source=footer)  
> .  
> For more options, visit [https://groups.google.com/d/optout](https://groups.google.com/d/optout).

--  
You received this message because you are subscribed to the Google Groups "elasticsearch" group.  
To unsubscribe from this group and stop receiving emails from it, send an email to [elasticsearch+unsubscribe@googlegroups.com](mailto:elasticsearch+unsubscribe@googlegroups.com).  
To view this discussion on the web visit [https://groups.google.com/d/msgid/elasticsearch/a6982a61-f44b-4b83-a254-0056a043df83%40googlegroups.com](https://groups.google.com/d/msgid/elasticsearch/a6982a61-f44b-4b83-a254-0056a043df83%40googlegroups.com).  
For more options, visit [https://groups.google.com/d/optout](https://groups.google.com/d/optout).

---

<div class="post-metadata">

**Author:** ![vaniaravinda](https://avatars.discourse-cdn.com/v4/letter/v/7993a0/32.png) [@vaniaravinda](https://discuss.elastic.co/u/vaniaravinda)\
**Post date:** [April 3, 2016, 8:34am UTC](https://discuss.elastic.co/t/elasticsearch-analysis-phonetic-installs-correctly-but-fails-when-creating-an-index/16306/4 "2016-04-03T08:34:48Z")

</div>

Hi @Thiago_Valverde,

Can u please let me know how to install phonetic analyser plugin.

Thanks,  
@vaniaravinda

---

<div class="post-metadata">

**Author:** ![dadoonet](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/dadoonet/32/137187_2.png) [@dadoonet](https://discuss.elastic.co/u/dadoonet)\
**Post date:** [April 3, 2016, 11:59am UTC](https://discuss.elastic.co/t/elasticsearch-analysis-phonetic-installs-correctly-but-fails-when-creating-an-index/16306/5 "2016-04-03T11:59:10Z")

</div>

Don't answer to 2 years old threads. I does not make sense.

Open a new one.

BTW read this [https://www.elastic.co/guide/en/elasticsearch/plugins/current/analysis-phonetic.html](https://www.elastic.co/guide/en/elasticsearch/plugins/current/analysis-phonetic.html)

---

<div class="post-metadata">

**Author:** ![vaniaravinda](https://avatars.discourse-cdn.com/v4/letter/v/7993a0/32.png) [@vaniaravinda](https://discuss.elastic.co/u/vaniaravinda)\
**Post date:** [April 3, 2016, 1:36pm UTC](https://discuss.elastic.co/t/elasticsearch-analysis-phonetic-installs-correctly-but-fails-when-creating-an-index/16306/6 "2016-04-03T13:36:55Z")

</div>

Hi @dadoonet,

First of all TanQ for ur quick response. I created a new thread ([https://discuss.elastic.co/t/how-to-install-elasticsearch-phonetic-analysis-plugin/46153](https://discuss.elastic.co/t/how-to-install-elasticsearch-phonetic-analysis-plugin/46153)). I need it urgently so thought that someone will help me as soon as possible. That's y I posted here also. I'm sorry for opening the old thread. I have already gone through the link u provided but I'm not able to run it. It will be help full if u provide more details.

Thanks,  
@vaniaravinda

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [July 5, 2017, 11:02pm UTC](https://discuss.elastic.co/t/elasticsearch-analysis-phonetic-installs-correctly-but-fails-when-creating-an-index/16306/7 "2017-07-05T23:02:52Z")

</div>


