# ElasticSearch and CentOS 7: Failed to start elasticsearch-.service: Unit not found

**URL:** <https://discuss.elastic.co/t/elasticsearch-and-centos-7-failed-to-start-elasticsearch-service-unit-not-found/217676>\
**Category:** Elasticsearch\
**Created:** [February 3, 2020, 6:57pm UTC](https://discuss.elastic.co/t/elasticsearch-and-centos-7-failed-to-start-elasticsearch-service-unit-not-found/217676 "2020-02-03T18:57:02Z")\
**Posts on this page:** 2\
**Page:** 1

<div class="post-metadata">

**Author:** ![psohn](https://avatars.discourse-cdn.com/v4/letter/p/f19dbf/32.png) [@psohn](https://discuss.elastic.co/u/psohn)\
**Post date:** [February 3, 2020, 6:57pm UTC](https://discuss.elastic.co/t/elasticsearch-and-centos-7-failed-to-start-elasticsearch-service-unit-not-found/217676/1 "2020-02-03T18:57:02Z")

</div>

Hello,

First time trying to install and configure ElkStack on CentOS7 and ran into some issues. Was able to install the Elasticsearch package, however, I have not been able to start ElasticSearch after using `systemctl start elasticsearch`.

I receive the following error:  
Failed to start elasticsearch-.service: Unit not found.

Config yml is below. Are there any other logs I can use to troubleshoot?

 ![Screen Shot 2020-02-03 at 1.56.17 PM](https://us1.discourse-cdn.com/elastic/original/3X/b/1/b10db9cd8b12a22922a21faf59d9bf65904d8ced.png)

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [March 2, 2020, 6:57pm UTC](https://discuss.elastic.co/t/elasticsearch-and-centos-7-failed-to-start-elasticsearch-service-unit-not-found/217676/2 "2020-03-02T18:57:04Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
