# ElasticSearch and Kibana installed successfully, but cannot be accessed by web browser

**URL:** <https://discuss.elastic.co/t/elasticsearch-and-kibana-installed-successfully-but-cannot-be-accessed-by-web-browser/220065>\
**Category:** Elasticsearch\
**Created:** [February 20, 2020, 12:50am UTC](https://discuss.elastic.co/t/elasticsearch-and-kibana-installed-successfully-but-cannot-be-accessed-by-web-browser/220065 "2020-02-20T00:50:33Z")\
**Posts on this page:** 6\
**Page:** 1

<div class="post-metadata">

**Author:** ![vernal](https://avatars.discourse-cdn.com/v4/letter/v/b38774/32.png) [@vernal](https://discuss.elastic.co/u/vernal)\
**Post date:** [February 20, 2020, 12:50am UTC](https://discuss.elastic.co/t/elasticsearch-and-kibana-installed-successfully-but-cannot-be-accessed-by-web-browser/220065/1 "2020-02-20T00:50:33Z")

</div>

Below is the setting from kibana.yml:  
server.port: 5601  
server.host: namenode2  
elasticsearch.url: "[http://namenode2:9200](http://namenode2:9200)"

Below is the setting from elasticsearch.yml:  
cluster.name: es-prod  
node.name: master-1  
path.data: /var/lib/elasticsearch  
path.logs: /var/log/elasticsearch  
network.host: ["namenode2", _local_]

When I tried vi /etc/hosts, I get:  
172.15.7.169 namenode2

But when I typed [http://172.15.7.169:5601](http://172.15.7.169:5601), I get the following error message:

# This site can’t be reached

**172.15.7.169** refused to connect

Actually, it can be seen from the following results:  
root@namenode2: /etc/elasticsearch\> curl -X GET '[http://localhost:5601](http://localhost:5601)' -v

- About to connect() to localhost port 5601 (#0)
- Trying ::1...
- Connection refused
- Trying 127.0.0.1...
- Connected to localhost (127.0.0.1) port 5601 (#0)  
\*\> GET / HTTP/1.1  
\*\> User-Agent: curl/7.29.0  
\*\> Host: localhost:5601  
\*\> Accept: _/_  
\*\>  
\*\< HTTP/1.1 302 Found  
\*\< location: /spaces/enter  
\*\< kbn-name: namenode2  
\*\< kbn-license-sig: \*b9c6f9f9a3160f5ca28c2b723dfa02f5cc0901042cf3f9868f1f5ea0f48eb3a1  
\*\< kbn-xpack-sig: a01841de727f78f70d3c61089bd6feac  
\*\< cache-control: no-cache  
\*\< content-length: 0  
\*\< Date: Thu, 20 Feb 2020 00:46:38 GMT  
\*\< Connection: keep-alive  
\*\<
- Connection #0 to host localhost left intact

root@namenode2: /etc/elasticsearch\> curl -X GET '[http://localhost:9200](http://localhost:9200)' -v

- About to connect() to localhost port 9200 (#0)
- Trying ::1...
- Connected to localhost (::1) port 9200 (#0)

> GET / HTTP/1.1  
> User-Agent: curl/7.29.0  
> Host: localhost:9200  
> Accept: _/_

\< HTTP/1.1 200 OK  
\< content-type: application/json; charset=UTF-8  
\< content-length: 534  
\<  
{  
"name" : "namenode2",  
"cluster\_name" : "elasticsearch",  
"cluster\_uuid" : "fKBvGU5HTmeBkh40Z3Umgg",  
"version" : {  
"number" : "7.6.0",  
"build\_flavor" : "default",  
"build\_type" : "rpm",  
"build\_hash" : "7f634e9f44834fbc12724506cc1da681b0c3b1e3",  
"build\_date" : "2020-02-06T00:09:00.449973Z",  
"build\_snapshot" : false,  
"lucene\_version" : "8.4.0",  
"minimum\_wire\_compatibility\_version" : "6.8.0",  
"minimum\_index\_compatibility\_version" : "6.0.0-beta1"  
},  
"tagline" : "You Know, for Search"  
}

- Connection #0 to host localhost left intact

However, if I changed "localhost" to "172.15.7.169", I get:  
root@namenode2: /etc/elasticsearch\> curl -X GET '[http://172.15.7.169:9200](http://172.15.7.169:9200)' -v

- About to connect() to 172.15.7.169 port 9200 (#0)
- Trying 172.15.7.169...
- Connection refused
- Failed connect to 172.15.7.169:9200; Connection refused
- Closing connection 0  
curl: (7) Failed connect to 172.15.7.169:9200; Connection refused

root@namenode2: /etc/elasticsearch\> curl -X GET '[http://172.15.7.169:5601](http://172.15.7.169:5601)' -v

- About to connect() to 172.15.7.169 port 5601 (#0)
- Trying 172.15.7.169...
- Connection refused
- Failed connect to 172.15.7.169:5601; Connection refused
- Closing connection 0  
curl: (7) Failed connect to 172.15.7.169:5601; Connection refused

What is wrong with my setting?

---

<div class="post-metadata">

**Author:** ![spinscale](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/spinscale/32/25011_2.png) [@spinscale](https://discuss.elastic.co/u/spinscale)\
**Post date:** [February 20, 2020, 8:18am UTC](https://discuss.elastic.co/t/elasticsearch-and-kibana-installed-successfully-but-cannot-be-accessed-by-web-browser/220065/2 "2020-02-20T08:18:38Z")

</div>

by default, Elasticsearch only listens on localhost. Has this been changed in your YAML configuration?

---

<div class="post-metadata">

**Author:** ![vernal](https://avatars.discourse-cdn.com/v4/letter/v/b38774/32.png) [@vernal](https://discuss.elastic.co/u/vernal)\
**Post date:** [February 25, 2020, 12:30am UTC](https://discuss.elastic.co/t/elasticsearch-and-kibana-installed-successfully-but-cannot-be-accessed-by-web-browser/220065/3 "2020-02-25T00:30:44Z")

</div>

Yes, you can see from the above, I modified it, but still not working.

---

<div class="post-metadata">

**Author:** ![vernal](https://avatars.discourse-cdn.com/v4/letter/v/b38774/32.png) [@vernal](https://discuss.elastic.co/u/vernal)\
**Post date:** [February 27, 2020, 6:09pm UTC](https://discuss.elastic.co/t/elasticsearch-and-kibana-installed-successfully-but-cannot-be-accessed-by-web-browser/220065/4 "2020-02-27T18:09:55Z")

</div>

I made some changes, so the master node can work, but data node cannot work. And kibana web browser can run.

Here is the configuration file for the data node:

# ---------------------------------- Cluster -----------------------------------

# 

# Use a descriptive name for your cluster:

# 

cluster.name: es-prod

# 

# ------------------------------------ Node ------------------------------------

# 

# Use a descriptive name for the node:

# 

node.name: data-1

# 

# Add custom attributes to the node:

# 

#node.attr.rack: r1

# 

# ----------------------------------- Paths ------------------------------------

# 

# Path to directory where to store the data (separate multiple locations by comma):

# 

path.data: /var/lib/elasticsearch

# Path to log files:

# 

path.logs: /var/log/elasticsearch

# 

# ----------------------------------- Memory -----------------------^X------------

# 

# Lock the memory on startup:

# 

#bootstrap.memory\_lock: true

# 

# ---------------------------------- Network -----------------------------------

# 

# Set the bind address to a specific IP (IPv4 or IPv6):

# 

network.host: ["172.15.7.184", _local_]

# 

# Set a custom port for HTTP:

# 

#http.port: 9200

# 

# For more information, consult the network module documentation.

# 

# --------------------------------- Discovery ----------------------------------

# 

# Pass an initial list of hosts to perform discovery when this node is started:

# The default list of hosts is ["127.0.0.1", "[::1]"]

# 

discovery.seed\_hosts: ["172.15.7.169", "172.15.7.182", "172.15.7.183"]

# 

# Bootstrap the cluster using an initial set of master-eligible nodes:

# 

cluster.initial\_master\_nodes: ["master-1", "master-2", "master-3"]

# 

# For more information, consult the discovery and cluster formation module documentation.

# 

# ---------------------------------- Gateway -----------------------------------

# 

# Block initial recovery after a full cluster restart until N nodes are started:

# 

#gateway.recover\_after\_nodes: 3

# 

# For more information, consult the gateway module documentation.

# 

# ---------------------------------- Various -----------------------------------

# 

# Require explicit names when deleting indices:

# 

#action.destructive\_requires\_name: true  
node.master: false  
node.data: true

---

<div class="post-metadata">

**Author:** ![spinscale](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/spinscale/32/25011_2.png) [@spinscale](https://discuss.elastic.co/u/spinscale)\
**Post date:** [March 12, 2020, 10:13am UTC](https://discuss.elastic.co/t/elasticsearch-and-kibana-installed-successfully-but-cannot-be-accessed-by-web-browser/220065/5 "2020-03-12T10:13:15Z")

</div>

first, please format your code snippets. This is very hard to read and it's hard to extract the real configuration options, maybe also leave out the comments.  
Second, please share the first lines of elasticsearch until it is started, this will show on which network interfaces Elasticsearch is bound to.

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [April 9, 2020, 10:13am UTC](https://discuss.elastic.co/t/elasticsearch-and-kibana-installed-successfully-but-cannot-be-accessed-by-web-browser/220065/6 "2020-04-09T10:13:27Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
