# Elasticsearch and kibana service stopped after x-pack installation ,\[Failed to load plugin class \[org.elasticsearch.xpack.XPackPlugin\]

**URL:** <https://discuss.elastic.co/t/elasticsearch-and-kibana-service-stopped-after-x-pack-installation-failed-to-load-plugin-class-org-elasticsearch-xpack-xpackplugin/72896>\
**Category:** Elasticsearch\
**Created:** [January 26, 2017, 12:17pm UTC](https://discuss.elastic.co/t/elasticsearch-and-kibana-service-stopped-after-x-pack-installation-failed-to-load-plugin-class-org-elasticsearch-xpack-xpackplugin/72896 "2017-01-26T12:17:36Z")\
**Posts on this page:** 5\
**Page:** 1

<div class="post-metadata">

**Author:** ![FardinBehboudi](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/fardinbehboudi/32/14906_2.png) [@FardinBehboudi](https://discuss.elastic.co/u/FardinBehboudi)\
**Post date:** [January 26, 2017, 12:17pm UTC](https://discuss.elastic.co/t/elasticsearch-and-kibana-service-stopped-after-x-pack-installation-failed-to-load-plugin-class-org-elasticsearch-xpack-xpackplugin/72896/1 "2017-01-26T12:17:36Z")

</div>

i am using Elastic stack 5.1  
i had elasticsearcha nd kibana installed with xpack installed on themPreformatted text and they were working also i installed logstash and beats.(order of installation was like what i wrote)  
after installing beat(i think) and some changes in my company VPN and proxy. my elasticsaerch andkibana stopped working, the service is not even getting start.  
i remove x-pack then the ES and kibana working but again when i install x-pack ES and kibana Stop.  
what should I do?

the log says teh xpack plugin cant load!

[2017-01-26T11:34:12,963][WARN][o.e.b.ElasticsearchUncaughtExceptionHandler] [] uncaught exception in thread [main]  
org.elasticsearch.bootstrap.StartupException: ElasticsearchException[Failed to load plugin class [org.elasticsearch.xpack.XPackPlugin]]; nested: InvocationTargetException; nested: AccessDeniedException[/etc/elasticsearch/x-pack/system\_key];  
at org.elasticsearch.bootstrap.Elasticsearch.init(Elasticsearch.java:125) ~[elasticsearch-5.1.2.jar:5.1.2]  
at org.elasticsearch.bootstrap.Elasticsearch.execute(Elasticsearch.java:112) ~[elasticsearch-5.1.2.jar:5.1.2]  
at org.elasticsearch.cli.SettingCommand.execute(SettingCommand.java:54) ~[elasticsearch-5.1.2.jar:5.1.2]  
at org.elasticsearch.cli.Command.mainWithoutErrorHandling(Command.java:122) ~[elasticsearch-5.1.2.jar:5.1.2]  
at org.elasticsearch.cli.Command.main(Command.java:88) ~[elasticsearch-5.1.2.jar:5.1.2]  
at org.elasticsearch.bootstrap.Elasticsearch.main(Elasticsearch.java:89) ~[elasticsearch-5.1.2.jar:5.1.2]  
at org.elasticsearch.bootstrap.Elasticsearch.main(Elasticsearch.java:82) ~[elasticsearch-5.1.2.jar:5.1.2]  
Caused by: org.elasticsearch.ElasticsearchException: Failed to load plugin class [org.elasticsearch.xpack.XPackPlugin]  
at org.elasticsearch.plugins.PluginsService.loadPlugin(PluginsService.java:384) ~[elasticsearch-5.1.2.jar:5.1.2]  
at org.elasticsearch.plugins.PluginsService.loadBundles(PluginsService.java:336) ~[elasticsearch-5.1.2.jar:5.1.2]  
at org.elasticsearch.plugins.PluginsService.(PluginsService.java:132) ~[elasticsearch-5.1.2.jar:5.1.2]  
at org.elasticsearch.node.Node.(Node.java:294) ~[elasticsearch-5.1.2.jar:5.1.2]  
at org.elasticsearch.node.Node.(Node.java:229) ~[elasticsearch-5.1.2.jar:5.1.2]  
at org.elasticsearch.bootstrap.Bootstrap$6.(Bootstrap.java:214) ~[elasticsearch-5.1.2.jar:5.1.2]  
at org.elasticsearch.bootstrap.Bootstrap.setup(Bootstrap.java:214) ~[elasticsearch-5.1.2.jar:5.1.2]  
at org.elasticsearch.bootstrap.Bootstrap.init(Bootstrap.java:306) ~[elasticsearch-5.1.2.jar:5.1.2]  
at org.elasticsearch.bootstrap.Elasticsearch.init(Elasticsearch.java:121) ~[elasticsearch-5.1.2.jar:5.1.2]  
... 6 more  
Caused by: java.lang.reflect.InvocationTargetException  
at sun.reflect.NativeConstructorAccessorImpl.newInstance0(Native Method) ~[?:?]  
at sun.reflect.NativeConstructorAccessorImpl.newInstance(NativeConstructorAccessorImpl.java:62) ~[?:?]  
at sun.reflect.DelegatingConstructorAccessorImpl.newInstance(DelegatingConstructorAccessorImpl.java:45) ~[?:?]  
at java.lang.reflect.Constructor.newInstance(Constructor.java:423) ~[?:1.8.0\_121]  
at org.elasticsearch.plugins.PluginsService.loadPlugin(PluginsService.java:373) ~[elasticsearch-5.1.2.jar:5.1.2]  
at org.elasticsearch.plugins.PluginsService.loadBundles(PluginsService.java:336) ~[elasticsearch-5.1.2.jar:5.1.2]  
at org.elasticsearch.plugins.PluginsService.(PluginsService.java:132) ~[elasticsearch-5.1.2.jar:5.1.2]  
at org.elasticsearch.node.Node.(Node.java:294) ~[elasticsearch-5.1.2.jar:5.1.2]  
at org.elasticsearch.node.Node.(Node.java:229) ~[elasticsearch-5.1.2.jar:5.1.2]  
at org.elasticsearch.bootstrap.Bootstrap$6.(Bootstrap.java:214) ~[elasticsearch-5.1.2.jar:5.1.2]  
at org.elasticsearch.bootstrap.Bootstrap.setup(Bootstrap.java:214) ~[elasticsearch-5.1.2.jar:5.1.2]  
at org.elasticsearch.bootstrap.Bootstrap.init(Bootstrap.java:306) ~[elasticsearch-5.1.2.jar:5.1.2]  
at org.elasticsearch.bootstrap.Elasticsearch.init(Elasticsearch.java:121) ~[elasticsearch-5.1.2.jar:5.1.2]  
... 6 more  
Caused by: java.nio.file.AccessDeniedException: /etc/elasticsearch/x-pack/system\_key  
at sun.nio.fs.UnixException.translateToIOException(UnixException.java:84) ~[?:?]  
at sun.nio.fs.UnixException.rethrowAsIOException(UnixException.java:102) ~[?:?]  
at sun.nio.fs.UnixException.rethrowAsIOException(UnixException.java:107) ~[?:?]  
at sun.nio.fs.UnixFileSystemProvider.newByteChannel(UnixFileSystemProvider.java:214) ~[?:?]  
at java.nio.file.Files.newByteChannel(Files.java:361) ~[?:1.8.0\_121]  
at java.nio.file.Files.newByteChannel(Files.java:407) ~[?:1.8.0\_121]  
at java.nio.file.Files.readAllBytes(Files.java:3152) ~[?:1.8.0\_121]  
at org.elasticsearch.xpack.security.crypto.CryptoService.readSystemKey(CryptoService.java:160) ~[?:?]  
at org.elasticsearch.xpack.security.crypto.CryptoService.(CryptoService.java:112) ~[?:?]  
at org.elasticsearch.xpack.security.Security.(Security.java:191) ~[?:?]  
at org.elasticsearch.xpack.XPackPlugin.(XPackPlugin.java:193) ~[?:?]  
at sun.reflect.NativeConstructorAccessorImpl.newInstance0(Native Method) ~[?:?]  
at sun.reflect.NativeConstructorAccessorImpl.newInstance(NativeConstructorAccessorImpl.java:62) ~[?:?]  
at sun.reflect.DelegatingConstructorAccessorImpl.newInstance(DelegatingConstructorAccessorImpl.java:45) ~[?:?]  
at java.lang.reflect.Constructor.newInstance(Constructor.java:423) ~[?:1.8.0\_121]  
at org.elasticsearch.plugins.PluginsService.loadPlugin(PluginsService.java:373) ~[elasticsearch-5.1.2.jar:5.1.2]  
at org.elasticsearch.plugins.PluginsService.loadBundles(PluginsService.java:336) ~[elasticsearch-5.1.2.jar:5.1.2]  
at org.elasticsearch.plugins.PluginsService.(PluginsService.java:132) ~[elasticsearch-

---

<div class="post-metadata">

**Author:** ![warkolm](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/warkolm/32/39224_2.png) [@warkolm](https://discuss.elastic.co/u/warkolm)\
**Post date:** [January 27, 2017, 1:41am UTC](https://discuss.elastic.co/t/elasticsearch-and-kibana-service-stopped-after-x-pack-installation-failed-to-load-plugin-class-org-elasticsearch-xpack-xpackplugin/72896/2 "2017-01-27T01:41:09Z")

</div>

> [@FardinBehboudi](#):
>
> AccessDeniedException[/etc/elasticsearch/x-pack/system\_key

That's the cause though, I'd check that file.

---

<div class="post-metadata">

**Author:** ![FardinBehboudi](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/fardinbehboudi/32/14906_2.png) [@FardinBehboudi](https://discuss.elastic.co/u/FardinBehboudi)\
**Post date:** [January 27, 2017, 2:05pm UTC](https://discuss.elastic.co/t/elasticsearch-and-kibana-service-stopped-after-x-pack-installation-failed-to-load-plugin-class-org-elasticsearch-xpack-xpackplugin/72896/3 "2017-01-27T14:05:28Z")

</div>

Hi  
thank you Mark.  
in fact it was running but when i installed the filebeat and packetbeat and started to do this tutorial:  
[https://www.elastic.co/guide/en/kibana/current/tutorial-load-dataset.html](https://www.elastic.co/guide/en/kibana/current/tutorial-load-dataset.html)

after mapping the data i get intu this problem and elasticsearch stopped working.

---

<div class="post-metadata">

**Author:** ![FardinBehboudi](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/fardinbehboudi/32/14906_2.png) [@FardinBehboudi](https://discuss.elastic.co/u/FardinBehboudi)\
**Post date:** [January 28, 2017, 3:09pm UTC](https://discuss.elastic.co/t/elasticsearch-and-kibana-service-stopped-after-x-pack-installation-failed-to-load-plugin-class-org-elasticsearch-xpack-xpackplugin/72896/4 "2017-01-28T15:09:59Z")

</div>

i checked that file there are some unidentified characters on that, also i am working with root user and i also gave the permision to my root user and add that in elasticsearch group, but again i have this problem!

what do you think i should do?

thanks

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [February 25, 2017, 3:10pm UTC](https://discuss.elastic.co/t/elasticsearch-and-kibana-service-stopped-after-x-pack-installation-failed-to-load-plugin-class-org-elasticsearch-xpack-xpackplugin/72896/5 "2017-02-25T15:10:04Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
