# Elasticsearch cannot be started after an upgrade: Temporary file directory \[${ES\_TMPDIR}\] does not exist or is not accessible

**URL:** <https://discuss.elastic.co/t/elasticsearch-cannot-be-started-after-an-upgrade-temporary-file-directory-es-tmpdir-does-not-exist-or-is-not-accessible/217780>\
**Category:** Elasticsearch\
**Created:** [February 4, 2020, 11:13am UTC](https://discuss.elastic.co/t/elasticsearch-cannot-be-started-after-an-upgrade-temporary-file-directory-es-tmpdir-does-not-exist-or-is-not-accessible/217780 "2020-02-04T11:13:06Z")\
**Posts on this page:** 2\
**Page:** 1

<div class="post-metadata">

**Author:** ![nelyanne-v](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/nelyanne-v/32/62083_2.png) [@nelyanne-v](https://discuss.elastic.co/u/nelyanne-v)\
**Post date:** [February 4, 2020, 11:13am UTC](https://discuss.elastic.co/t/elasticsearch-cannot-be-started-after-an-upgrade-temporary-file-directory-es-tmpdir-does-not-exist-or-is-not-accessible/217780/1 "2020-02-04T11:13:06Z")

</div>

Hi all,

I am trying to upgrade my Elasticsearch cluster from 7.4.0 to 7.5.2. It is running on CentOS 7 with Java 1.8.0. I used the rpm files from [https://www.elastic.co/downloads/elasticsearch](https://www.elastic.co/downloads/elasticsearch). I successfully upgraded the first node, but now I am having some issues with the second one. I would be grateful for help.

**Steps to reproduce** :

1. sudo rpm -Uvh elasticsearch-7.5.2-x86\_64.rpm
2. systemctl daemon-reload
3. sudo systemctl start elasticsearch.service

Service cannot be started, see the logs below.

**Provide logs (if relevant)** :

```
 -- Unit elasticsearch.service has begun starting up.
 Feb 04 16:01:59 xxx-server-3 elasticsearch[129216]: OpenJDK 64-Bit Server VM warning: Option UseConcMarkSweepGC was deprecated in version 9.0 and will likely be removed in a future rele
 Feb 04 16:02:00 xxx-server-3 elasticsearch[129216]: ERROR: Temporary file directory [${ES_TMPDIR}] does not exist or is not accessible
 Feb 04 16:02:00 xxx-server-3 systemd[1]: elasticsearch.service: main process exited, code=exited, status=78/n/a
 Feb 04 16:02:00 xxx-server-3 systemd[1]: Failed to start Elasticsearch.
 -- Subject: Unit elasticsearch.service has failed
 -- Defined-By: systemd
 -- Support: http://lists.freedesktop.org/mailman/listinfo/systemd-devel
 --
 -- Unit elasticsearch.service has failed.
 --
 -- The result is failed.
 Feb 04 16:02:00 xxx-server-3 systemd[1]: Unit elasticsearch.service entered failed state.
 Feb 04 16:02:00 xxx-server-3 systemd[1]: elasticsearch.service failed.
```

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [March 3, 2020, 11:13am UTC](https://discuss.elastic.co/t/elasticsearch-cannot-be-started-after-an-upgrade-temporary-file-directory-es-tmpdir-does-not-exist-or-is-not-accessible/217780/2 "2020-03-03T11:13:15Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
