# Elasticsearch cannot up because /org/freedesktop/PolicyKit1/AuthenticationAgent Blocked

**URL:** <https://discuss.elastic.co/t/elasticsearch-cannot-up-because-org-freedesktop-policykit1-authenticationagent-blocked/277464>\
**Category:** Elasticsearch\
**Created:** [June 30, 2021, 1:09pm UTC](https://discuss.elastic.co/t/elasticsearch-cannot-up-because-org-freedesktop-policykit1-authenticationagent-blocked/277464 "2021-06-30T13:09:39Z")\
**Posts on this page:** 4\
**Page:** 1

<div class="post-metadata">

**Author:** ![kemalkolcuoglu](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/kemalkolcuoglu/32/88245_2.png) [@kemalkolcuoglu](https://discuss.elastic.co/u/kemalkolcuoglu)\
**Post date:** [June 30, 2021, 1:09pm UTC](https://discuss.elastic.co/t/elasticsearch-cannot-up-because-org-freedesktop-policykit1-authenticationagent-blocked/277464/1 "2021-06-30T13:09:39Z")

</div>

Hello Everyone,

**Cluster version:** 7.7.0  
**OS Version:** Centos 7.9  
**Java Version:** Java 8

We have an issue with Elasticsearch when we try to up the service.

`journalctl -xe` output:

```auto
Jun 30 08:59:10 elk-master-2 systemd[1]: elasticsearch.service: main process exited, code=exited, status=1/FAILURE
Jun 30 08:59:10 elk-master-2 systemd[1]: Failed to start Elasticsearch.
-- Subject: Unit elasticsearch.service has failed
-- Defined-By: systemd
-- Support: http://lists.freedesktop.org/mailman/listinfo/systemd-devel
-- 
-- Unit elasticsearch.service has failed.
-- 
-- The result is failed.
Jun 30 08:59:10 elk-master-2 systemd[1]: Unit elasticsearch.service entered failed state.
Jun 30 08:59:10 elk-master-2 systemd[1]: elasticsearch.service failed.
Jun 30 08:59:10 elk-master-2 polkitd[875]: Unregistered Authentication Agent for unix-process:18024:8081908 (system bus name :1.92, object path /org/freedesktop/PolicyKit1/AuthenticationAgent, locale C) (disconnected from bus)
Jun 30 08:59:21 elk-master-2 sshd[18254]: Accepted password for root from 10.254.113.14 port 63682 ssh2
Jun 30 08:59:21 elk-master-2 systemd-logind[869]: New session 38 of user root.

```

So, I think the problem about AuthenticationAgent but I really don't know why this blocks up the service.

Could someone help with this issue?

---

<div class="post-metadata">

**Author:** ![warkolm](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/warkolm/32/39224_2.png) [@warkolm](https://discuss.elastic.co/u/warkolm)\
**Post date:** [July 1, 2021, 12:19am UTC](https://discuss.elastic.co/t/elasticsearch-cannot-up-because-org-freedesktop-policykit1-authenticationagent-blocked/277464/2 "2021-07-01T00:19:56Z")

</div>

What do your Elasticsearch logs show?

---

<div class="post-metadata">

**Author:** ![alicango](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/alicango/32/84498_2.png) [@alicango](https://discuss.elastic.co/u/alicango)\
**Post date:** [July 1, 2021, 1:18pm UTC](https://discuss.elastic.co/t/elasticsearch-cannot-up-because-org-freedesktop-policykit1-authenticationagent-blocked/277464/3 "2021-07-01T13:18:11Z")

</div>

You can close this discussion as a solved. The reason for the problem was elasticsearch.yml

```auto
path.data: /home/elasticsearch/data
path.logs: /home/elasticsearch/logs
path.repo: /home/elasticsearch/backup

```

we created each path manually and the service started up successfully.

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [July 29, 2021, 1:18pm UTC](https://discuss.elastic.co/t/elasticsearch-cannot-up-because-org-freedesktop-policykit1-authenticationagent-blocked/277464/4 "2021-07-29T13:18:32Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
