# Elasticsearch can't active

**URL:** <https://discuss.elastic.co/t/elasticsearch-cant-active/124686>\
**Category:** Elasticsearch\
**Created:** [March 20, 2018, 5:33am UTC](https://discuss.elastic.co/t/elasticsearch-cant-active/124686 "2018-03-20T05:33:04Z")\
**Posts on this page:** 15\
**Page:** 1

<div class="post-metadata">

**Author:** ![fitmren\_lamhr](https://avatars.discourse-cdn.com/v4/letter/f/a5b964/32.png) [@fitmren\_lamhr](https://discuss.elastic.co/u/fitmren_lamhr)\
**Post date:** [March 20, 2018, 5:33am UTC](https://discuss.elastic.co/t/elasticsearch-cant-active/124686/1 "2018-03-20T05:33:04Z")

</div>

hello, i got some issues in elasticsearch.  
when i curl -xget ‘[http://localhost:9200/\_cluster/health?pretty=true’](http://localhost:9200/_cluster/health?pretty=true%E2%80%99)  
i got error:  
curl: (7) Failed to connect to localhost port 9200: Connection refused

then i check my elasticsearch’s status:

root@stagging-graylog:~ sudo systemctl status elasticsearch ● elasticsearch.service - Elasticsearch Loaded: loaded (/usr/lib/systemd/system/elasticsearch.service; enabled; vendoem/elasticsearch.service; enabled; vendor preset: enabled)  
Active: failed (Result: exit-code) since Tue 2018-03-20 10:32:10 WIB; 53min a Docs: [http://www.elastic.co](http://www.elastic.co) Process: 9365 ExecStart=/usr/share/elasticsearch/bin/elasticsearch -Des.pidfile={PID\_DIR}/elasticsearch.pid -Des.default.path.home={ES\_HOME} -Des.default.pault.path.home={ES\_HOME} -Des.default.path.logs={LOG\_DIR} -Des.default.path.data={DATA\_DIR} -Des.default.path.conf=${CONF\_DIR} (code=exited, status=1/FAILURE)  
Process: 9362 ExecStartPre=/usr/share/elasticsearch/bin/elasticsearch-systemd-elasticsearch/bin/elasticsearch-systemd-pre-exec (code=exited, status=0/SUCCESS)  
Main PID: 9365 (code=exited, status=1/FAILURE)

Mar 20 10:32:10 stagging-graylog elasticsearch[9365]:

Mar 20 10:32:10 stagging-graylog elasticsearch[9365]: #  
Mar 20 10:32:10 stagging-graylog elasticsearch[9365]: # ------------------------  
Mar 20 10:32:10 stagging-graylog elasticsearch[9365]: #  
Mar 20 10:32:10 stagging-graylog elasticsearch[9365]: # Block initial recovery a  
Mar 20 10:32:10 stagging-graylog systemd[1]: elasticsearch.service: Main process[1]: elasticsearch.service: Main process exited, code=exited, status=1/FAILURE

Mar 20 10:32:10 stagging-graylogsystemd[1]: elasticsearch.service: Unit entered[1]: elasticsearch.service: Unit entered failed state.

Mar 20 10:32:10 stagging-graylog systemd[1]: elasticsearch.service: Failed with[1]: elasticsearch.service: Failed with result ‘exit-code’.

here the logs:

[2018-03-20 10:15:45,543][INFO][node] [Schemer] version[2.4.6], pid[8225], build[5376dca/2017-07-18T12:17:44Z]  
[2018-03-20 10:15:45,546][INFO][node] [Schemer] initializializing …  
[2018-03-20 10:15:45,979][INFO][plugins] [Schemer] modules [reindex, lang-expression, lang-groovy], plugins [], sites []

[2018-03-20 10:15:46,005][INFO][env] [Schemer] using [1] data paths, mounts [[//dev/vda1)]], net usable\_space [21.5gb], net total\_space [28.4gb], spins? [possibly], types [ext4]  
[2018-03-20 10:15:46,005][INFO][env] [Schemer] heap size [1015.6mb], compressed ordinary object pointers [true]  
[2018-03-20 10:15:46,017][ERROR][bootstrap] Exception

java.lang.Error: java.security.AccessControlException: access denied (“java.lang.reflect.ReflectPermission” “suppressAccessChecks”)  
at com.twitter.jsr166e.Striped64.(Striped64.java:319)  
at org.elasticsearch.common.metrics.CounterMetric.(CounterMetretric.java:28)  
at org.elasticsearch.common.util.concurrent.EsAbortPolicy.(EsAborPolicy.java:30)  
at org.elasticsearch.common.util.concurrent.EsExecutors.newFixed(EsExectors.java:80)  
at org.elasticsearch.threadpool.ThreadPool.rebuild(ThreadPool.java:510)  
at org.elasticsearch.threadpool.ThreadPool.build(ThreadPool.java:428)  
at org.elasticsearch.threadpool.ThreadPool.(ThreadPool.java:234)  
at org.elasticsearch.node.Node.(Node.java:170)  
at org.elasticsearch.node.Node.(Node.java:140)  
at org.elasticsearch.node.NodeBuilder.build(NodeBuilder.java:143)  
at org.elasticsearch.bootstrap.Bootstrap.setup(Bootstrap.java:194)  
at org.elasticsearch.bootstrap.Bootstrap.init(Bootstrap.java:286)

---

<div class="post-metadata">

**Author:** ![Shaik\_Thowsif](https://avatars.discourse-cdn.com/v4/letter/s/3d9bf3/32.png) [@Shaik\_Thowsif](https://discuss.elastic.co/u/Shaik_Thowsif)\
**Post date:** [March 20, 2018, 5:44am UTC](https://discuss.elastic.co/t/elasticsearch-cant-active/124686/2 "2018-03-20T05:44:49Z")

</div>

try this command "service elasticsearch start"

---

<div class="post-metadata">

**Author:** ![Shaik\_Thowsif](https://avatars.discourse-cdn.com/v4/letter/s/3d9bf3/32.png) [@Shaik\_Thowsif](https://discuss.elastic.co/u/Shaik_Thowsif)\
**Post date:** [March 20, 2018, 5:45am UTC](https://discuss.elastic.co/t/elasticsearch-cant-active/124686/3 "2018-03-20T05:45:07Z")

</div>

After that check the status

---

<div class="post-metadata">

**Author:** ![harshbajaj16](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/harshbajaj16/32/44970_2.png) [@harshbajaj16](https://discuss.elastic.co/u/harshbajaj16)\
**Post date:** [March 20, 2018, 5:50am UTC](https://discuss.elastic.co/t/elasticsearch-cant-active/124686/4 "2018-03-20T05:50:50Z")

</div>

> [@fitmren\_lamhr](#):
>
> version[2.4.6]

Can you pls share the below details:

Elasticsearch version:

and if you upgraded then pls let me know?

as i can see its showing 2.4.6 version of elasticsearch.

> [@fitmren\_lamhr](#):
>
> [2018-03-20 10:15:45,543][INFO][node] [Schemer] version[2.4.6], pid[8225], build[5376dca/2017-07-18T12:17:44Z]

---

<div class="post-metadata">

**Author:** ![fitmren\_lamhr](https://avatars.discourse-cdn.com/v4/letter/f/a5b964/32.png) [@fitmren\_lamhr](https://discuss.elastic.co/u/fitmren_lamhr)\
**Post date:** [March 20, 2018, 6:02am UTC](https://discuss.elastic.co/t/elasticsearch-cant-active/124686/5 "2018-03-20T06:02:41Z")

</div>

> [@fitmren\_lamhr](#):
>
> sudo systemctl status elasticsearch

hello, i've tried but status still failed

---

<div class="post-metadata">

**Author:** ![Shaik\_Thowsif](https://avatars.discourse-cdn.com/v4/letter/s/3d9bf3/32.png) [@Shaik\_Thowsif](https://discuss.elastic.co/u/Shaik_Thowsif)\
**Post date:** [March 20, 2018, 6:06am UTC](https://discuss.elastic.co/t/elasticsearch-cant-active/124686/6 "2018-03-20T06:06:10Z")

</div>

> [@harshbajaj16](#):
>
> you

you can kill port using this command "netstat -nlp|grep 9200"  
after that u will see jobid or pid of port then kill the port using this command  
"kill -9 pid" (pid means jobid).  
After killing port you can restart your system then do this command  
1)sudo service elasticsearch start  
2)sudo service elasticsearch status

---

<div class="post-metadata">

**Author:** ![fitmren\_lamhr](https://avatars.discourse-cdn.com/v4/letter/f/a5b964/32.png) [@fitmren\_lamhr](https://discuss.elastic.co/u/fitmren_lamhr)\
**Post date:** [March 20, 2018, 6:08am UTC](https://discuss.elastic.co/t/elasticsearch-cant-active/124686/7 "2018-03-20T06:08:06Z")

</div>

yes, the version is 2.4.6

---

<div class="post-metadata">

**Author:** ![fitmren\_lamhr](https://avatars.discourse-cdn.com/v4/letter/f/a5b964/32.png) [@fitmren\_lamhr](https://discuss.elastic.co/u/fitmren_lamhr)\
**Post date:** [March 20, 2018, 6:11am UTC](https://discuss.elastic.co/t/elasticsearch-cant-active/124686/8 "2018-03-20T06:11:23Z")

</div>

> [@Shaik\_Thowsif](#):
>
> netstat -nlp|grep 9200

thank you for suggest, but i tried netstat -nlp|grep 9200 it didn't show the jobid.

---

<div class="post-metadata">

**Author:** ![fitmren\_lamhr](https://avatars.discourse-cdn.com/v4/letter/f/a5b964/32.png) [@fitmren\_lamhr](https://discuss.elastic.co/u/fitmren_lamhr)\
**Post date:** [March 20, 2018, 6:13am UTC](https://discuss.elastic.co/t/elasticsearch-cant-active/124686/9 "2018-03-20T06:13:55Z")

</div>

![Capture](https://us1.discourse-cdn.com/elastic/original/3X/b/f/bfe27f5ba62c1c1f25cef759f09864d46663e504.PNG)

---

<div class="post-metadata">

**Author:** ![Shaik\_Thowsif](https://avatars.discourse-cdn.com/v4/letter/s/3d9bf3/32.png) [@Shaik\_Thowsif](https://discuss.elastic.co/u/Shaik_Thowsif)\
**Post date:** [March 20, 2018, 6:16am UTC](https://discuss.elastic.co/t/elasticsearch-cant-active/124686/10 "2018-03-20T06:16:17Z")

</div>

try this command  
netstat -a -n | grep tcp |grep 9200

---

<div class="post-metadata">

**Author:** ![fitmren\_lamhr](https://avatars.discourse-cdn.com/v4/letter/f/a5b964/32.png) [@fitmren\_lamhr](https://discuss.elastic.co/u/fitmren_lamhr)\
**Post date:** [March 20, 2018, 6:21am UTC](https://discuss.elastic.co/t/elasticsearch-cant-active/124686/11 "2018-03-20T06:21:18Z")

</div>

![Capture](https://us1.discourse-cdn.com/elastic/original/3X/6/d/6da8cc90928b02a2be8b13e66a1a878cb6590fdc.PNG)  
it still didn't show anything

---

<div class="post-metadata">

**Author:** ![Shaik\_Thowsif](https://avatars.discourse-cdn.com/v4/letter/s/3d9bf3/32.png) [@Shaik\_Thowsif](https://discuss.elastic.co/u/Shaik_Thowsif)\
**Post date:** [March 20, 2018, 6:34am UTC](https://discuss.elastic.co/t/elasticsearch-cant-active/124686/12 "2018-03-20T06:34:02Z")

</div>

have you restarted your system

---

<div class="post-metadata">

**Author:** ![fitmren\_lamhr](https://avatars.discourse-cdn.com/v4/letter/f/a5b964/32.png) [@fitmren\_lamhr](https://discuss.elastic.co/u/fitmren_lamhr)\
**Post date:** [March 20, 2018, 6:39am UTC](https://discuss.elastic.co/t/elasticsearch-cant-active/124686/13 "2018-03-20T06:39:04Z")

</div>

yep. i just restarting system, then i try again. but still same

---

<div class="post-metadata">

**Author:** ![Shaik\_Thowsif](https://avatars.discourse-cdn.com/v4/letter/s/3d9bf3/32.png) [@Shaik\_Thowsif](https://discuss.elastic.co/u/Shaik_Thowsif)\
**Post date:** [March 20, 2018, 6:49am UTC](https://discuss.elastic.co/t/elasticsearch-cant-active/124686/14 "2018-03-20T06:49:22Z")

</div>

check configuration file once

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [April 17, 2018, 6:49am UTC](https://discuss.elastic.co/t/elasticsearch-cant-active/124686/15 "2018-04-17T06:49:29Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
