# Elasticsearch - Certificate Error

**URL:** https://discuss.elastic.co/t/elasticsearch-certificate-error/337489
**Category:** Elasticsearch
**Created:** [July 3, 2023, 4:55pm UTC](https://discuss.elastic.co/t/elasticsearch-certificate-error/337489 "2023-07-03T16:55:47Z")
**Posts on this page:** 3
**Page:** 1

<div class="post-metadata">

### Author: ![Brian-cf1](https://avatars.discourse-cdn.com/v4/letter/b/b77776/32.png) [@Brian-cf1](https://discuss.elastic.co/u/Brian-cf1)
#### Post date: [July 3, 2023, 4:55pm UTC](https://discuss.elastic.co/t/elasticsearch-certificate-error/337489/1 "2023-07-03T16:55:47Z")

</div>

```auto
Failed to connect to backoff(elasticsearch(https://es:9200)): Get "https://e
Jul 03 16:52:00 elasticsearch_host metricbeat[1700]: 2023-07-03T16:52:00.717Z INFO [publisher_pipeline_output] pipeline/output.go:145 Attempting to reconnect to backoff(elasticsearch(https://es:9200)) with 5460
Jul 03 16:52:00 elasticsearch_host metricbeat[1700]: 2023-07-03T16:52:00.717Z INFO [publisher] pipeline/retry.go:213 retryer: send wait signal to consumer
Jul 03 16:52:00 elasticsearch_host metricbeat[1700]: 2023-07-03T16:52:00.717Z INFO [publisher] pipeline/retry.go:217 done
Jul 03 16:52:00 elasticsearch_host metricbeat[1700]: 2023-07-03T16:52:00.722Z ERROR [esclientleg] transport/logging.go:37 Error dialing x509: certificate signed by unknown authority (possibly because of "cyrpto/rsa

```

any ideas what this could mean ?

---

<div class="post-metadata">

### Author: ![stephenb](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/stephenb/32/40856_2.png) [@stephenb](https://discuss.elastic.co/u/stephenb)
#### Post date: [July 3, 2023, 6:15pm UTC](https://discuss.elastic.co/t/elasticsearch-certificate-error/337489/2 "2023-07-03T18:15:10Z")

</div>

Hi @Brian-cf1 Welcome to the community!!

And.. 🙂

You're going to have to provide much more context if you want help...

What are you trying to do When you got this error, perhaps trying to get metricbeat to connect with elasticsearch? But hard

That's just a guess because no context...

If so, please provide your filebeat.yml and your elasticsearch.yml.

Did you set up Elastic search with the automatically configured security?

Did you run the following to test connectivity

`filebeat test output`

Did you try to run a curl command between the file beat host and the elasticsearch host using the URLs and credentials?

Provide the. .ymls and run these commands. Let us know what you find out. Perhaps we can then help.

---

<div class="post-metadata">

### Author: ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)
#### Post date: [July 31, 2023, 6:15pm UTC](https://discuss.elastic.co/t/elasticsearch-certificate-error/337489/3 "2023-07-31T18:15:13Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
