# Elasticsearch client node in Docker unable to join non Docker cluster

**URL:** <https://discuss.elastic.co/t/elasticsearch-client-node-in-docker-unable-to-join-non-docker-cluster/40989>\
**Category:** Elasticsearch\
**Created:** [February 4, 2016, 5:28pm UTC](https://discuss.elastic.co/t/elasticsearch-client-node-in-docker-unable-to-join-non-docker-cluster/40989 "2016-02-04T17:28:43Z")\
**Posts on this page:** 3\
**Page:** 1

<div class="post-metadata">

**Author:** ![bvoros](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/bvoros/32/5246_2.png) [@bvoros](https://discuss.elastic.co/u/bvoros)\
**Post date:** [February 4, 2016, 5:28pm UTC](https://discuss.elastic.co/t/elasticsearch-client-node-in-docker-unable-to-join-non-docker-cluster/40989/1 "2016-02-04T17:28:43Z")

</div>

Hello All,

We have an 1.7.5 Elasticsearch cluster of 6 nodes.

I am trying to join a client only node that is on Docker and have been unable to apart from one time.

The Docker host is on the same network with the Elasticsearch cluster.

The ES client node did join once and it was then stopped the restarted out of curiosity and it was unable to rejoin the cluster after that.

Also tried deleting the container and launching a new one but it made no difference.

What could be causing this?

The ES related config looks like this:

es.cluster.name=ClusterName  
es.network.publish\_host=10.x.6.90  
es.http.port=9200-9300  
es.transport.tcp.port=9300-9400  
es.index.action.destructive\_requires\_name=true  
es.index.query.bool.max\_clause\_count=1000000  
es.indices.breaker.total.limit=75%  
es.threadpool.bulk.queue\_size=1000  
es.node.client=true  
es.node.data=false  
es.node.master=false  
es.http.enabled=false  
es.discovery.zen.ping.multicast.enabled=false  
es.discovery.zen.ping.unicast.hosts="10.x.6.80,10.x.6.81,10.x.6.82,10.x.7.80,10.x.7.81,10.x.7.82"

The error:  
17:03:50.859 [main] INFO org.elasticsearch.node - [Mangle] starting ...  
17:03:50.943 [main] INFO org.elasticsearch.transport - [Mangle] bound\_address {inet[/0:0:0:0:0:0:0:0:9300]}, publish\_address {inet[/10.x.6.90:9300]}  
17:03:50.958 [main] INFO org.elasticsearch.discovery - [Mangle] ClusterName/zj62\_vPpQYWNzV6kuJbrFg  
17:03:54.043 [elasticsearch[Mangle][generic][T#1]] INFO org.elasticsearch.discovery.zen - [Mangle] failed to send join request to master [[MasterNode3][2fq2A98lR9qnkS37WPyA5g][MasterNode3][inet[/10.x.6.82:9300]]{master=true}], reason [RemoteTransportException[[MasterNode3][inet[/10.x.6.82:9300]][internal:discovery/zen/join]]; nested: ConnectTransportException[[Mangle][inet[/10.x.6.90:9300]] connect\_timeout[30s]]; nested: ConnectException[Connection refused: /10.x.6.90:9300]; ]  
17:03:57.079 [elasticsearch[Mangle][generic][T#1]] INFO org.elasticsearch.discovery.zen - [Mangle] failed to send join request to master [[MasterNode3][2fq2A98lR9qnkS37WPyA5g][MasterNode3][inet[/10.x.6.82:9300]]{master=true}], reason [RemoteTransportException[[MasterNode3][inet[/10.x.6.82:9300]][internal:discovery/zen/join]]; nested: ConnectTransportException[[Mangle][inet[/10.x.6.90:9300]] connect\_timeout[30s]]; nested: ConnectException[Connection refused: /10.x.6.90:9300]; ]

---

<div class="post-metadata">

**Author:** ![bvoros](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/bvoros/32/5246_2.png) [@bvoros](https://discuss.elastic.co/u/bvoros)\
**Post date:** [February 5, 2016, 11:58am UTC](https://discuss.elastic.co/t/elasticsearch-client-node-in-docker-unable-to-join-non-docker-cluster/40989/2 "2016-02-05T11:58:53Z")

</div>

Some additional information on this.  
If the transport port is directly mapped (-p 9300:9300), it can join.

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [July 5, 2017, 11:18pm UTC](https://discuss.elastic.co/t/elasticsearch-client-node-in-docker-unable-to-join-non-docker-cluster/40989/3 "2017-07-05T23:18:36Z")

</div>


