# Elasticsearch Cluster 7.5.1 Not Working on docker

**URL:** <https://discuss.elastic.co/t/elasticsearch-cluster-7-5-1-not-working-on-docker/213327>\
**Category:** Elasticsearch\
**Tags:** docker\
**Created:** [December 30, 2019, 10:21am UTC](https://discuss.elastic.co/t/elasticsearch-cluster-7-5-1-not-working-on-docker/213327 "2019-12-30T10:21:03Z")\
**Posts on this page:** 16\
**Page:** 1

<div class="post-metadata">

**Author:** ![jayjit](https://avatars.discourse-cdn.com/v4/letter/j/9de0a6/32.png) [@jayjit](https://discuss.elastic.co/u/jayjit)\
**Post date:** [December 30, 2019, 10:21am UTC](https://discuss.elastic.co/t/elasticsearch-cluster-7-5-1-not-working-on-docker/213327/1 "2019-12-30T10:21:03Z")

</div>

Hi  
Our Elasticsearch Cluster 7.4.2 three node cluster was working great. But due once this is got upgrade to 7.5.1 cluster is not working. It is failing with following error.

Same docker-compose.yml was working to start Elasticsearch Cluster, but now it is giving error.

elasticsearch3 | {"type": "server", "timestamp": "2019-12-30T09:52:24,674Z", "level": "INFO", "component": "o.e.t.TransportService", "cluster.name": "docker-cluster", "node.name": "jana-es03", "message": "publish\_address {172.228.5.2:9300}, bound\_addresses {0.0.0.0:9300}" }  
elasticsearch3 | {"type": "server", "timestamp": "2019-12-30T09:52:24,785Z", "level": "INFO", "component": "o.e.b.BootstrapChecks", "cluster.name": "docker-cluster", "node.name": "jana-es03", "message": "bound or publishing to a non-loopback address, enforcing bootstrap checks" }  
elasticsearch2 | {"type": "server", "timestamp": "2019-12-30T09:52:24,908Z", "level": "INFO", "component": "o.e.t.TransportService", "cluster.name": "docker-cluster", "node.name": "jana-es02", "message": "publish\_address {172.228.5.3:9300}, bound\_addresses {0.0.0.0:9300}" }  
elasticsearch2 | {"type": "server", "timestamp": "2019-12-30T09:52:25,032Z", "level": "INFO", "component": "o.e.b.BootstrapChecks", "cluster.name": "docker-cluster", "node.name": "jana-es02", "message": "bound or publishing to a non-loopback address, enforcing bootstrap checks" }  
elasticsearch | {"type": "server", "timestamp": "2019-12-30T09:52:32,007Z", "level": "WARN", "component": "o.e.c.c.ClusterFormationFailureHelper", "cluster.name": "docker-cluster", "node.name": "jana-es01", "message": "master not discovered yet, this node has not previously joined a bootstrapped (v7+) cluster, and this node must discover master-eligible nodes [jana-es01, jana-es02, jana-es03] to bootstrap a cluster: have discovered [{jana-es01}{oXxDspbBREu2pPg-XEIVbw}{7tuXgP1oSyegGOJXHHFz9A}{172.228.5.1}{172.228.5.1:9300}{dim}]; discovery will continue using [172.228.5.3:9300, 172.228.5.2:9300] from hosts providers and [{jana-es01}{oXxDspbBREu2pPg-XEIVbw}{7tuXgP1oSyegGOJXHHFz9A}{172.228.5.1}{172.228.5.1:9300}{dim}] from last-known cluster state; node term 0, last-accepted version 0 in term 0" }  
elasticsearch3 | {"type": "server", "timestamp": "2019-12-30T09:52:34,806Z", "level": "WARN", "component": "o.e.c.c.ClusterFormationFailureHelper", "cluster.name": "docker-cluster", "node.name": "jana-es03", "message": "master not discovered yet, this node has not previously joined a bootstrapped (v7+) cluster, and this node must discover master-eligible nodes [jana-es01, jana-es02, jana-es03] to bootstrap a cluster: have discovered [{jana-es03}{7UG1s50jTK2v18SBCwmYyg}{qF56KrjMRsWAGnpWjEMy5A}{172.228.5.2}{172.228.5.2:9300}{dim}]; discovery will continue using [172.228.5.1:9300, 172.228.5.3:9300] from hosts providers and [{jana-es03}{7UG1s50jTK2v18SBCwmYyg}{qF56KrjMRsWAGnpWjEMy5A}{172.228.5.2}{172.228.5.2:9300}{dim}] from last-known cluster state; node term 0, last-accepted version 0 in term 0" }  
elasticsearch2 | {"type": "server", "timestamp": "2019-12-30T09:52:35,074Z", "level": "WARN", "component": "o.e.c.c.ClusterFormationFailureHelper", "cluster.name": "docker-cluster", "node.name": "jana-es02", "message": "master not discovered yet, this node has not previously joined a bootstrapped (v7+) cluster, and this node must discover master-eligible nodes [jana-es01, jana-es02, jana-es03] to bootstrap a cluster: have discovered [{jana-es02}{K5IUkCRpTXi1NNTTi6l7eQ}{spcBW1kYQZW6KzTEWNr\_Kw}{172.228.5.3}{172.228.5.3:9300}{dim}]; discovery will continue using [172.228.5.1:9300, 172.228.5.2:9300] from hosts providers and [{jana-es02}{K5IUkCRpTXi1NNTTi6l7eQ}{spcBW1kYQZW6KzTEWNr\_Kw}{172.228.5.3}{172.228.5.3:9300}{dim}] from last-known cluster state; node term 0, last-accepted version 0 in term 0" }  
jana-kibana | {"type":"log","@timestamp":"2019-12-30T09:52:35Z","tags":["warning","migrations"],"pid":9,"message":"Unable to connect to Elasticsearch. Error: Request Timeout after 30000ms"}  
elasticsearch | {"type": "server", "timestamp": "2019-12-30T09:52:42,010Z", "level": "WARN", "component": "o.e.c.c.ClusterFormationFailureHelper", "cluster.name": "docker-cluster", "node.name": "jana-es01", "message": "master not discovered yet, this node has not previously joined a bootstrapped (v7+) cluster, and this node must discover master-eligible nodes [jana-es01, jana-es02, jana-es03] to bootstrap a cluster: have discovered [{jana-es01}{oXxDspbBREu2pPg-XEIVbw}{7tuXgP1oSyegGOJXHHFz9A}{172.228.5.1}{172.228.5.1:9300}{dim}]; discovery will continue using [172.228.5.3:9300, 172.228.5.2:9300] from hosts providers and [{jana-es01}{oXxDspbBREu2pPg-XEIVbw}{7tuXgP1oSyegGOJXHHFz9A}{172.228.5.1}{172.228.5.1:9300}{dim}] from last-known cluster state; node term 0, last-accepted version 0 in term 0" }  
elasticsearch3 | {"type": "server", "timestamp": "2019-12-30T09:52:44,808Z", "level": "WARN", "component": "o.e.c.c.ClusterFormationFailureHelper", "cluster.name": "docker-cluster", "node.name": "jana-es03", "message": "master not discovered yet, this node has not previously joined a bootstrapped (v7+) cluster, and this node must discover master-eligible nodes [jana-es01, jana-es02, jana-es03] to bootstrap a cluster: have discovered [{jana-es03}{7UG1s50jTK2v18SBCwmYyg}{qF56KrjMRsWAGnpWjEMy5A}{172.228.5.2}{172.228.5.2:9300}{dim}]; discovery will continue using [172.228.5.1:9300, 172.228.5.3:9300] from hosts providers and [{jana-es03}{7UG1s50jTK2v18SBCwmYyg}{qF56KrjMRsWAGnpWjEMy5A}{172.228.5.2}{172.228.5.2:9300}{dim}] from last-known cluster state; node term 0, last-accepted version 0 in term 0" }  
elasticsearch2 | {"type": "server", "timestamp": "2019-12-30T09:52:45,077Z", "level": "WARN", "component": "o.e.c.c.ClusterFormationFailureHelper", "cluster.name": "docker-cluster", "node.name": "jana-es02", "message": "master not discovered yet, this node has not previously joined a bootstrapped (v7+) cluster, and this node must discover master-eligible nodes [jana-es01, jana-es02, jana-es03] to bootstrap a cluster: have discovered [{jana-es02}{K5IUkCRpTXi1NNTTi6l7eQ}{spcBW1kYQZW6KzTEWNr\_Kw}{172.228.5.3}{172.228.5.3:9300}{dim}]; discovery will continue using [172.228.5.1:9300, 172.228.5.2:9300] from hosts providers and [{jana-es02}{K5IUkCRpTXi1NNTTi6l7eQ}{spcBW1kYQZW6KzTEWNr\_Kw}{172.228.5.3}{172.228.5.3:9300}{dim}] from last-known cluster state; node term 0, last-accepted version 0 in term 0" }  
elasticsearch | {"type": "server", "timestamp": "2019-12-30T09:52:52,012Z", "level": "WARN", "component": "o.e.c.c.ClusterFormationFailureHelper", "cluster.name": "docker-cluster", "node.name": "jana-es01", "message": "master not discovered yet, this node has not previously joined a bootstrapped (v7+) cluster, and this node must discover master-eligible nodes [jana-es01, jana-es02, jana-es03] to bootstrap a cluster: have discovered [{jana-es01}{oXxDspbBREu2pPg-XEIVbw}{7tuXgP1oSyegGOJXHHFz9A}{172.228.5.1}{172.228.5.1:9300}{dim}]; discovery will continue using [172.228.5.3:9300, 172.228.5.2:9300] from hosts providers and [{jana-es01}{oXxDspbBREu2pPg-XEIVbw}{7tuXgP1oSyegGOJXHHFz9A}{172.228.5.1}{172.228.5.1:9300}{dim}] from last-known cluster state; node term 0, last-accepted version 0 in term 0" }  
elasticsearch | {"type": "server", "timestamp": "2019-12-30T09:52:52,073Z", "level": "WARN", "component": "o.e.n.Node", "cluster.name": "docker-cluster", "node.name": "jana-es01", "message": "timed out while waiting for initial discovery state - timeout: 30s" }  
elasticsearch | {"type": "server", "timestamp": "2019-12-30T09:52:52,088Z", "level": "INFO", "component": "o.e.h.AbstractHttpServerTransport", "cluster.name": "docker-cluster", "node.name": "jana-es01", "message": "publish\_address {172.228.5.1:9200}, bound\_addresses {0.0.0.0:9200}" }  
elasticsearch | {"type": "server", "timestamp": "2019-12-30T09:52:52,088Z", "level": "INFO", "component": "o.e.n.Node", "cluster.name": "docker-cluster", "node.name": "jana-es01", "message": "started" }  
elasticsearch3 | {"type": "server", "timestamp": "2019-12-30T09:52:54,810Z", "level": "WARN", "component": "o.e.c.c.ClusterFormationFailureHelper", "cluster.name": "docker-cluster", "node.name": "jana-es03", "message": "master not discovered yet, this node has not previously joined a bootstrapped (v7+) cluster, and this node must discover master-eligible nodes [jana-es01, jana-es02, jana-es03] to bootstrap a cluster: have discovered [{jana-es03}{7UG1s50jTK2v18SBCwmYyg}{qF56KrjMRsWAGnpWjEMy5A}{172.228.5.2}{172.228.5.2:9300}{dim}]; discovery will continue using [172.228.5.1:9300, 172.228.5.3:9300] from hosts providers and [{jana-es03}{7UG1s50jTK2v18SBCwmYyg}{qF56KrjMRsWAGnpWjEMy5A}{172.228.5.2}{172.228.5.2:9300}{dim}] from last-known cluster state; node term 0, last-accepted version 0 in term 0" }  
elasticsearch3 | {"type": "server", "timestamp": "2019-12-30T09:52:54,833Z", "level": "WARN", "component": "o.e.n.Node", "cluster.name": "docker-cluster", "node.name": "jana-es03", "message": "timed out while waiting for initial discovery state - timeout: 30s" }  
elasticsearch3 | {"type": "server", "timestamp": "2019-12-30T09:52:54,852Z", "level": "INFO", "component": "o.e.h.AbstractHttpServerTransport", "cluster.name": "docker-cluster", "node.name": "jana-es03", "message": "publish\_address {172.228.5.2:9200}, bound\_addresses {0.0.0.0:9200}" }  
elasticsearch3 | {"type": "server", "timestamp": "2019-12-30T09:52:54,852Z", "level": "INFO", "component": "o.e.n.Node", "cluster.name": "docker-cluster", "node.name": "jana-es03", "message": "started" }  
elasticsearch2 | {"type": "server", "timestamp": "2019-12-30T09:52:55,078Z", "level": "WARN", "component": "o.e.c.c.ClusterFormationFailureHelper", "cluster.name": "docker-cluster", "node.name": "jana-es02", "message": "master not discovered yet, this node has not previously joined a bootstrapped (v7+) cluster, and this node must discover master-eligible nodes [jana-es01, jana-es02, jana-es03] to bootstrap a cluster: have discovered [{jana-es02}{K5IUkCRpTXi1NNTTi6l7eQ}{spcBW1kYQZW6KzTEWNr\_Kw}{172.228.5.3}{172.228.5.3:9300}{dim}]; discovery will continue using [172.228.5.1:9300, 172.228.5.2:9300] from hosts providers and [{jana-es02}{K5IUkCRpTXi1NNTTi6l7eQ}{spcBW1kYQZW6KzTEWNr\_Kw}{172.228.5.3}{172.228.5.3:9300}{dim}] from last-known cluster state; node term 0, last-accepted version 0 in term 0" }  
elasticsearch2 | {"type": "server", "timestamp": "2019-12-30T09:52:55,098Z", "level": "WARN", "component": "o.e.n.Node", "cluster.name": "docker-cluster", "node.name": "jana-es02", "message": "timed out while waiting for initial discovery state - timeout: 30s" }  
elasticsearch2 | {"type": "server", "timestamp": "2019-12-30T09:52:55,123Z", "level": "INFO", "component": "o.e.h.AbstractHttpServerTransport", "cluster.name": "docker-cluster", "node.name": "jana-es02", "message": "publish\_address {172.228.5.3:9200}, bound\_addresses {0.0.0.0:9200}" }  
elasticsearch2 | {"type": "server", "timestamp": "2019-12-30T09:52:55,123Z", "level": "INFO", "component": "o.e.n.Node", "cluster.name": "docker-cluster", "node.name": "jana-es02", "message": "started" }  
elasticsearch | {"type": "server", "timestamp": "2019-12-30T09:53:02,013Z", "level": "WARN", "component": "o.e.c.c.ClusterFormationFailureHelper", "cluster.name": "docker-cluster", "node.name": "jana-es01", "message": "master not discovered yet, this node has not previously joined a bootstrapped (v7+) cluster, and this node must discover master-eligible nodes [jana-es01, jana-es02, jana-es03] to bootstrap a cluster: have discovered [{jana-es01}{oXxDspbBREu2pPg-XEIVbw}{7tuXgP1oSyegGOJXHHFz9A}{172.228.5.1}{172.228.5.1:9300}{dim}]; discovery will continue using [172.228.5.3:9300, 172.228.5.2:9300] from hosts providers and [{jana-es01}{oXxDspbBREu2pPg-XEIVbw}{7tuXgP1oSyegGOJXHHFz9A}{172.228.5.1}{172.228.5.1:9300}{dim}] from last-known cluster state; node term 0, last-accepted version 0 in term 0" }

---

<div class="post-metadata">

**Author:** ![Armin\_Braun](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/armin_braun/32/20092_2.png) [@Armin\_Braun](https://discuss.elastic.co/u/Armin_Braun)\
**Post date:** [December 30, 2019, 10:48am UTC](https://discuss.elastic.co/t/elasticsearch-cluster-7-5-1-not-working-on-docker/213327/2 "2019-12-30T10:48:35Z")

</div>

Hi @jayjit

did you make sure that the nodes can actually see each other on the network? It looks like they can't from those logs. Can you share your `docker-compose.yml`? Also, you are using the official ES docker images right?

---

<div class="post-metadata">

**Author:** ![jayjit](https://avatars.discourse-cdn.com/v4/letter/j/9de0a6/32.png) [@jayjit](https://discuss.elastic.co/u/jayjit)\
**Post date:** [December 30, 2019, 12:22pm UTC](https://discuss.elastic.co/t/elasticsearch-cluster-7-5-1-not-working-on-docker/213327/3 "2019-12-30T12:22:12Z")

</div>

Hi Armin,

Yes these are docker nodes so they are able to communicate, it seems Voting Configuration not happening in new version. Please let me know how can I share docker-compose file.

---

<div class="post-metadata">

**Author:** ![Armin\_Braun](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/armin_braun/32/20092_2.png) [@Armin\_Braun](https://discuss.elastic.co/u/Armin_Braun)\
**Post date:** [December 30, 2019, 12:29pm UTC](https://discuss.elastic.co/t/elasticsearch-cluster-7-5-1-not-working-on-docker/213327/4 "2019-12-30T12:29:18Z")

</div>

I'm mainly suspicious about the network connectivity here because I see no logging that indicates the nodes are actually seeing each other but I see:

> jana-kibana | {"type":"log","@timestamp":"2019-12-30T09:52:35Z","tags":["warning","migrations"],"pid":9,"message":"Unable to connect to Elasticsearch. Error: Request Timeout after 30000ms"}

So Kibana seems unable to physically connect to ES as well? (if the cluster was RED or so Kibana would throw a different error afaik).

> Please let me know how can I share docker-compose file.

You should be able to just paste the `docker-compose.yml` here (just quote it in ``` as a code block for readability ;))

---

<div class="post-metadata">

**Author:** ![jayjit](https://avatars.discourse-cdn.com/v4/letter/j/9de0a6/32.png) [@jayjit](https://discuss.elastic.co/u/jayjit)\
**Post date:** [December 30, 2019, 12:33pm UTC](https://discuss.elastic.co/t/elasticsearch-cluster-7-5-1-not-working-on-docker/213327/5 "2019-12-30T12:33:28Z")

</div>

version: '3.5'  
services:  
elasticsearch:  
image: [docker.elastic.co/elasticsearch/elasticsearch-oss:7.5.1](http://docker.elastic.co/elasticsearch/elasticsearch-oss:7.5.1)  
container\_name: elasticsearch  
environment:  
- node.name=jana-es01  
- node.master=true  
- node.data=true  
- node.ingest=true  
- discovery.seed\_hosts=elasticsearch,elasticsearch2,elasticsearch3  
- cluster.initial\_master\_nodes=jana-es01,jana-es02,jana-es03  
- cluster.name=docker-cluster  
- bootstrap.memory\_lock=true  
- http.cors.enabled=true  
- http.cors.allow-origin=\*  
- "ES\_JAVA\_OPTS=-Xms512m -Xmx512m"  
- timezone= "Asia/Kolkata"  
ulimits:  
memlock:  
soft: -1  
hard: -1  
volumes:  
- esdata1:/docker/elasticsearch/data  
ports:  
- 9030:9200  
networks:  
- jana-esnet  
elasticsearch2:  
image: [docker.elastic.co/elasticsearch/elasticsearch-oss:7.5.1](http://docker.elastic.co/elasticsearch/elasticsearch-oss:7.5.1)  
container\_name: elasticsearch2  
environment:  
- node.name=jana-es02  
- node.master=true  
- node.data=true  
- node.ingest=true  
- discovery.seed\_hosts=elasticsearch,elasticsearch2,elasticsearch3  
- cluster.initial\_master\_nodes=jana-es01,jana-es02,jana-es03  
- cluster.name=docker-cluster  
- bootstrap.memory\_lock=true  
- http.cors.enabled=true  
- http.cors.allow-origin=\*  
- "ES\_JAVA\_OPTS=-Xms512m -Xmx512m"  
- timezone= "Asia/Kolkata"  
ulimits:  
memlock:  
soft: -1  
hard: -1  
volumes:  
- esdata2:/docker/elasticsearch/data  
networks:  
- jana-esnet  
elasticsearch3:  
image: [docker.elastic.co/elasticsearch/elasticsearch-oss:7.5.1](http://docker.elastic.co/elasticsearch/elasticsearch-oss:7.5.1)  
container\_name: elasticsearch3  
environment:  
- node.name=jana-es03  
- node.master=true  
- node.data=true  
- node.ingest=true  
- discovery.seed\_hosts=elasticsearch,elasticsearch2,elasticsearch3  
- cluster.initial\_master\_nodes=jana-es01,jana-es02,jana-es03  
- cluster.name=docker-cluster  
- bootstrap.memory\_lock=true  
- http.cors.enabled=true  
- http.cors.allow-origin=\*  
- "ES\_JAVA\_OPTS=-Xms512m -Xmx512m"  
- timezone= "Asia/Kolkata"  
ulimits:  
memlock:  
soft: -1  
hard: -1  
volumes:  
- esdata3:/docker/elasticsearch/data  
networks:  
- jana-esnet  
kibana:  
image: '[docker.elastic.co/kibana/kibana-oss:7.5.1](http://docker.elastic.co/kibana/kibana-oss:7.5.1)'  
container\_name: jana-kibana  
environment:  
- discovery.seed\_hosts=elasticsearch,elasticsearch2,elasticsearch3  
- cluster.initial\_master\_nodes=jana-es01,jana-es02,jana-es03  
- cluster.name=docker-cluster  
- server\_name=jana-kibana  
- elasticsearch\_host=elasticsearch  
- elasticsearch\_url=http://elasticsearch:9030  
- timezone= "Asia/Kolkata"  
ports:  
- '5802:5601'  
volumes:  
- jana-kibana:/docker/jana-kibana/data  
networks:  
- jana-esnet  
volumes:  
esdata1:  
driver: local  
esdata2:  
driver: local  
esdata3:  
driver: local  
jana-kibana:  
driver: local  
networks:  
jana-esnet:  
external: true

---

<div class="post-metadata">

**Author:** ![Armin\_Braun](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/armin_braun/32/20092_2.png) [@Armin\_Braun](https://discuss.elastic.co/u/Armin_Braun)\
**Post date:** [December 30, 2019, 12:41pm UTC](https://discuss.elastic.co/t/elasticsearch-cluster-7-5-1-not-working-on-docker/213327/6 "2019-12-30T12:41:43Z")

</div>

> [@jayjit](#):
>
> jana-esnet

Why are you using this network as an `external` network? Maybe try to recreate that network?  
If that doesn't help can you share the details of the network from `docker network inspect jana-esnet`?

---

<div class="post-metadata">

**Author:** ![jayjit](https://avatars.discourse-cdn.com/v4/letter/j/9de0a6/32.png) [@jayjit](https://discuss.elastic.co/u/jayjit)\
**Post date:** [December 30, 2019, 1:12pm UTC](https://discuss.elastic.co/t/elasticsearch-cluster-7-5-1-not-working-on-docker/213327/7 "2019-12-30T13:12:49Z")

</div>

That is docker network already got created and was working fine.  
Please find output as following -  
NETWORK ID NAME DRIVER SCOPE  
19dea103b9b2 bridge bridge local  
a7c263772321 host host local  
59a509dbe89d jana-esnet bridge local  
412c21bdcd0b none null local  
root@sdruelstcap01:/docker# docker network inspect jana-esnet  
[  
{  
"Name": "jana-esnet",  
"Id": "59a509dbe89d9c4f778adcf770aa93577740c79b9f8b6a8de4af3a9a8c302a26",  
"Created": "2019-11-15T11:34:20.790851851Z",  
"Scope": "local",  
"Driver": "bridge",  
"EnableIPv6": false,  
"IPAM": {  
"Driver": "default",  
"Options": {},  
"Config": [  
{  
"Subnet": "172.228.0.0/16",  
"IPRange": "172.228.5.0/24",  
"Gateway": "172.228.0.1"  
}  
]  
},  
"Internal": false,  
"Attachable": true,  
"Ingress": false,  
"ConfigFrom": {  
"Network": ""  
},  
"ConfigOnly": false,  
"Containers": {  
"411effa710786c8b7c74833d66ac599f6923035f234a3e4823f3b7fbae0b38ff": {  
"Name": "elasticsearch3",  
"EndpointID": "414e6037fcb656ac4233d35470ef0def9d4f374230ec0e3f44bd66eea020f3a3",  
"MacAddress": "02:42:ac:e4:05:03",  
"IPv4Address": "172.228.5.3/16",  
"IPv6Address": ""  
},  
"ac4398ea4294a4050e09496d7e6aeeb059c7bc62b3f78fc98fc12ec0e5138d09": {  
"Name": "jana-kibana",  
"EndpointID": "2b5e59a4522ec477a4d3c08d8257414fab2032670f72b9c76f0c866cdc7c3224",  
"MacAddress": "02:42:ac:e4:05:00",  
"IPv4Address": "172.228.5.0/16",  
"IPv6Address": ""  
},  
"bc74be9204656a01e9942330713f7e93df3dc3c9cdd1e48dc15b682c42b82024": {  
"Name": "elasticsearch",  
"EndpointID": "f3d5272ae47473d290ddf6a529727464c66ba8a9774ece7e3c08091b9debedce",  
"MacAddress": "02:42:ac:e4:05:02",  
"IPv4Address": "172.228.5.2/16",  
"IPv6Address": ""  
},  
"f19fda05962d05eff0f5606dfc381826c7a085fe6865a5520905875223d15a4f": {  
"Name": "elasticsearch2",  
"EndpointID": "14096efe9acc24a15153491cbfaa25725b6d78d86cebf1388374e89e6048e5b9",  
"MacAddress": "02:42:ac:e4:05:01",  
"IPv4Address": "172.228.5.1/16",  
"IPv6Address": ""  
}  
},  
"Options": {},  
"Labels": {}  
}  
]

---

<div class="post-metadata">

**Author:** ![Armin\_Braun](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/armin_braun/32/20092_2.png) [@Armin\_Braun](https://discuss.elastic.co/u/Armin_Braun)\
**Post date:** [December 30, 2019, 1:37pm UTC](https://discuss.elastic.co/t/elasticsearch-cluster-7-5-1-not-working-on-docker/213327/8 "2019-12-30T13:37:27Z")

</div>

That network technically looks ok (though it's kind of weird that it allocated an IP ending in `.0` to Kibana, this is technically correct but I'm not sure it'll work fine in all environments). Did you verify the nodes can ping each other though by actually shelling into one of them via `docker exec` or similar?

---

<div class="post-metadata">

**Author:** ![jayjit](https://avatars.discourse-cdn.com/v4/letter/j/9de0a6/32.png) [@jayjit](https://discuss.elastic.co/u/jayjit)\
**Post date:** [December 30, 2019, 1:43pm UTC](https://discuss.elastic.co/t/elasticsearch-cluster-7-5-1-not-working-on-docker/213327/9 "2019-12-30T13:43:59Z")

</div>

This is working as vlan is same for docker network.  
I am having older logs where it was working as VotingConfiguration is coming after bootstrap checks.  
It seems issue with new version.  
Can you confirm if oss version support cluster??

elasticsearch | {"type": "server", "timestamp": "2019-09-20T16:04:11,981+0000", "level": "INFO", "component": "o.e.n.Node", "cluster.name": "docker-cluster", "node.name": "jana-es01", "message": "initialized" }  
elasticsearch | {"type": "server", "timestamp": "2019-09-20T16:04:11,984+0000", "level": "INFO", "component": "o.e.n.Node", "cluster.name": "docker-cluster", "node.name": "jana-es01", "message": "starting ..." }  
elasticsearch | {"type": "server", "timestamp": "2019-09-20T16:04:12,476+0000", "level": "INFO", "component": "o.e.t.TransportService", "cluster.name": "docker-cluster", "node.name": "jana-es01", "message": "publish\_address {172.228.5.4:9300}, bound\_addresses {0.0.0.0:9300}" }  
elasticsearch | {"type": "server", "timestamp": "2019-09-20T16:04:12,496+0000", "level": "INFO", "component": "o.e.b.BootstrapChecks", "cluster.name": "docker-cluster", "node.name": "jana-es01", "message": "bound or publishing to a non-loopback address, enforcing bootstrap checks" }  
elasticsearch | {"type": "server", "timestamp": "2019-09-20T16:04:13,343+0000", "level": "INFO", "component": "o.e.c.c.Coordinator", "cluster.name": "docker-cluster", "node.name": "jana-es01", "message": "setting initial configuration to VotingConfiguration{HrUwXCcVRGe9AMv3KTe2Hw,{bootstrap-placeholder}-jana-es02,DncMGLVwQGak7G2dfORZXQ}" }  
elasticsearch3 | {"type": "server", "timestamp": "2019-09-20T16:04:13,364+0000", "level": "INFO", "component": "o.e.c.c.Coordinator", "cluster.name": "docker-cluster", "node.name": "jana-es03", "message": "setting initial configuration to VotingConfiguration{HrUwXCcVRGe9AMv3KTe2Hw,{bootstrap-placeholder}-jana-es02,DncMGLVwQGak7G2dfORZXQ}" }

---

<div class="post-metadata">

**Author:** ![Armin\_Braun](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/armin_braun/32/20092_2.png) [@Armin\_Braun](https://discuss.elastic.co/u/Armin_Braun)\
**Post date:** [December 30, 2019, 1:56pm UTC](https://discuss.elastic.co/t/elasticsearch-cluster-7-5-1-not-working-on-docker/213327/10 "2019-12-30T13:56:27Z")

</div>

> This is working as vlan is same for docker network.

Kibana seems unable to connect to the ES cluster at the very least, though this seems due to using the host exposed port in setting `elasticsearch_url=http://elasticsearch:9030` instead of the port in the container network (9200) `elasticsearch_url=http://elasticsearch:9200`.

The fact that the network was working with other containers previously does not necessarily mean it's still properly functional. Again, as there is no indication that the nodes are actually seeing each other (no warnings logged on the network layer) it seems likely that they can't physically communicate and you should make sure they can by checking that at least pings go through between them on the docker network.

> [@jayjit](#):
>
> Can you confirm if oss version support cluster??

Yes it does support clustering in OSS.

---

<div class="post-metadata">

**Author:** ![jayjit](https://avatars.discourse-cdn.com/v4/letter/j/9de0a6/32.png) [@jayjit](https://discuss.elastic.co/u/jayjit)\
**Post date:** [December 30, 2019, 2:07pm UTC](https://discuss.elastic.co/t/elasticsearch-cluster-7-5-1-not-working-on-docker/213327/11 "2019-12-30T14:07:45Z")

</div>

Kibana is not working as elastic cluster not working.

Can help me to identify, Last cluster of 7.4.2 was non-OSS, can you confirm any changes required to run OSS cluster to work, any other parameters on docker-compose.yml file.

```
 Name Command State Ports

```

* * *

elasticsearch /usr/local/bin/docker-entr ... Up 0.0.0.0:9030-\>9200/tcp, 9300/tcp  
elasticsearch2 /usr/local/bin/docker-entr ... Up 9200/tcp, 9300/tcp  
elasticsearch3 /usr/local/bin/docker-entr ... Up 9200/tcp, 9300/tcp

---

<div class="post-metadata">

**Author:** ![Armin\_Braun](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/armin_braun/32/20092_2.png) [@Armin\_Braun](https://discuss.elastic.co/u/Armin_Braun)\
**Post date:** [December 30, 2019, 2:16pm UTC](https://discuss.elastic.co/t/elasticsearch-cluster-7-5-1-not-working-on-docker/213327/12 "2019-12-30T14:16:58Z")

</div>

@jayjit

> Kibana is not working as elastic cluster not working.

Kibana is pointed at the wrong port as far as I can tell, that's why it's timing out (if ES wasn't up and it could communicate with the REST endpoint of the node it would raise a different error and not just time out).

In the absence of any other information it still seems the most likely that there is some form of network communication issue between the nodes.  
Does it work if you run the same configuration against a fresh network like e.g.:

```auto
networks:
  elastic:
    driver: bridge

```

? That would be a thing to try first as well as checking the connectivity between nodes by shelling into them and trying a `ping`.

---

<div class="post-metadata">

**Author:** ![jayjit](https://avatars.discourse-cdn.com/v4/letter/j/9de0a6/32.png) [@jayjit](https://discuss.elastic.co/u/jayjit)\
**Post date:** [December 30, 2019, 2:21pm UTC](https://discuss.elastic.co/t/elasticsearch-cluster-7-5-1-not-working-on-docker/213327/13 "2019-12-30T14:21:49Z")

</div>

external elastic port is 9030  
ports:  
- 9030:9200  
so [http://elasticsearch:9030](http://elasticsearch:9030) at kibana docker is correct.

My concern is OSS version option rest I think is correct.

---

<div class="post-metadata">

**Author:** ![Armin\_Braun](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/armin_braun/32/20092_2.png) [@Armin\_Braun](https://discuss.elastic.co/u/Armin_Braun)\
**Post date:** [December 30, 2019, 2:24pm UTC](https://discuss.elastic.co/t/elasticsearch-cluster-7-5-1-not-working-on-docker/213327/14 "2019-12-30T14:24:49Z")

</div>

> [@jayjit](#):
>
> external elastic port is 9030  
> ports:
> 
> - 9030:9200  
> so [http://elasticsearch:9030](http://elasticsearch:9030) at kibana docker is correct.

But the Kibana container lives in the internal network as well so it must use the internal port and not the host exposed one?

---

<div class="post-metadata">

**Author:** ![jayjit](https://avatars.discourse-cdn.com/v4/letter/j/9de0a6/32.png) [@jayjit](https://discuss.elastic.co/u/jayjit)\
**Post date:** [December 31, 2019, 10:45am UTC](https://discuss.elastic.co/t/elasticsearch-cluster-7-5-1-not-working-on-docker/213327/15 "2019-12-31T10:45:26Z")

</div>

I able to fix the issue after drop and create docker network.

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [January 28, 2020, 10:45am UTC](https://discuss.elastic.co/t/elasticsearch-cluster-7-5-1-not-working-on-docker/213327/16 "2020-01-28T10:45:38Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
