# ElasticSearch Cluster do not work with Shield plugin

**URL:** <https://discuss.elastic.co/t/elasticsearch-cluster-do-not-work-with-shield-plugin/46967>\
**Category:** Elasticsearch\
**Created:** [April 11, 2016, 9:43am UTC](https://discuss.elastic.co/t/elasticsearch-cluster-do-not-work-with-shield-plugin/46967 "2016-04-11T09:43:19Z")\
**Posts on this page:** 4\
**Page:** 1

<div class="post-metadata">

**Author:** ![chtj2k001](https://avatars.discourse-cdn.com/v4/letter/c/bc79bd/32.png) [@chtj2k001](https://discuss.elastic.co/u/chtj2k001)\
**Post date:** [April 11, 2016, 9:43am UTC](https://discuss.elastic.co/t/elasticsearch-cluster-do-not-work-with-shield-plugin/46967/1 "2016-04-11T09:43:19Z")

</div>

I am using the ES 2.1.1. I have created a cluster with name "wisesearch", which included two node "wisesearch-node1" and "wisesearch-node2", it had worked fine until I installed Shield plugin.

After start node1, the node1's log show "[wisesearch-node1] failed to send join request to master" error. And the other hand, the node2's log show "java.net.NoRouteToHostException: No route to host". The ES will show "cluster\_block\_exception" error with query index:  
{  
"error" : {  
"root\_cause" : [ {  
"type" : "cluster\_block\_exception",  
"reason" : "blocked by: [SERVICE\_UNAVAILABLE/1/state not recovered / initialized];"  
} ],  
"type" : "cluster\_block\_exception",  
"reason" : "blocked by: [SERVICE\_UNAVAILABLE/1/state not recovered / initialized];"  
},  
"status" : 503  
}

Node1's log:  
[2016-04-11 17:35:05,870][INFO][discovery.zen] [wisesearch-node1] failed to send join request to master [{wisesearch-node2}{WSGMaGHSQEyrHZmONb8J6w}{10.47.211.106}{10.47.211.106:9300}], reason [RemoteTransportException[[wisesearch-node2][10.47.211.106:9300][internal:discovery/zen/join]]; nested: ConnectTransportException[[wisesearch-node1][10.47.211.95:9300] connect\_timeout[30s]]; nested: NotSerializableExceptionWrapper[No route to host]; ]

Node2's log:  
[2016-04-11 17:35:37,562][WARN][shield.transport.netty] [wisesearch-node2] exception caught on transport layer [[id: 0x14feb6ff]], closing connection  
java.net.NoRouteToHostException: No route to host  
at sun.nio.ch.SocketChannelImpl.checkConnect(Native Method)  
at sun.nio.ch.SocketChannelImpl.finishConnect(SocketChannelImpl.java:717)  
at org.jboss.netty.channel.socket.nio.NioClientBoss.connect(NioClientBoss.java:152)

The Node1's elasticsearch.yum file:  
[cluster.name](http://cluster.name): wisesearch  
[node.name](http://node.name): wisesearch-node1  
network.host: 0.0.0.0  
discovery.zen.ping.unicast.hosts: ["10.47.211.106"]  
discovery.zen.minimum\_master\_nodes: 2  
shield.audit.enabled: true

The Node2's elasticsearch.yum file:  
[cluster.name](http://cluster.name): wisesearch  
[node.name](http://node.name): wisesearch-node2  
network.host: 0.0.0.0  
discovery.zen.ping.unicast.hosts: ["10.47.211.95"]  
discovery.zen.minimum\_master\_nodes: 2  
shield.audit.enabled: true

---

<div class="post-metadata">

**Author:** ![chtj2k001](https://avatars.discourse-cdn.com/v4/letter/c/bc79bd/32.png) [@chtj2k001](https://discuss.elastic.co/u/chtj2k001)\
**Post date:** [April 12, 2016, 1:48am UTC](https://discuss.elastic.co/t/elasticsearch-cluster-do-not-work-with-shield-plugin/46967/2 "2016-04-12T01:48:30Z")

</div>

Does anyone know how to fix this? Thanks!!

---

<div class="post-metadata">

**Author:** ![warkolm](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/warkolm/32/39224_2.png) [@warkolm](https://discuss.elastic.co/u/warkolm)\
**Post date:** [April 12, 2016, 3:59am UTC](https://discuss.elastic.co/t/elasticsearch-cluster-do-not-work-with-shield-plugin/46967/3 "2016-04-12T03:59:15Z")

</div>

We solved this in [After use Shield, the ES cluster do not work](https://discuss.elastic.co/t/after-use-shield-the-es-cluster-do-not-work/47061/3)

However in future, please do not cross post 🙂

---

<div class="post-metadata">

**Author:** ![warkolm](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/warkolm/32/39224_2.png) [@warkolm](https://discuss.elastic.co/u/warkolm)\
**Post date:** [April 12, 2016, 3:59am UTC](https://discuss.elastic.co/t/elasticsearch-cluster-do-not-work-with-shield-plugin/46967/4 "2016-04-12T03:59:17Z")

</div>


