# Elasticsearch cluster new Node addition error

**URL:** https://discuss.elastic.co/t/elasticsearch-cluster-new-node-addition-error/365429
**Category:** Elasticsearch
**Created:** [August 23, 2024, 7:05am UTC](https://discuss.elastic.co/t/elasticsearch-cluster-new-node-addition-error/365429 "2024-08-23T07:05:50Z")
**Posts on this page:** 9
**Page:** 1

<div class="post-metadata">

### Author: ![saxena\_shk7](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/saxena_shk7/32/132741_2.png) [@saxena\_shk7](https://discuss.elastic.co/u/saxena_shk7)
#### Post date: [August 23, 2024, 7:05am UTC](https://discuss.elastic.co/t/elasticsearch-cluster-new-node-addition-error/365429/1 "2024-08-23T07:05:50Z")

</div>

I am trying to add third node in my elasticsearch existing cluster, but is unable to do so. I have tried everything from uncommenting transport.host option and setting it to 0.0.0.0 also setting discovery.seed\_host to master-node IP but still its giving this error

 ![Capture](https://us1.discourse-cdn.com/elastic/original/3X/b/5/b52f7878811325100c8a7605fda66ba00ea5f870.jpeg)

---

<div class="post-metadata">

### Author: ![Tortoise](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/tortoise/32/147587_2.png) [@Tortoise](https://discuss.elastic.co/u/Tortoise)
#### Post date: [August 23, 2024, 8:08am UTC](https://discuss.elastic.co/t/elasticsearch-cluster-new-node-addition-error/365429/2 "2024-08-23T08:08:44Z")

</div>

Could you please share the uncommented entries from elasticsearch.yml in order to review further. Also on the 3 node which you want to add it should be using reconfigure command.

/usr/share/elasticsearch/bin/elasticsearch-reconfigure-node --enrollment-token

---

<div class="post-metadata">

### Author: ![saxena\_shk7](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/saxena_shk7/32/132741_2.png) [@saxena\_shk7](https://discuss.elastic.co/u/saxena_shk7)
#### Post date: [August 23, 2024, 9:18am UTC](https://discuss.elastic.co/t/elasticsearch-cluster-new-node-addition-error/365429/3 "2024-08-23T09:18:26Z")

</div>

======================== Elasticsearch Configuration =========================

# 

# NOTE: Elasticsearch comes with reasonable defaults for most settings.

# Before you set out to tweak and tune the configuration, make sure you

# understand what are you trying to accomplish and the consequences.

# 

# The primary way of configuring a node is via this file. This template lists

# the most important settings you may want to configure for a production cluster.

# 

# Please consult the documentation for further information on configuration options:

# [Elasticsearch Guide | Elastic](https://www.elastic.co/guide/en/elasticsearch/reference/index.html)

# 

# ---------------------------------- Cluster -----------------------------------

# 

# Use a descriptive name for your cluster:

# 

#[cluster.name](http://cluster.name): my-application

# 

# ------------------------------------ Node ------------------------------------

# 

# Use a descriptive name for the node:

# 

#[node.name](http://node.name): node-1

# 

# Add custom attributes to the node:

# 

#node.attr.rack: r1

# 

# ----------------------------------- Paths ------------------------------------

# 

# Path to directory where to store the data (separate multiple locations by comma):

# 

path.data: /var/lib/elasticsearch

# 

# Path to log files:

# 

path.logs: /var/log/elasticsearch

# 

# ----------------------------------- Memory -----------------------------------

# 

# Lock the memory on startup:

# 

#bootstrap.memory\_lock: true

# 

# Make sure that the heap size is set to about half the memory available

# on the system and that the owner of the process is allowed to use this

# limit.

# 

# Elasticsearch performs poorly when the system is swapping the memory.

# 

# ---------------------------------- Network -----------------------------------

# 

# By default Elasticsearch is only accessible on localhost. Set a different

# address here to expose this node on the network:

# 

#network.host: 192.168.0.1

# 

# By default Elasticsearch listens for HTTP traffic on the first free port it

# finds starting at 9200. Set a specific HTTP port here:

# 

#http.port: 9200

# 

# For more information, consult the network module documentation.

# 

# --------------------------------- Discovery ----------------------------------

# 

# Pass an initial list of hosts to perform discovery when this node is started:

# The default list of hosts is ["127.0.0.1", "[::1]"]

discovery.seed\_hosts: ["[196.1.111.61:9300](http://196.1.111.61:9300)"]

# 

# Bootstrap the cluster using an initial set of master-eligible nodes:

# 

#cluster.initial\_master\_nodes: ["node-1", "node-2"]

# 

# For more information, consult the discovery and cluster formation module documentation.

# 

# ---------------------------------- Various -----------------------------------

# 

# Allow wildcard deletion of indices:

# 

#action.destructive\_requires\_name: false

this is my config file for Node-3 and i already ran this command of elasticsearch-reconfigure-node --enrollment token

---

<div class="post-metadata">

### Author: ![Tortoise](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/tortoise/32/147587_2.png) [@Tortoise](https://discuss.elastic.co/u/Tortoise)
#### Post date: [August 23, 2024, 9:37am UTC](https://discuss.elastic.co/t/elasticsearch-cluster-new-node-addition-error/365429/4 "2024-08-23T09:37:40Z")

</div>

Hello,

Thank you for the details. Below are the parameters should be uncommented :

cluster.name: \*\*\*\*\* (from my master or original running node)  
node.name: node3  
network.host: IP address of this host  
http.port: 9200  
transport.host: 0.0.0.0  
discovery.seed\_hosts:

- 1.1.1.1

Thanks,

---

<div class="post-metadata">

### Author: ![saxena\_shk7](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/saxena_shk7/32/132741_2.png) [@saxena\_shk7](https://discuss.elastic.co/u/saxena_shk7)
#### Post date: [August 23, 2024, 9:49am UTC](https://discuss.elastic.co/t/elasticsearch-cluster-new-node-addition-error/365429/5 "2024-08-23T09:49:04Z")

</div>

Thanks for your reply, but still after changing the above parameters its giving this error.

 ![Capture1](https://us1.discourse-cdn.com/elastic/original/3X/7/a/7a8b0f59c6e14c76b218c378e925d5f3af344c13.jpeg)

# ======================== Elasticsearch Configuration =========================

# 

# NOTE: Elasticsearch comes with reasonable defaults for most settings.

# Before you set out to tweak and tune the configuration, make sure you

# understand what are you trying to accomplish and the consequences.

# 

# The primary way of configuring a node is via this file. This template lists

# the most important settings you may want to configure for a production cluster.

# 

# Please consult the documentation for further information on configuration options:

# [Elasticsearch Guide | Elastic](https://www.elastic.co/guide/en/elasticsearch/reference/index.html)

# 

# ---------------------------------- Cluster -----------------------------------

# 

# Use a descriptive name for your cluster:

# 

[cluster.name](http://cluster.name): ims-cluster

# 

# ------------------------------------ Node ------------------------------------

# 

# Use a descriptive name for the node:

# 

[node.name](http://node.name): node-3

# 

# Add custom attributes to the node:

# 

#node.attr.rack: r1

# 

# ----------------------------------- Paths ------------------------------------

# 

# Path to directory where to store the data (separate multiple locations by comma):

# 

path.data: /var/lib/elasticsearch

# 

# Path to log files:

# 

path.logs: /var/log/elasticsearch

# 

# ----------------------------------- Memory -----------------------------------

# 

# Lock the memory on startup:

# 

#bootstrap.memory\_lock: true

# 

# Make sure that the heap size is set to about half the memory available

# on the system and that the owner of the process is allowed to use this

# limit.

# 

# Elasticsearch performs poorly when the system is swapping the memory.

# 

# ---------------------------------- Network -----------------------------------

# 

# By default Elasticsearch is only accessible on localhost. Set a different

# address here to expose this node on the network:

# 

network.host: 196.1.111.65

# 

# By default Elasticsearch listens for HTTP traffic on the first free port it

# finds starting at 9200. Set a specific HTTP port here:

# 

http.port: 9200  
transport.host: 0.0.0.0

# 

# For more information, consult the network module documentation.

# 

# --------------------------------- Discovery ----------------------------------

# 

# Pass an initial list of hosts to perform discovery when this node is started:

# The default list of hosts is ["127.0.0.1", "[::1]"]

discovery.seed\_hosts:

- 196.1.111.61

# 

# Bootstrap the cluster using an initial set of master-eligible nodes:

# 

#cluster.initial\_master\_nodes: ["node-1", "node-2"]

# 

# For more information, consult the discovery and cluster formation module documentation.

# 

# ---------------------------------- Various -----------------------------------

# 

# Allow wildcard deletion of indices:

# 

#action.destructive\_requires\_name: false

---

<div class="post-metadata">

### Author: ![Tortoise](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/tortoise/32/147587_2.png) [@Tortoise](https://discuss.elastic.co/u/Tortoise)
#### Post date: [August 23, 2024, 10:02am UTC](https://discuss.elastic.co/t/elasticsearch-cluster-new-node-addition-error/365429/7 "2024-08-23T10:02:36Z")

</div>

Hello,

Please check below documents

> [@This node doesn't appear to be auto-configured for security. Expected configuration is missing from elasticsearch.yml](https://discuss.elastic.co/t/this-node-doesnt-appear-to-be-auto-configured-for-security-expected-configuration-is-missing-from-elasticsearch-yml/339649):
>
> Kindly Help, While the Elasticsearch is with the default elasticsearch.yml it is giving such error /usr/share/elasticsearch/bin/elasticsearch-reconfigure-node --enrollment-token Generates all the necessary security configuration for a node in a secured cluster Option Description -E Configure a setting --enrollment-token The enrollment token to use -h, --help Show help -s, --silent Show minimal output -v, --verbose Show verbose output ERROR: Abor…

[https://discuss.elastic.co/t/not-able-to-add-node-to-existing-cluster/348068/9](https://discuss.elastic.co/t/not-able-to-add-node-to-existing-cluster/348068/9)

> **[Add and remove nodes in your cluster | Elasticsearch Guide \[8.15\] | Elastic](https://www.elastic.co/guide/en/elasticsearch/reference/current/add-elasticsearch-nodes.html#add-elasticsearch-nodes)**

Thanks

---

<div class="post-metadata">

### Author: ![saxena\_shk7](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/saxena_shk7/32/132741_2.png) [@saxena\_shk7](https://discuss.elastic.co/u/saxena_shk7)
#### Post date: [August 23, 2024, 11:46am UTC](https://discuss.elastic.co/t/elasticsearch-cluster-new-node-addition-error/365429/8 "2024-08-23T11:46:08Z")

</div>

Thanks for the above reply!!! even after trying the above methods it is showing error that the master node is not reachable , i dont know if this is a bug or what because both the nodes are in the same subnet and even ports are opened and there is no firewall configuration applied.

 ![Capture2](https://us1.discourse-cdn.com/elastic/original/3X/1/5/153b0c481a5fe64afddec497f78b1211f1b68729.jpeg)

---

<div class="post-metadata">

### Author: ![Tortoise](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/tortoise/32/147587_2.png) [@Tortoise](https://discuss.elastic.co/u/Tortoise)
#### Post date: [August 23, 2024, 11:53am UTC](https://discuss.elastic.co/t/elasticsearch-cluster-new-node-addition-error/365429/9 "2024-08-23T11:53:21Z")

</div>

Hello,

Seems some issue related as raised below :

> [@Unable to generate a enrollement token with scope level to node ERROR: Failed to determine the health of the cluster. , with exit code 69](https://discuss.elastic.co/t/unable-to-generate-a-enrollement-token-with-scope-level-to-node-error-failed-to-determine-the-health-of-the-cluster-with-exit-code-69/361887/2):
>
> This and this don't match up. You shouldn't be able to access your cluster via http (non-SSL) if your node has SSL enabled.

Thanks

---

<div class="post-metadata">

### Author: ![saxena\_shk7](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/saxena_shk7/32/132741_2.png) [@saxena\_shk7](https://discuss.elastic.co/u/saxena_shk7)
#### Post date: [August 26, 2024, 10:21am UTC](https://discuss.elastic.co/t/elasticsearch-cluster-new-node-addition-error/365429/10 "2024-08-26T10:21:57Z")

</div>

Finally problem solved. I have reinstalled the elasticsearch by downloadinging its zip package, I think its a bug. Anyways thanks @Tortoise.
