# Elasticsearch code=exited, status=1/FAILURE

**URL:** https://discuss.elastic.co/t/elasticsearch-code-exited-status-1-failure/336595
**Category:** Elasticsearch
**Tags:** elastic-stack-monitoring
**Created:** [June 21, 2023, 1:43pm UTC](https://discuss.elastic.co/t/elasticsearch-code-exited-status-1-failure/336595 "2023-06-21T13:43:21Z")
**Posts on this page:** 1
**Showing post:** 4

<div class="post-metadata">

### Author: ![leandrojmp](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/leandrojmp/32/107231_2.png) [@leandrojmp](https://discuss.elastic.co/u/leandrojmp)
#### Post date: [June 21, 2023, 2:19pm UTC](https://discuss.elastic.co/t/elasticsearch-code-exited-status-1-failure/336595/4 "2023-06-21T14:19:57Z")

</div>

O erro é esse aqui:

> Jun 21 09:37:49 systemd-entrypoint: Failed to load native library:jansi-2.4.0-bd276cefa76a63f8-libjansi.so.The native library file at /tmp/elasticsearch-9107953253587356133/jansi-2.4.0-bd276cefa76a63f8-libjansi.so is not executable, make sure that the directory is mounted on a partition without the noexec flag, or set the jansi.tmpdir system property to point to a proper location. osinfo: Linux/x86\_64

A partição do diretório `/tmp` tá montada como `noexec`, o diretório pros arquivos temporários que o Elasticsearch usa precisa permitir execução, isso tá explicado [nessa parte da documentação](https://www.elastic.co/guide/en/elasticsearch/reference/current/executable-jna-tmpdir.html).

Você precisa criar um outro diretório pra armazenar os arquivos temporários, dar permissão pro usuário `elasticsearch` ler e escrever nesse diretório e adicionar esse arquivo nas configurações do serviço do Elasticsearch como explicado na documentação.

Acho que seria algo mais ou menos assim:

```auto
$ cd /usr/share/elasticsearch
$ sudo mkdir tmp
$ sudo chown elasticsearch:elasticsearch tmp
$ sudo systemctl edit elasticsearch

```

Ai no editor que abre você cola isso

```auto
[Service]
Environment=ES_TMPDIR=/usr/share/elasticsearch/tmp

```

---

_[View the full topic](https://discuss.elastic.co/t/elasticsearch-code-exited-status-1-failure/336595)._
