# elasticsearch.common.breaker.CircuitBreakingException: \[parent\] Data too large, data for

**URL:** https://discuss.elastic.co/t/elasticsearch-common-breaker-circuitbreakingexception-parent-data-too-large-data-for/213703
**Category:** Elasticsearch
**Created:** [January 3, 2020, 12:28pm UTC](https://discuss.elastic.co/t/elasticsearch-common-breaker-circuitbreakingexception-parent-data-too-large-data-for/213703 "2020-01-03T12:28:57Z")
**Posts on this page:** 2
**Page:** 1

<div class="post-metadata">

### Author: ![abhi\_12](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/abhi_12/32/45032_2.png) [@abhi\_12](https://discuss.elastic.co/u/abhi_12)
#### Post date: [January 3, 2020, 12:28pm UTC](https://discuss.elastic.co/t/elasticsearch-common-breaker-circuitbreakingexception-parent-data-too-large-data-for/213703/1 "2020-01-03T12:28:57Z")

</div>

Hi All,

We are getting these error on elastic-search. Please let me know the permanent fix for this.

elastic-search version:elasticsearch-7.3.2  
filebeatversion: filebeat-7.3.2

ERROR pipeline/output.go:100 Failed to connect to backoff(elasticsearch([http://xxx:9200](http://xxx:9200))): Connection marked as failed because the onConnect callback failed: 1 error: Error loading pipeline for fileset elasticsearch/audit: couldn't load pipeline: couldn't load json. Error: 429 Too Many Requests: {"error":{"root\_cause":[{"type":"circuit\_breaking\_exception","reason":"[parent] Data too large, data for [\<transport\_request\>] would be [1000536140/954.1mb], which is larger than the limit of [986932838/941.2mb], real usage: [1000533984/954.1mb], new bytes reserved: [2156/2.1kb], usages [request=0/0b, fielddata=1116/1kb, in\_flight\_requests=2156/2.1kb, accounting=537615094/512.7mb]","bytes\_wanted":1000536140,"bytes\_limit":986932838,"durability":"PERMANENT"}],"type":"circuit\_breaking\_exception","reason":"[parent] Data too large, data for [\<transport\_request\>] would be [1000536140/954.1mb], which is larger than the limit of [986932838/941.2mb], real usage: [1000533984/954.1mb], new bytes reserved: [2156/2.1kb], usages [request=0/0b, fielddata=1116/1kb, in\_flight\_requests=2156/2.1kb, accounting=537615094/512.7mb]","bytes\_wanted":1000536140,"bytes\_limit":986932838,"durability":"PERMANENT"},"status":429}. Response body: {"error":{"root\_cause":[{"type":"circuit\_breaking\_exception","reason":"[parent] Data too large, data for [\<transport\_request\>] would be [1000536140/954.1mb], which is larger than the limit of [986932838/941.2mb], real usage: [1000533984/954.1mb], new bytes reserved: [2156/2.1kb], usages [request=0/0b, fielddata=1116/1kb, in\_flight\_requests=2156/2.1kb, accounting=537615094/512.7mb]","bytes\_wanted":1000536140,"bytes\_limit":986932838,"durability":"PERMANENT"}],"type":"circuit\_breaking\_exception","reason":"[parent] Data too large, data for [\<transport\_request\>] would be [1000536140/954.1mb], which is larger than the limit of [986932838/941.2mb], real usage: [1000533984/954.1mb], new bytes reserved: [2156/2.1kb], usages [request=0/0b, fielddata=1116/1kb, in\_flight\_requests=2156/2.1kb, accounting=537615094/512.7mb]","bytes\_wanted":1000536140,"bytes\_limit":986932838,"durability":"PERMANENT"},"status":429}

Any query feel free to ask me.

---

<div class="post-metadata">

### Author: ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)
#### Post date: [January 31, 2020, 12:29pm UTC](https://discuss.elastic.co/t/elasticsearch-common-breaker-circuitbreakingexception-parent-data-too-large-data-for/213703/2 "2020-01-31T12:29:01Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
