# Elasticsearch Create a snapshot repository error

**URL:** <https://discuss.elastic.co/t/elasticsearch-create-a-snapshot-repository-error/60830>\
**Category:** Elasticsearch\
**Created:** [September 19, 2016, 3:42am UTC](https://discuss.elastic.co/t/elasticsearch-create-a-snapshot-repository-error/60830 "2016-09-19T03:42:58Z")\
**Posts on this page:** 15\
**Page:** 1

<div class="post-metadata">

**Author:** ![Canon88](https://avatars.discourse-cdn.com/v4/letter/c/ba8739/32.png) [@Canon88](https://discuss.elastic.co/u/Canon88)\
**Post date:** [September 19, 2016, 3:42am UTC](https://discuss.elastic.co/t/elasticsearch-create-a-snapshot-repository-error/60830/1 "2016-09-19T03:42:58Z")

</div>

When I use  
curl -XPUT '[http://192.168.184.33:9200/\_snapshot/elkbak](http://192.168.184.33:9200/_snapshot/elkbak)' -d '{"type": "fs","settings": {"location": "/data/elk\_bak","compress": true}}'.  
Shows the following error:  
{"error":{"root\_cause":[{"type":"repository\_verification\_exception","reason":"[elkbak] [AvxdLuwDTGCif9MujDW8mw, 'RemoteTransportException[[logserver-es-02][192.168.184.34:9300][internal:admin/repository/verify]]; nested: RepositoryVerificationException[[elkbak] store location [/data/elk\_bak] is not accessible on the node [{logserver-es-02}{AvxdLuwDTGCif9MujDW8mw}{192.168.184.34}{192.168.184.34:9300}{master=true}]]; nested: NotSerializableExceptionWrapper[access\_denied\_exception: /data/elk\_bak/tests-UI5DJFuzRLWs2XuQ2SIcgA/data-AvxdLuwDTGCif9MujDW8mw.dat];']]"}],"type":"repository\_verification\_exception","reason":"[elkbak] [AvxdLuwDTGCif9MujDW8mw, 'RemoteTransportException[[logserver-es-02][192.168.184.34:9300][internal:admin/repository/verify]]; nested: RepositoryVerificationException[[elkbak] store location [/data/elk\_bak] is not accessible on the node [{logserver-es-02}{AvxdLuwDTGCif9MujDW8mw}{192.168.184.34}{192.168.184.34:9300}{master=true}]]; nested: NotSerializableExceptionWrapper[access\_denied\_exception: /data/elk\_bak/tests-UI5DJFuzRLWs2XuQ2SIcgA/data-AvxdLuwDTGCif9MujDW8mw.dat];']]"},"status":500}

This is my configuration.  
logserver-es-01

[cluster.name](http://cluster.name): my\_logsearch  
[node.name](http://node.name): logserver-es-01  
node.master: true  
node.data: true  
index.number\_of\_shards: 5  
index.number\_of\_replicas: 1  
path.logs: "/data/logs/elasticsearch"  
path.data: "/data/elasticsearch"  
network.host: 192.168.184.33  
http.port: 9200  
bootstrap.mlockall: true  
transport.tcp.compress: true

discovery.zen.fd.connect\_on\_network\_disconnect : true  
discovery.zen.initial\_ping\_timeout : 10s  
discovery.zen.fd.ping\_interval : 2s  
discovery.zen.fd.ping\_retries : 10

network.tcp.keep\_alive : true  
indices.recovery.max\_size\_per\_sec: 0  
indices.recovery.concurrent\_streams: 5  
discovery.zen.ping.multicast.enabled: false  
discovery.zen.ping.timeout: 3s  
discovery.zen.ping.unicast.hosts: ["logserver-es-01","logserver-es-02"]  
path.repo: ["/data/elk\_bak"]  
logserver-es-02

[node.name](http://node.name): logserver-es-02  
....  
path.repo: ["/data/elk\_bak"]

What is the problem, anybody help me. Thank you!

---

<div class="post-metadata">

**Author:** ![JoarSvensson](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/joarsvensson/32/8740_2.png) [@JoarSvensson](https://discuss.elastic.co/u/JoarSvensson)\
**Post date:** [September 19, 2016, 6:29am UTC](https://discuss.elastic.co/t/elasticsearch-create-a-snapshot-repository-error/60830/2 "2016-09-19T06:29:30Z")

</div>

> [@Canon88](#):
>
> store location [/data/elk\_bak] is not accessible on the node [{logserver-es-02}

Are you sure the directory "/data/elk\_bak" is accessible and that the permissions meet the requirements?

---

<div class="post-metadata">

**Author:** ![Canon88](https://avatars.discourse-cdn.com/v4/letter/c/ba8739/32.png) [@Canon88](https://discuss.elastic.co/u/Canon88)\
**Post date:** [September 19, 2016, 8:10am UTC](https://discuss.elastic.co/t/elasticsearch-create-a-snapshot-repository-error/60830/3 "2016-09-19T08:10:57Z")

</div>

The elk\_bak permissions:  
`drwxr-xr-x 3 nobody nobody 4096 Sep 19 14:50 elk_bak`  
The Elasticsearch process, is to use elasticsearch start. Is this problem?

---

<div class="post-metadata">

**Author:** ![Christian\_Dahlqvist](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/christian_dahlqvist/32/4617_2.png) [@Christian\_Dahlqvist](https://discuss.elastic.co/u/Christian_Dahlqvist)\
**Post date:** [September 19, 2016, 8:23am UTC](https://discuss.elastic.co/t/elasticsearch-create-a-snapshot-repository-error/60830/4 "2016-09-19T08:23:41Z")

</div>

The repository path must be a [shared file system](https://www.elastic.co/guide/en/elasticsearch/reference/current/modules-snapshots.html#_shared_file_system_repository) accessible to all nodes in the cluster. is this the case in your setup?

---

<div class="post-metadata">

**Author:** ![Canon88](https://avatars.discourse-cdn.com/v4/letter/c/ba8739/32.png) [@Canon88](https://discuss.elastic.co/u/Canon88)\
**Post date:** [September 19, 2016, 8:28am UTC](https://discuss.elastic.co/t/elasticsearch-create-a-snapshot-repository-error/60830/5 "2016-09-19T08:28:06Z")

</div>

Yes. All the nodes in the cluster mount NFS\_Server folder.  
NFS\_Server:  
[root @ localhost conf] # more/etc/exports  
/backup 192.168.184.33 (rw, sync, no\_root\_squash)  
/backup 192.168.184.34 (rw, sync, no\_root\_squash)

Cluster nodes 1

mount -t NFS 192.168.184.19: /backup/data/elk\_bak /

Cluster node 2  
mount -t NFS 192.168.184.19: /backup/data/elk\_bak /

---

<div class="post-metadata">

**Author:** ![Christian\_Dahlqvist](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/christian_dahlqvist/32/4617_2.png) [@Christian\_Dahlqvist](https://discuss.elastic.co/u/Christian_Dahlqvist)\
**Post date:** [September 19, 2016, 8:30am UTC](https://discuss.elastic.co/t/elasticsearch-create-a-snapshot-repository-error/60830/6 "2016-09-19T08:30:52Z")

</div>

Is the path `"/backup/data/elk_bak/"` or `"/data/elk_bak/"`?

---

<div class="post-metadata">

**Author:** ![Canon88](https://avatars.discourse-cdn.com/v4/letter/c/ba8739/32.png) [@Canon88](https://discuss.elastic.co/u/Canon88)\
**Post date:** [September 19, 2016, 8:33am UTC](https://discuss.elastic.co/t/elasticsearch-create-a-snapshot-repository-error/60830/7 "2016-09-19T08:33:58Z")

</div>

Is the path /data/elk\_bak/  
Cluster nodes 1  
mount -t nfs 192.168.184.19:/backup /data/elk\_bak/  
Cluster nodes 2  
mount -t nfs 192.168.184.19:/backup /data/elk\_bak/

Cluster nodes 1  
elasticsearch.yml  
...  
path.repo: ["/data/elk\_bak"]

Cluster nodes 2  
elasticsearch.yml  
...  
path.repo: ["/data/elk\_bak"]

---

<div class="post-metadata">

**Author:** ![kmroz](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/kmroz/32/62741_2.png) [@kmroz](https://discuss.elastic.co/u/kmroz)\
**Post date:** [June 30, 2017, 4:26pm UTC](https://discuss.elastic.co/t/elasticsearch-create-a-snapshot-repository-error/60830/8 "2017-06-30T16:26:29Z")

</div>

Was there a solution to this? currently running into the same issue?

---

<div class="post-metadata">

**Author:** ![amruta.mohite](https://avatars.discourse-cdn.com/v4/letter/a/76d3ee/32.png) [@amruta.mohite](https://discuss.elastic.co/u/amruta.mohite)\
**Post date:** [March 9, 2018, 6:35am UTC](https://discuss.elastic.co/t/elasticsearch-create-a-snapshot-repository-error/60830/9 "2018-03-09T06:35:52Z")

</div>

Is any solution there for this issue, I am running into same issue.

---

<div class="post-metadata">

**Author:** ![Nikesh](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/nikesh/32/86579_2.png) [@Nikesh](https://discuss.elastic.co/u/Nikesh)\
**Post date:** [February 27, 2019, 12:43pm UTC](https://discuss.elastic.co/t/elasticsearch-create-a-snapshot-repository-error/60830/10 "2019-02-27T12:43:32Z")

</div>

I'm running into the same issue  
Is there any solution to this?

---

<div class="post-metadata">

**Author:** ![drivera](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/drivera/32/39900_2.png) [@drivera](https://discuss.elastic.co/u/drivera)\
**Post date:** [March 2, 2019, 11:19am UTC](https://discuss.elastic.co/t/elasticsearch-create-a-snapshot-repository-error/60830/11 "2019-03-02T11:19:14Z")

</div>

Same problem here. Looking into uid and gid right now.

---

<div class="post-metadata">

**Author:** ![Shubham](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/shubham/32/62276_2.png) [@Shubham](https://discuss.elastic.co/u/Shubham)\
**Post date:** [April 9, 2020, 7:32am UTC](https://discuss.elastic.co/t/elasticsearch-create-a-snapshot-repository-error/60830/12 "2020-04-09T07:32:38Z")

</div>

Is there any solution to this ? Running into same issue.

---

<div class="post-metadata">

**Author:** ![rakeshraagu2](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/rakeshraagu2/32/66283_2.png) [@rakeshraagu2](https://discuss.elastic.co/u/rakeshraagu2)\
**Post date:** [April 24, 2020, 5:40pm UTC](https://discuss.elastic.co/t/elasticsearch-create-a-snapshot-repository-error/60830/13 "2020-04-24T17:40:25Z")

</div>

HI Guys,

This issue is solved.

The problem here is the shared directory is not inheriting the permissions for newly created contents. You need to set default acl permission on the shared directory by,

'sudo setfacl -m d:u:elasticsearch:rwx /data/elk\_back'

Its Working...

---

<div class="post-metadata">

**Author:** ![faxm0dem](https://avatars.discourse-cdn.com/v4/letter/f/c77e96/32.png) [@faxm0dem](https://discuss.elastic.co/u/faxm0dem)\
**Post date:** [May 17, 2021, 10:16am UTC](https://discuss.elastic.co/t/elasticsearch-create-a-snapshot-repository-error/60830/14 "2021-05-17T10:16:46Z")

</div>

this should be in the documentation ! thanks rakeshraagu2

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [November 4, 2022, 4:28am UTC](https://discuss.elastic.co/t/elasticsearch-create-a-snapshot-repository-error/60830/15 "2022-11-04T04:28:32Z")

</div>


