# Elasticsearch curl failed to connect to port 9200 conncetion refused

**URL:** <https://discuss.elastic.co/t/elasticsearch-curl-failed-to-connect-to-port-9200-conncetion-refused/126012>\
**Category:** Elasticsearch\
**Created:** [March 29, 2018, 3:10am UTC](https://discuss.elastic.co/t/elasticsearch-curl-failed-to-connect-to-port-9200-conncetion-refused/126012 "2018-03-29T03:10:19Z")\
**Posts on this page:** 6\
**Page:** 1

<div class="post-metadata">

**Author:** ![zqy961](https://avatars.discourse-cdn.com/v4/letter/z/ecccb3/32.png) [@zqy961](https://discuss.elastic.co/u/zqy961)\
**Post date:** [March 29, 2018, 3:10am UTC](https://discuss.elastic.co/t/elasticsearch-curl-failed-to-connect-to-port-9200-conncetion-refused/126012/1 "2018-03-29T03:10:19Z")

</div>

i install elasticsearch.6.2.3 by apt-get  
i didn't change elasticsearch.yml  
os:ubuntu 16  
run elasticsearch by systemctl start elasticsearch.service

when i input the command 'systemctl status elasticsearch.service'  
i shows that elasticsearch is alive  
but when i try to crul ,i get  
curl :(7) failed to connect to localhost port 9200 :conncetion refused

---

<div class="post-metadata">

**Author:** ![warkolm](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/warkolm/32/39224_2.png) [@warkolm](https://discuss.elastic.co/u/warkolm)\
**Post date:** [March 29, 2018, 4:49am UTC](https://discuss.elastic.co/t/elasticsearch-curl-failed-to-connect-to-port-9200-conncetion-refused/126012/2 "2018-03-29T04:49:08Z")

</div>

What do the Elasticsearch logs show?

---

<div class="post-metadata">

**Author:** ![zqy961](https://avatars.discourse-cdn.com/v4/letter/z/ecccb3/32.png) [@zqy961](https://discuss.elastic.co/u/zqy961)\
**Post date:** [March 29, 2018, 5:10am UTC](https://discuss.elastic.co/t/elasticsearch-curl-failed-to-connect-to-port-9200-conncetion-refused/126012/3 "2018-03-29T05:10:30Z")

</div>

command: systemctl status elasticsearch.service  
elasticsearch.service - LSB:Starts elasticsearch  
Loaded: loaded (/etc/init.d/elasticsearch; bad; vendor preset: enabled)  
Active: active (exited) since Thu 2018-03-29 10:47:49 CST; 2h 14min ago  
Docs: man:systemd-sysv-generator(8)  
Process: 924 ExecStop=/etc/init.d/elasticsearch stop (code=exited, status=0/SUCCESS)  
Process: 963 ExecStart=/etc/init.d/elasticsearch start (code=exited, status=0/SUCCESS)

Mar 29 10:47:49 zqy systemd[1]: Starting LSB:Starts elasticsearch  
Mar 29 10:27:49 zqy systemd[1]: started LSB:Starts elasticsearch

i check /var/log/elasticsearh there's nothing in it

then i input the command :ps -aux|grep elasticsearch , i got nothing which means that elasticsearch didn't start actually  
i guess something must be wrong in network connection ,may be run out of time  
what do u think ? any idea about configuration?

---

<div class="post-metadata">

**Author:** ![warkolm](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/warkolm/32/39224_2.png) [@warkolm](https://discuss.elastic.co/u/warkolm)\
**Post date:** [March 29, 2018, 5:23am UTC](https://discuss.elastic.co/t/elasticsearch-curl-failed-to-connect-to-port-9200-conncetion-refused/126012/4 "2018-03-29T05:23:11Z")

</div>

What about the OS log, there should be something stating what is wrong.

---

<div class="post-metadata">

**Author:** ![zqy961](https://avatars.discourse-cdn.com/v4/letter/z/ecccb3/32.png) [@zqy961](https://discuss.elastic.co/u/zqy961)\
**Post date:** [March 29, 2018, 7:36am UTC](https://discuss.elastic.co/t/elasticsearch-curl-failed-to-connect-to-port-9200-conncetion-refused/126012/6 "2018-03-29T07:36:19Z")

</div>

i found the reason  
because before i install elasticsearch by apt-get ,i did't do apt update ,so i install the old version ,now i reinstall it and everything seems ok .  
thanks for ur help

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [April 26, 2018, 7:36am UTC](https://discuss.elastic.co/t/elasticsearch-curl-failed-to-connect-to-port-9200-conncetion-refused/126012/7 "2018-04-26T07:36:39Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
