# Elasticsearch 起動後のcurlを使った正常性確認でエラー

**URL:** <https://discuss.elastic.co/t/elasticsearch-curl/178141>\
**Category:** 日本語による質問・議論はこちら\
**Created:** [April 24, 2019, 3:46am UTC](https://discuss.elastic.co/t/elasticsearch-curl/178141 "2019-04-24T03:46:05Z")\
**Posts on this page:** 6\
**Page:** 1

<div class="post-metadata">

**Author:** ![iasenust](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/iasenust/32/43502_2.png) [@iasenust](https://discuss.elastic.co/u/iasenust)\
**Post date:** [April 24, 2019, 3:46am UTC](https://discuss.elastic.co/t/elasticsearch-curl/178141/1 "2019-04-24T03:46:05Z")

</div>

基本的がわかっておらず恐縮ですがご教授ください。  
linux(Ubuntu)でbin/elasticsearchでelasticsearchを起動した後、  
別のシェルからcurl http://localhost:9200と打つと

ERROR

| &nbsp; |

| ページを表示できません |

| &nbsp; |

といったような表示が出てしまいます。一方、ブラウザでhttp://localhost:9200/ で確認すると、正常に  
{  
"name" : "nekamodel",  
"cluster\_name" : "elasticsearch",  
"cluster\_uuid" : "Z4NTsl-7QiabAzkC7ZfobQ",  
"version" : {  
"number" : "7.0.0",  
"build\_flavor" : "default",  
"build\_type" : "tar",  
"build\_hash" : "b7e28a7",  
"build\_date" : "2019-04-05T22:55:32.697037Z",  
"build\_snapshot" : false,  
"lucene\_version" : "8.0.0",  
"minimum\_wire\_compatibility\_version" : "6.7.0",  
"minimum\_index\_compatibility\_version" : "6.0.0-beta1"  
},  
"tagline" : "You Know, for Search"  
}

と表示されます。windowsでELK6.5を試していた時にはこのようなことは発生していませんでした。  
私がlinuxが慣れてないからなのかもしれませんが原因についてわかりますでしょうか？

| サーバーに接続できません。  
サーバーが存在しないか、接続拒否している可能性があります。 |

---

<div class="post-metadata">

**Author:** ![iasenust](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/iasenust/32/43502_2.png) [@iasenust](https://discuss.elastic.co/u/iasenust)\
**Post date:** [April 24, 2019, 3:51am UTC](https://discuss.elastic.co/t/elasticsearch-curl/178141/2 "2019-04-24T03:51:08Z")

</div>

すみません、エラー表示のHTML文をそのままコピーしたら表示されませんでした。失礼しました。  
エラーの文言としては、

・ページを表示できません  
・サーバーに接続できません。  
・サーバーが存在しないか、接続拒否している可能性があります。

という文言が入ってきます。  
よろしくお願い致します。

---

<div class="post-metadata">

**Author:** ![iasenust](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/iasenust/32/43502_2.png) [@iasenust](https://discuss.elastic.co/u/iasenust)\
**Post date:** [April 24, 2019, 7:36am UTC](https://discuss.elastic.co/t/elasticsearch-curl/178141/3 "2019-04-24T07:36:04Z")

</div>

すみません。自分なりに調べてうまくいくことができました。原因は  
elasticsearch.yaml に「network.host：0.0.0.0」 を設定していなかった、  
ことによるものののようでした。ただ、上記を設定したとたんに起動時に  
[1]: max file descriptors [4096] for elasticsearch process is too low, increase to at least [65536]  
[2]: max virtual memory areas vm.max\_map\_count [65530] is too low, increase to at least [262144]  
のエラーが出始めたので、OS側の設定を色々変更することで対応できました。  
ありがとうございました。

---

<div class="post-metadata">

**Author:** ![tsgkdt](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/tsgkdt/32/39151_2.png) [@tsgkdt](https://discuss.elastic.co/u/tsgkdt)\
**Post date:** [April 24, 2019, 8:30am UTC](https://discuss.elastic.co/t/elasticsearch-curl/178141/4 "2019-04-24T08:30:08Z")

</div>

おそらく、OS側の設定をいろいろ、というのは以下のような内容かと思います。  
後々、他の方が検索してこのスレッドをみたとき用に。

## File Descriptors

> **[Increase the file descriptor limit | Elastic Docs](https://www.elastic.co/docs/deploy-manage/deploy/self-managed/file-descriptors)**
>
> Elasticsearch uses a lot of file descriptors or file handles. Running out of file descriptors can be disastrous and will most probably lead to data loss...

> On macOS, you must also pass the JVM option `-XX:-MaxFDLimit` to Elasticsearch in order for it to make use of the higher file descriptor limit.

## Virtual Memory

> **[Increase virtual memory | Elastic Docs](https://www.elastic.co/docs/deploy-manage/deploy/self-managed/vm-max-map-count)**
>
> Elasticsearch uses a mmapfs directory by default to store its indices. The default operating system limits on mmap counts is likely to be too low, which...

> On Linux, you can increase the limits by running the following command as `root` :  
> sysctl -w vm.max\_map\_count=262144

---

<div class="post-metadata">

**Author:** ![iasenust](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/iasenust/32/43502_2.png) [@iasenust](https://discuss.elastic.co/u/iasenust)\
**Post date:** [April 25, 2019, 2:19am UTC](https://discuss.elastic.co/t/elasticsearch-curl/178141/5 "2019-04-25T02:19:08Z")

</div>

フォロー頂きましてありがとうございます。

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [May 23, 2019, 2:33am UTC](https://discuss.elastic.co/t/elasticsearch-curl/178141/6 "2019-05-23T02:33:20Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
