# ElasticSearch deployment is failing in Azure from Marketplace

**URL:** <https://discuss.elastic.co/t/elasticsearch-deployment-is-failing-in-azure-from-marketplace/174384>\
**Category:** Elasticsearch\
**Created:** [March 28, 2019, 3:49pm UTC](https://discuss.elastic.co/t/elasticsearch-deployment-is-failing-in-azure-from-marketplace/174384 "2019-03-28T15:49:43Z")\
**Posts on this page:** 16\
**Page:** 1

<div class="post-metadata">

**Author:** ![kyogesh91](https://avatars.discourse-cdn.com/v4/letter/k/8e8cbc/32.png) [@kyogesh91](https://discuss.elastic.co/u/kyogesh91)\
**Post date:** [March 28, 2019, 3:49pm UTC](https://discuss.elastic.co/t/elasticsearch-deployment-is-failing-in-azure-from-marketplace/174384/1 "2019-03-28T15:49:43Z")

</div>

ElasticSearch deployment is failing in Microsoft Azure Marketplace.

Snippet of the error.  
[https://pastebin.com/uYpTce3T](https://pastebin.com/uYpTce3T)

Below is the link to files shared by Microsoft Azure Support.

[https://support.microsoft.com/en-us/files?workspace=eyJ0eXAiOiJKV1QiLCJhbGciOiJSUzI1NiJ9.eyJ3c2lkIjoiNjc2OWU3OWUtZGU2ZS00ZDk2LThhODYtZTBkYzhkMTBhNzY2Iiwic3IiOiIxMTkwMzI2MjEwMDMxODgiLCJhcHBpZCI6ImU2ZWU0M2ViLTBmYmMtNDU0Ni1iYzUyLTRjMTYxZmNkZjRjNCIsInN2IjoidjEiLCJycyI6IkV4dGVybmFsIiwid3RpZCI6ImUzOTRkN2ExLTlhYmEtNDVlNi05YTA0LTVkZmNiMzhlMjNlYSIsImlzcyI6Imh0dHBzOi8vYXBpLmR0bW5lYnVsYS5taWNyb3NvZnQuY29tIiwiYXVkIjoiaHR0cDovL3NtYyIsImV4cCI6MTU2MTQ5ODQzMywibmJmIjoxNTUzNzIyNDMzfQ.BDfJmjuq2IZjAGdl4XATF3TrxpSQjgklM5zoMG5zVhIseIDNzQNhoopnrfsc8mDguioLSODw6iC5nYmD6uoEm2BPidC-bdPuc4W\_eASIQWV69CouKkbu-1iV9O0BfcjvEdjh2DGpn5p1nBAXreINib7FpoARPhUrfrKj3aPI9pZkkN9mm9uYo-ZG4F7sM5\_taGtFSHceX8rvE4Iqu1vZF8gyt6FAOZOvPlBahMI0M4bTk68umpLKYC3XqOVACu5-cTMzIZFaw3gYiSYHzJZGuv-UZrW-wYPPXrN-J9K2javrjVZBYohjy48pCNX1WVoCckr9faUDgtQLdmcMHbsk7w&wid=6769e79e-de6e-4d96-8a86-e0dc8d10a766](https://support.microsoft.com/en-us/files?workspace=eyJ0eXAiOiJKV1QiLCJhbGciOiJSUzI1NiJ9.eyJ3c2lkIjoiNjc2OWU3OWUtZGU2ZS00ZDk2LThhODYtZTBkYzhkMTBhNzY2Iiwic3IiOiIxMTkwMzI2MjEwMDMxODgiLCJhcHBpZCI6ImU2ZWU0M2ViLTBmYmMtNDU0Ni1iYzUyLTRjMTYxZmNkZjRjNCIsInN2IjoidjEiLCJycyI6IkV4dGVybmFsIiwid3RpZCI6ImUzOTRkN2ExLTlhYmEtNDVlNi05YTA0LTVkZmNiMzhlMjNlYSIsImlzcyI6Imh0dHBzOi8vYXBpLmR0bW5lYnVsYS5taWNyb3NvZnQuY29tIiwiYXVkIjoiaHR0cDovL3NtYyIsImV4cCI6MTU2MTQ5ODQzMywibmJmIjoxNTUzNzIyNDMzfQ.BDfJmjuq2IZjAGdl4XATF3TrxpSQjgklM5zoMG5zVhIseIDNzQNhoopnrfsc8mDguioLSODw6iC5nYmD6uoEm2BPidC-bdPuc4W_eASIQWV69CouKkbu-1iV9O0BfcjvEdjh2DGpn5p1nBAXreINib7FpoARPhUrfrKj3aPI9pZkkN9mm9uYo-ZG4F7sM5_taGtFSHceX8rvE4Iqu1vZF8gyt6FAOZOvPlBahMI0M4bTk68umpLKYC3XqOVACu5-cTMzIZFaw3gYiSYHzJZGuv-UZrW-wYPPXrN-J9K2javrjVZBYohjy48pCNX1WVoCckr9faUDgtQLdmcMHbsk7w&wid=6769e79e-de6e-4d96-8a86-e0dc8d10a766)

---

<div class="post-metadata">

**Author:** ![forloop](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/forloop/32/9021_2.png) [@forloop](https://discuss.elastic.co/u/forloop)\
**Post date:** [March 30, 2019, 1:46pm UTC](https://discuss.elastic.co/t/elasticsearch-deployment-is-failing-in-azure-from-marketplace/174384/2 "2019-03-30T13:46:03Z")

</div>

The error message indicates that Elasticsearch was not seen to be running within a given wait period during the deployment. The [log files on the VM](https://www.elastic.co/guide/en/elastic-stack-deploy/current/azure-arm-template-troubleshooting-azure-logs.html) should provide more details for what the underlying cause is. You can [access the Elasticsearch VMs via SSH through either Kibana or a Jumpbox](https://www.elastic.co/guide/en/elastic-stack-deploy/current/azure-arm-template-troubleshooting-accessing-nodes.html).

---

<div class="post-metadata">

**Author:** ![kyogesh91](https://avatars.discourse-cdn.com/v4/letter/k/8e8cbc/32.png) [@kyogesh91](https://discuss.elastic.co/u/kyogesh91)\
**Post date:** [April 1, 2019, 1:28pm UTC](https://discuss.elastic.co/t/elasticsearch-deployment-is-failing-in-azure-from-marketplace/174384/3 "2019-04-01T13:28:07Z")

</div>

I have attached the screenshots of deployment status from Azure.  
For log files from "xdex-master-0", please go to the link specified earlier from [suuport.microsoft.com](http://suuport.microsoft.com)

 ![Screenshot%20from%202019-04-01%2008-59-23](https://us1.discourse-cdn.com/elastic/original/3X/c/7/c7116375d5206d0a0030e979aa2df68c7548450f.png) ![Screenshot%20from%202019-04-01%2008-58-59](https://us1.discourse-cdn.com/elastic/original/3X/8/8/88b5ccfe55df1f57cb2fe8dac6e335d5d2b5b5a2.png)

---

<div class="post-metadata">

**Author:** ![forloop](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/forloop/32/9021_2.png) [@forloop](https://discuss.elastic.co/u/forloop)\
**Post date:** [April 2, 2019, 12:24am UTC](https://discuss.elastic.co/t/elasticsearch-deployment-is-failing-in-azure-from-marketplace/174384/4 "2019-04-02T00:24:13Z")

</div>

@kyogesh91 the screenshot of failed deployments doesn't provide any more information beyond the information in the pastebin link you've provided.

To get to the root cause, you would need to SSH into one of the failed nodes e.g. start with `xdev-master-0` and [inspect the log files](https://www.elastic.co/guide/en/elastic-stack-deploy/current/azure-arm-template-troubleshooting-azure-logs.html) on the VM. There are several common reasons why a cluster may fail to form, for example,

1. The vnet to which you're attaching the cluster is using custom DNS servers as opposed to Azure DNS, which are unable to resolve by hostname on the vnet. The template assumes that [Azure DNS is used, or that custom DNS servers are configured to be able to resolve by hostname](https://www.elastic.co/guide/en/elastic-stack-deploy/current/azure-arm-template-networking.html#dns-resolution).

2. A transient error downloading one of the template dependencies such as an apt package or the Elasticsearch RPM package. It doesn't look like the latter in this case as the process would have failed much earlier.

3. An error related to DNS resolution on the VMs

I don't see a network resource in the screenshot above, which makes me suspect you're attaching to an existing vnet that may be using custom DNS servers. If this is the case, can you check the DNS server logs?

---

<div class="post-metadata">

**Author:** ![kyogesh91](https://avatars.discourse-cdn.com/v4/letter/k/8e8cbc/32.png) [@kyogesh91](https://discuss.elastic.co/u/kyogesh91)\
**Post date:** [April 2, 2019, 12:46am UTC](https://discuss.elastic.co/t/elasticsearch-deployment-is-failing-in-azure-from-marketplace/174384/5 "2019-04-02T00:46:46Z")

</div>

I am sorry, I thought I had shared the files.

Below is the link which contains the log files you asked for

[https://10xts-my.sharepoint.com/:f:/p/yogesh/Elwp1U4ILQtEi0GlYN5s39cBOppdEXNLdZ9rGRCzd\_-hyw?e=v6lGE7](https://10xts-my.sharepoint.com/:f:/p/yogesh/Elwp1U4ILQtEi0GlYN5s39cBOppdEXNLdZ9rGRCzd_-hyw?e=v6lGE7)

---

<div class="post-metadata">

**Author:** ![forloop](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/forloop/32/9021_2.png) [@forloop](https://discuss.elastic.co/u/forloop)\
**Post date:** [April 2, 2019, 12:53am UTC](https://discuss.elastic.co/t/elasticsearch-deployment-is-failing-in-azure-from-marketplace/174384/6 "2019-04-02T00:53:30Z")

</div>

Please see my previous reply about vnets and custom DNS servers. The error in the elastic-.log file

```auto
[2019-03-30T15:48:22,121][ERROR][o.e.b.Bootstrap] [xdex-master-1] Exception
java.lang.IllegalArgumentException: No up-and-running site-local (private) addresses found, got [name:lo (lo), name:eth0 (eth0)]
	at org.elasticsearch.common.network.NetworkUtils.getSiteLocalAddresses(NetworkUtils.java:184) ~[elasticsearch-6.6.1.jar:6.6.1]
	at org.elasticsearch.common.network.NetworkService.resolveInternal(NetworkService.java:218) ~[elasticsearch-6.6.1.jar:6.6.1]
	at org.elasticsearch.common.network.NetworkService.resolveInetAddresses(NetworkService.java:192) ~[elasticsearch-6.6.1.jar:6.6.1]
	at org.elasticsearch.common.network.NetworkService.resolveBindHostAddresses(NetworkService.java:108) ~[elasticsearch-6.6.1.jar:6.6.1]
	at org.elasticsearch.transport.TcpTransport.bindServer(TcpTransport.java:373) ~[elasticsearch-6.6.1.jar:6.6.1]
	at org.elasticsearch.transport.netty4.Netty4Transport.doStart(Netty4Transport.java:136) ~[?:?]
	at org.elasticsearch.xpack.core.security.transport.netty4.SecurityNetty4Transport.doStart(SecurityNetty4Transport.java:98) ~[?:?]
	at org.elasticsearch.xpack.security.transport.netty4.SecurityNetty4ServerTransport.doStart(SecurityNetty4ServerTransport.java:43) ~[?:?]
	at org.elasticsearch.common.component.AbstractLifecycleComponent.start(AbstractLifecycleComponent.java:65) ~[elasticsearch-6.6.1.jar:6.6.1]
	at org.elasticsearch.transport.TransportService.doStart(TransportService.java:229) ~[elasticsearch-6.6.1.jar:6.6.1]
	at org.elasticsearch.common.component.AbstractLifecycleComponent.start(AbstractLifecycleComponent.java:65) ~[elasticsearch-6.6.1.jar:6.6.1]
	at org.elasticsearch.node.Node.start(Node.java:716) ~[elasticsearch-6.6.1.jar:6.6.1]
	at org.elasticsearch.bootstrap.Bootstrap.start(Bootstrap.java:269) ~[elasticsearch-6.6.1.jar:6.6.1]
	at org.elasticsearch.bootstrap.Bootstrap.init(Bootstrap.java:342) [elasticsearch-6.6.1.jar:6.6.1]
	at org.elasticsearch.bootstrap.Elasticsearch.init(Elasticsearch.java:159) [elasticsearch-6.6.1.jar:6.6.1]
	at org.elasticsearch.bootstrap.Elasticsearch.execute(Elasticsearch.java:150) [elasticsearch-6.6.1.jar:6.6.1]
	at org.elasticsearch.cli.EnvironmentAwareCommand.execute(EnvironmentAwareCommand.java:86) [elasticsearch-6.6.1.jar:6.6.1]
	at org.elasticsearch.cli.Command.mainWithoutErrorHandling(Command.java:124) [elasticsearch-cli-6.6.1.jar:6.6.1]
	at org.elasticsearch.cli.Command.main(Command.java:90) [elasticsearch-cli-6.6.1.jar:6.6.1]
	at org.elasticsearch.bootstrap.Elasticsearch.main(Elasticsearch.java:116) [elasticsearch-6.6.1.jar:6.6.1]
	at org.elasticsearch.bootstrap.Elasticsearch.main(Elasticsearch.java:93) [elasticsearch-6.6.1.jar:6.6.1]

```

Indicates that you're using custom DNS servers. Per the documentation link in point 1 above, [These will need to be configured to perform hostname resolution.](https://docs.microsoft.com/en-au/azure/virtual-network/virtual-networks-name-resolution-for-vms-and-role-instances#name-resolution-that-uses-your-own-dns-server)

---

<div class="post-metadata">

**Author:** ![kyogesh91](https://avatars.discourse-cdn.com/v4/letter/k/8e8cbc/32.png) [@kyogesh91](https://discuss.elastic.co/u/kyogesh91)\
**Post date:** [April 2, 2019, 1:25am UTC](https://discuss.elastic.co/t/elasticsearch-deployment-is-failing-in-azure-from-marketplace/174384/7 "2019-04-02T01:25:48Z")

</div>

![Screenshot%20from%202019-04-01%2020-56-53](https://us1.discourse-cdn.com/elastic/original/3X/b/f/bf62c231256cc05715e72c024cc0edafa981ccd6.png)

This is what the settings have been in Azure

---

<div class="post-metadata">

**Author:** ![forloop](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/forloop/32/9021_2.png) [@forloop](https://discuss.elastic.co/u/forloop)\
**Post date:** [April 2, 2019, 1:58am UTC](https://discuss.elastic.co/t/elasticsearch-deployment-is-failing-in-azure-from-marketplace/174384/8 "2019-04-02T01:58:54Z")

</div>

Is that for the vnet to which the VMs are attached?

If you're on a VM on the vnet, can you resolve (e.g. ping) another VM by hostname?

---

<div class="post-metadata">

**Author:** ![kyogesh91](https://avatars.discourse-cdn.com/v4/letter/k/8e8cbc/32.png) [@kyogesh91](https://discuss.elastic.co/u/kyogesh91)\
**Post date:** [April 2, 2019, 2:39am UTC](https://discuss.elastic.co/t/elasticsearch-deployment-is-failing-in-azure-from-marketplace/174384/9 "2019-04-02T02:39:33Z")

</div>

![Screenshot%20from%202019-04-01%2022-38-32](https://us1.discourse-cdn.com/elastic/original/3X/8/1/81dd496308c4ed10a663c8c78137cca7ee44d44b.png)  
I was able to ping other master nodes and VMS in the VNET

---

<div class="post-metadata">

**Author:** ![forloop](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/forloop/32/9021_2.png) [@forloop](https://discuss.elastic.co/u/forloop)\
**Post date:** [April 2, 2019, 2:40am UTC](https://discuss.elastic.co/t/elasticsearch-deployment-is-failing-in-azure-from-marketplace/174384/10 "2019-04-02T02:40:53Z")

</div>

Can you ping them by hostname? The template does not use IP addresses because they are dynamically assigned.

---

<div class="post-metadata">

**Author:** ![kyogesh91](https://avatars.discourse-cdn.com/v4/letter/k/8e8cbc/32.png) [@kyogesh91](https://discuss.elastic.co/u/kyogesh91)\
**Post date:** [April 2, 2019, 2:45am UTC](https://discuss.elastic.co/t/elasticsearch-deployment-is-failing-in-azure-from-marketplace/174384/11 "2019-04-02T02:45:55Z")

</div>

![Screenshot%20from%202019-04-01%2022-40-24](https://us1.discourse-cdn.com/elastic/original/3X/4/4/44803711ec946bda0dd50e79facd277cc769a3c9.png) ![Screenshot%20from%202019-04-01%2022-45-14](https://us1.discourse-cdn.com/elastic/original/3X/2/f/2f13da9f8b518db7712e3c9a4e3e6903c6059c6d.png)

I am able to do it

---

<div class="post-metadata">

**Author:** ![forloop](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/forloop/32/9021_2.png) [@forloop](https://discuss.elastic.co/u/forloop)\
**Post date:** [April 2, 2019, 3:16am UTC](https://discuss.elastic.co/t/elasticsearch-deployment-is-failing-in-azure-from-marketplace/174384/12 "2019-04-02T03:16:03Z")

</div>

The first hostname pinged is not part of the cluster, so let's ignore that one for now.

Since you can ping VMs by hostname, I would suggest deleting the failed deployment resources (if they're in their own resource group, you can delete the resource group) and redeploy again.

---

<div class="post-metadata">

**Author:** ![kyogesh91](https://avatars.discourse-cdn.com/v4/letter/k/8e8cbc/32.png) [@kyogesh91](https://discuss.elastic.co/u/kyogesh91)\
**Post date:** [April 2, 2019, 3:19am UTC](https://discuss.elastic.co/t/elasticsearch-deployment-is-failing-in-azure-from-marketplace/174384/13 "2019-04-02T03:19:06Z")

</div>

I have tried your suggestion atleast three times. Same result.  
I have uploaded the template that is generated by the UI for reference

[https://10xts-my.sharepoint.com/:f:/p/yogesh/Elwp1U4ILQtEi0GlYN5s39cBOppdEXNLdZ9rGRCzd\_-hyw?e=v6lGE7](https://10xts-my.sharepoint.com/:f:/p/yogesh/Elwp1U4ILQtEi0GlYN5s39cBOppdEXNLdZ9rGRCzd_-hyw?e=v6lGE7)

---

<div class="post-metadata">

**Author:** ![forloop](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/forloop/32/9021_2.png) [@forloop](https://discuss.elastic.co/u/forloop)\
**Post date:** [April 2, 2019, 3:59am UTC](https://discuss.elastic.co/t/elasticsearch-deployment-is-failing-in-azure-from-marketplace/174384/14 "2019-04-02T03:59:59Z")

</div>

I'm fairly sure the issue is in the existing vnet that the cluster is being connected to. An easy way to see if this is the case is to deploy a vnet with the cluster instead of attaching it to an existing one.

Elasticsearch HTTP layer accepts incoming HTTP requests on port 9200, and the Transport layer accepts TCP connections on port 9300. Can you communicate with other VMs on the network from a VM using these ports?

---

<div class="post-metadata">

**Author:** ![kyogesh91](https://avatars.discourse-cdn.com/v4/letter/k/8e8cbc/32.png) [@kyogesh91](https://discuss.elastic.co/u/kyogesh91)\
**Post date:** [April 2, 2019, 12:13pm UTC](https://discuss.elastic.co/t/elasticsearch-deployment-is-failing-in-azure-from-marketplace/174384/15 "2019-04-02T12:13:04Z")

</div>

I tried to use a new Vnet and it worked.  
The existing VNET security group settings are attached.

 ![Screenshot%20from%202019-04-02%2008-11-21](https://us1.discourse-cdn.com/elastic/original/3X/9/b/9b3c57a6ed22a20ea40cbf72a03e5e4f6c5b9ca2.png)

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [April 30, 2019, 12:13pm UTC](https://discuss.elastic.co/t/elasticsearch-deployment-is-failing-in-azure-from-marketplace/174384/16 "2019-04-30T12:13:05Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
