# ElasticSearch didn't start at first try

**URL:** <https://discuss.elastic.co/t/elasticsearch-didnt-start-at-first-try/258747>\
**Category:** Elasticsearch\
**Created:** [December 15, 2020, 6:19pm UTC](https://discuss.elastic.co/t/elasticsearch-didnt-start-at-first-try/258747 "2020-12-15T18:19:51Z")\
**Posts on this page:** 4\
**Page:** 1

<div class="post-metadata">

**Author:** ![kae](https://avatars.discourse-cdn.com/v4/letter/k/bbe5ce/32.png) [@kae](https://discuss.elastic.co/u/kae)\
**Post date:** [December 15, 2020, 6:19pm UTC](https://discuss.elastic.co/t/elasticsearch-didnt-start-at-first-try/258747/1 "2020-12-15T18:19:51Z")

</div>

Hello Everyone,  
during deployment of my VM in my POD, ElasticSearch didn't start.  
issue on Journalctl is following :

`Dec 15 17:33:05 systemd[1]: Starting Elasticsearch...`  
`-- Subject: Unit elasticsearch.service has begun start-up`

`Dec 15 17:33:05 systemd[3983]: Failed at step RUNTIME_DIRECTORY spawning /usr/share/elasticsearch/bin/elasticsearch: File exists`  
`-- Subject: Process /usr/share/elasticsearch/bin/elasticsearch could not be executed`

`-- The process /usr/share/elasticsearch/bin/elasticsearch could not be executed and failed.`  
`-- The error number returned by this process is 17.`  
`Dec 15 17:33:05 systemd[1]: elasticsearch.service: main process exited, code=exited, status=233/RUNTIME_DIRECTORY`

then, when i'm starting it manually, it's start correctly...  
So I really don't understand what happening

anybody have an idea ?

---

<div class="post-metadata">

**Author:** ![warkolm](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/warkolm/32/39224_2.png) [@warkolm](https://discuss.elastic.co/u/warkolm)\
**Post date:** [December 15, 2020, 7:58pm UTC](https://discuss.elastic.co/t/elasticsearch-didnt-start-at-first-try/258747/2 "2020-12-15T19:58:28Z")

</div>

Welcome to our community! 😃  
Please format your code/logs/config using the `</>` button, or markdown style back ticks. It helps to make things easy to read which helps us help you 🙂

You should look in `/var/log/elasticsearch` for more information.

---

<div class="post-metadata">

**Author:** ![kae](https://avatars.discourse-cdn.com/v4/letter/k/bbe5ce/32.png) [@kae](https://discuss.elastic.co/u/kae)\
**Post date:** [December 15, 2020, 9:01pm UTC](https://discuss.elastic.co/t/elasticsearch-didnt-start-at-first-try/258747/3 "2020-12-15T21:01:10Z")

</div>

Hi Mark,  
sur you're right I should format my sharing. my apologize.  
I try to look in `/var/log/elasticsearch` but this folder is empty

the only logs that i found is in journalctl :  
`Dec 15 19:23:17 systemd[1]: Starting Elasticsearch...`  
`-- Unit elasticsearch.service has begun starting up.`  
`Dec 15 19:23:17 systemd[3986]: Failed at step RUNTIME_DIRECTORY spawning /usr/share/elasticsearch/bin/systemd-entrypoint: File exists`  
`-- Subject: Process /usr/share/elasticsearch/bin/systemd-entrypoint could not be executed`  
`Dec 15 19:23:17 systemd[1]: elasticsearch.service: main process exited, code=exited, status=233/RUNTIME_DIRECTORY`

I found a similar issue ([elasticsearch-wont-start-on-reboot](https://discuss.elastic.co/t/elasticsearch-wont-start-on-reboot/172228))  
I add a` rm /usr/lib/tmpfiles.d/elasticsearch.conf` before start cmd in the script but... it doesn't fix it.  
If I'm run manually through ssh remote the `systemctl start elasticsearch.service`  
elasticsearch service run fine and logs are available in `/var/log/elasticsearch`.

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [January 12, 2021, 9:01pm UTC](https://discuss.elastic.co/t/elasticsearch-didnt-start-at-first-try/258747/4 "2021-01-12T21:01:23Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
