# ElasticSearch didn't start at first try

**URL:** <https://discuss.elastic.co/t/elasticsearch-didnt-start-at-first-try/258747>\
**Category:** Elasticsearch\
**Created:** [December 15, 2020, 6:19pm UTC](https://discuss.elastic.co/t/elasticsearch-didnt-start-at-first-try/258747 "2020-12-15T18:19:51Z")\
**Posts on this page:** 1\
**Showing post:** 3

<div class="post-metadata">

**Author:** ![kae](https://avatars.discourse-cdn.com/v4/letter/k/bbe5ce/32.png) [@kae](https://discuss.elastic.co/u/kae)\
**Post date:** [December 15, 2020, 9:01pm UTC](https://discuss.elastic.co/t/elasticsearch-didnt-start-at-first-try/258747/3 "2020-12-15T21:01:10Z")

</div>

Hi Mark,  
sur you're right I should format my sharing. my apologize.  
I try to look in `/var/log/elasticsearch` but this folder is empty

the only logs that i found is in journalctl :  
`Dec 15 19:23:17 systemd[1]: Starting Elasticsearch...`  
`-- Unit elasticsearch.service has begun starting up.`  
`Dec 15 19:23:17 systemd[3986]: Failed at step RUNTIME_DIRECTORY spawning /usr/share/elasticsearch/bin/systemd-entrypoint: File exists`  
`-- Subject: Process /usr/share/elasticsearch/bin/systemd-entrypoint could not be executed`  
`Dec 15 19:23:17 systemd[1]: elasticsearch.service: main process exited, code=exited, status=233/RUNTIME_DIRECTORY`

I found a similar issue ([elasticsearch-wont-start-on-reboot](https://discuss.elastic.co/t/elasticsearch-wont-start-on-reboot/172228))  
I add a` rm /usr/lib/tmpfiles.d/elasticsearch.conf` before start cmd in the script but... it doesn't fix it.  
If I'm run manually through ssh remote the `systemctl start elasticsearch.service`  
elasticsearch service run fine and logs are available in `/var/log/elasticsearch`.

---

_[View the full topic](https://discuss.elastic.co/t/elasticsearch-didnt-start-at-first-try/258747)._
