# Elasticsearch docker container fails on aws: There is insufficient memory for the Java Runtime Environment to continue docker

**URL:** <https://discuss.elastic.co/t/elasticsearch-docker-container-fails-on-aws-there-is-insufficient-memory-for-the-java-runtime-environment-to-continue-docker/174031>\
**Category:** Elasticsearch\
**Created:** [March 27, 2019, 2:13am UTC](https://discuss.elastic.co/t/elasticsearch-docker-container-fails-on-aws-there-is-insufficient-memory-for-the-java-runtime-environment-to-continue-docker/174031 "2019-03-27T02:13:00Z")\
**Posts on this page:** 2\
**Page:** 1

<div class="post-metadata">

**Author:** ![Tinuade](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/tinuade/32/43246_2.png) [@Tinuade](https://discuss.elastic.co/u/Tinuade)\
**Post date:** [March 27, 2019, 2:13am UTC](https://discuss.elastic.co/t/elasticsearch-docker-container-fails-on-aws-there-is-insufficient-memory-for-the-java-runtime-environment-to-continue-docker/174031/1 "2019-03-27T02:13:00Z")

</div>

Hi! The elastic search docker container I deployed on aws fails with this error:There is insufficient memory for the Java Runtime Environment to continue docker. I've tried reducing the heap size with

```auto
"ES_JAVA_OPTS=-Xms512m -Xmx512m"

```

It still doesn't work

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [April 24, 2019, 2:13am UTC](https://discuss.elastic.co/t/elasticsearch-docker-container-fails-on-aws-there-is-insufficient-memory-for-the-java-runtime-environment-to-continue-docker/174031/2 "2019-04-24T02:13:02Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
