# Elasticsearch docker container fails to start with provided environmet variable

**URL:** <https://discuss.elastic.co/t/elasticsearch-docker-container-fails-to-start-with-provided-environmet-variable/288990>\
**Category:** Elasticsearch\
**Tags:** docker\
**Created:** [November 11, 2021, 12:09pm UTC](https://discuss.elastic.co/t/elasticsearch-docker-container-fails-to-start-with-provided-environmet-variable/288990 "2021-11-11T12:09:04Z")\
**Posts on this page:** 2\
**Page:** 1

<div class="post-metadata">

**Author:** ![michthom](https://avatars.discourse-cdn.com/v4/letter/m/90ced4/32.png) [@michthom](https://discuss.elastic.co/u/michthom)\
**Post date:** [November 11, 2021, 12:09pm UTC](https://discuss.elastic.co/t/elasticsearch-docker-container-fails-to-start-with-provided-environmet-variable/288990/1 "2021-11-11T12:09:04Z")

</div>

Hi guys, new here and unsure if this is Elasticsearch or docker issue, I think the former.

I'm trying to run Elasticsearch docker container but it fails to process supplied environment variable.

docker run -e "discovery.type=single-node" some\_path/Elasticsearch-oss:7.10.2

```
ERROR: [1] bootstrap checks failed
[1]: the default discovery settings are unsuitable for production use; at least one of [discovery.seed_hosts, discovery.seed_providers, cluster.initial_master_nodes] must be configured

```

I've seen chatter about similar but no useful resolution. I'd appreciate if anyone has ideas on the matter.

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [December 9, 2021, 12:09pm UTC](https://discuss.elastic.co/t/elasticsearch-docker-container-fails-to-start-with-provided-environmet-variable/288990/2 "2021-12-09T12:09:29Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
