# ElasticSearch Does Not Start on Clean Install

**URL:** <https://discuss.elastic.co/t/elasticsearch-does-not-start-on-clean-install/88418>\
**Category:** Elasticsearch\
**Created:** [June 6, 2017, 12:42pm UTC](https://discuss.elastic.co/t/elasticsearch-does-not-start-on-clean-install/88418 "2017-06-06T12:42:00Z")\
**Posts on this page:** 1\
**Showing post:** 4

<div class="post-metadata">

**Author:** ![kuthalam](https://avatars.discourse-cdn.com/v4/letter/k/a698b9/32.png) [@kuthalam](https://discuss.elastic.co/u/kuthalam)\
**Post date:** [June 7, 2017, 3:03pm UTC](https://discuss.elastic.co/t/elasticsearch-does-not-start-on-clean-install/88418/4 "2017-06-07T15:03:57Z")

</div>

@EddieTurizo:

Thank you for the link! I didn't have the Java path set (which I fixed in /etc/default/elasticsearch) and also looked here (since I was also having a memory issue):

> [@Memory lock not working](https://discuss.elastic.co/t/memory-lock-not-working/70576):
>
> I'm running a Fedora 25 ec2 image with elasticsearch 5.1.1 This are my settings: /etc/elasticsearch/elasticsearch.yml bootstrap.memory\_lock: true /usr/lib/systemd/system/elasticsearch.service LimitMEMLOCK=infinity /etc/sysconfig/elasticsearch MAX\_LOCKED\_MEMORY=unlimited /etc/security/limits.conf \* soft memlock unlimited \* hard memlock unlimited even after that I'm still getting: Unable to lock JVM Memory: error=12, reason=Cannot allocate memory Increase…

Now Elasticsearch is running just fine.

---

_[View the full topic](https://discuss.elastic.co/t/elasticsearch-does-not-start-on-clean-install/88418)._
