# Elasticsearch does not start

**URL:** <https://discuss.elastic.co/t/elasticsearch-does-not-start/315156>\
**Category:** Elasticsearch\
**Created:** [September 26, 2022, 9:32am UTC](https://discuss.elastic.co/t/elasticsearch-does-not-start/315156 "2022-09-26T09:32:39Z")\
**Posts on this page:** 3\
**Page:** 1

<div class="post-metadata">

**Author:** ![KermitSZ](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/kermitsz/32/111265_2.png) [@KermitSZ](https://discuss.elastic.co/u/KermitSZ)\
**Post date:** [September 26, 2022, 9:32am UTC](https://discuss.elastic.co/t/elasticsearch-does-not-start/315156/1 "2022-09-26T09:32:39Z")

</div>

Hello community,

We installed elasticsearch following this tutorial [Install Elasticsearch with Debian Package | Elasticsearch Guide [6.8] | Elastic](https://www.elastic.co/guide/en/elasticsearch/reference/6.8/deb.html#deb-repo) but the service crashes immediately after running the start command.  
This is the error message:  
systemctl status elasticsearch.service  
● elasticsearch.service - Elasticsearch  
Loaded: loaded (/lib/systemd/system/elasticsearch.service; enabled; vendor preset: enabled)  
Active: failed (Result: exit-code) since Mon 2022-09-26 11:24:40 CEST; 4s ago  
Docs: [http://www.elastic.co](http://www.elastic.co)  
Process: 2269458 ExecStart=/usr/share/elasticsearch/bin/elasticsearch -p ${PID\_DIR}/elasticsearch.pid --quiet (code=exited, status=1/FAILURE)  
Main PID: 2269458 (code=exited, status=1/FAILURE)  
CPU: 5.465s

Sep 26 11:24:39 myvm elasticsearch[2269458]: WARNING: System::setSecurityManager has been called by org.elasticsearch.bootstrap.Elasticsearch (file:/usr/share/elasticsearch/lib/elastic\>  
Sep 26 11:24:39 myvm elasticsearch[2269458]: WARNING: Please consider reporting this to the maintainers of org.elasticsearch.bootstrap.Elasticsearch  
Sep 26 11:24:39 myvm elasticsearch[2269458]: WARNING: System::setSecurityManager will be removed in a future release  
Sep 26 11:24:40 myvm elasticsearch[2269458]: WARNING: A terminally deprecated method in java.lang.System has been called  
Sep 26 11:24:40 myvm elasticsearch[2269458]: WARNING: System::setSecurityManager has been called by org.elasticsearch.bootstrap.Security (file:/usr/share/elasticsearch/lib/elasticsearc\>  
Sep 26 11:24:40 myvm elasticsearch[2269458]: WARNING: Please consider reporting this to the maintainers of org.elasticsearch.bootstrap.Security  
Sep 26 11:24:40 myvm elasticsearch[2269458]: WARNING: System::setSecurityManager will be removed in a future release  
Sep 26 11:24:40 myvm systemd[1]: elasticsearch.service: Main process exited, code=exited, status=1/FAILURE  
Sep 26 11:24:40 myvm systemd[1]: elasticsearch.service: Failed with result 'exit-code'.  
Sep 26 11:24:40 myvm systemd[1]: elasticsearch.service: Consumed 5.465s CPU time.

I checked the permissions and the config, but I'm not sure what else to check. Do you have a suggestion?

Thank you!

---

<div class="post-metadata">

**Author:** ![warkolm](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/warkolm/32/39224_2.png) [@warkolm](https://discuss.elastic.co/u/warkolm)\
**Post date:** [September 26, 2022, 10:07am UTC](https://discuss.elastic.co/t/elasticsearch-does-not-start/315156/2 "2022-09-26T10:07:22Z")

</div>

Welcome to our community! 😃

Elasticsearch 6.8 is [EOL](https://www.elastic.co/support/eol) and you should not be using it. Please use 8.4 as it is the latest.

The best thing you can do here, other than use a more modern release, is to check `/var/log/elasticsearch/elasticsearch.log` for more information.

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [October 24, 2022, 10:08am UTC](https://discuss.elastic.co/t/elasticsearch-does-not-start/315156/4 "2022-10-24T10:08:02Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
