# Elasticsearch doesn’t start: status=1/FAILURE (TLS/x-pack)

**URL:** https://discuss.elastic.co/t/elasticsearch-doesn-t-start-status-1-failure-tls-x-pack/123498
**Category:** Elasticsearch
**Created:** [March 12, 2018, 8:00am UTC](https://discuss.elastic.co/t/elasticsearch-doesn-t-start-status-1-failure-tls-x-pack/123498 "2018-03-12T08:00:21Z")
**Posts on this page:** 1
**Showing post:** 16

<div class="post-metadata">

### Author: ![manst](https://avatars.discourse-cdn.com/v4/letter/m/ed655f/32.png) [@manst](https://discuss.elastic.co/u/manst)
#### Post date: [March 15, 2018, 6:46pm UTC](https://discuss.elastic.co/t/elasticsearch-doesn-t-start-status-1-failure-tls-x-pack/123498/16 "2018-03-15T18:46:23Z")

</div>

I've seeing error and corrected it

[quote="manst, post:12, topic:123498"]  
discovery.zen.ping.unicast.hosts: ["192.168.222.232:9300", "192.168.222.233:9300"]

Now my first node see the second.

And next bulb of errors:

```
[INFO][o.e.d.z.ZenDiscovery] [master] failed to send join request to master [{data}{KC0RJjSzQhiagzzhHcDjag}{kC1Lw4_2RV6H8ebfXMgXGw}{192.168.222.233}{192.168.222.233:9300}{ml.machine_memory=1722236928, ml.max_open_jobs=20, ml.enabled=true}], reason [RemoteTransportException[[data][192.168.222.233:9300][internal:discovery/zen/join]]; nested: IllegalArgumentException[can't add node {master}{KC0RJjSzQhiagzzhHcDjag}{0lx-KxDlS5iVU-TI1xhMew}{192.168.222.232}{192.168.222.232:9300}{ml.machine_memory=2101534720, ml.max_open_jobs=20, ml.enabled=true}, found existing node {data}{KC0RJjSzQhiagzzhHcDjag}{kC1Lw4_2RV6H8ebfXMgXGw}{192.168.222.233}{192.168.222.233:9300}{ml.machine_memory=1722236928, ml.max_open_jobs=20, ml.enabled=true} with the same id but is a different node instance]; ]

```

solution for this error (you must deleted contents of data folder(/var/lib/elasticsearch/nodes/0) and restarted both the servers ):

> [@Setting up elastic search master and data node configuration in two different servers](https://discuss.elastic.co/t/setting-up-elastic-search-master-and-data-node-configuration-in-two-different-servers/98012/2):
>
> I have got the solution. As I installed through rpm packages in the logs I was getting below issue: [2017-08-24T03:50:01,331][INFO][o.e.d.z.ZenDiscovery] [node-2] failed to send join request to master [{node-1}{sYqhGZc4QyK\_cbZ9\_cz8gQ}{BBHUedE6Roaw0AMiYnQwIg}{172.31.4.119}{172.31.4.119:9300}], reason [RemoteTransportException[[node-1][172.31.4.119:9300][internal:discovery/zen/join]]; nested: IllegalArgumentException[can't add node {node-2}{sYqhGZc4QyK\_cbZ9\_cz8gQ}{FbDpyWy2S7SS1c8TvLsnfQ}{17…

Than I should change passwords , because i've had error:

```
/var/log/elasticsearch# curl -s 'localhost:9200/_cat/nodes?pretty' -u elastic:pass
{
  "error" : {
    "root_cause" : [
      {
        "type" : "security_exception",
        "reason" : "failed to authenticate user [elastic]",
        "header" : {
          "WWW-Authenticate" : "Basic realm=\"security\" charset=\"UTF-8\""
        }
      }
    ],
    "type" : "security_exception",
    "reason" : "failed to authenticate user [elastic]",
    "header" : {
      "WWW-Authenticate" : "Basic realm=\"security\" charset=\"UTF-8\""
    }
  },
  "status" : 401

```

---

_[View the full topic](https://discuss.elastic.co/t/elasticsearch-doesn-t-start-status-1-failure-tls-x-pack/123498)._
