# Elasticsearch error, after xpack authencation enabled

**URL:** <https://discuss.elastic.co/t/elasticsearch-error-after-xpack-authencation-enabled/326743>\
**Category:** Elasticsearch\
**Tags:** elastic-stack-security\
**Created:** [March 1, 2023, 9:46am UTC](https://discuss.elastic.co/t/elasticsearch-error-after-xpack-authencation-enabled/326743 "2023-03-01T09:46:07Z")\
**Posts on this page:** 3\
**Page:** 1

<div class="post-metadata">

**Author:** ![k\_noor](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/k_noor/32/117896_2.png) [@k\_noor](https://discuss.elastic.co/u/k_noor)\
**Post date:** [March 1, 2023, 9:46am UTC](https://discuss.elastic.co/t/elasticsearch-error-after-xpack-authencation-enabled/326743/1 "2023-03-01T09:46:07Z")

</div>

HI All,  
I have enabled the pack for authentication purpose, but error has reported as below.  
Cloud you please help in this.

at org.elasticsearch.bootstrap.Elasticsearch.init(Elasticsearch.java:173) ~[elasticsearch-7.17.9.jar:7.17.9]  
at org.elasticsearch.bootstrap.Elasticsearch.execute(Elasticsearch.java:160) ~[elasticsearch-7.17.9.jar:7.17.9]  
at org.elasticsearch.cli.EnvironmentAwareCommand.execute(EnvironmentAwareCommand.java:77) ~[elasticsearch-7.17.9.jar:7.17.9]  
at org.elasticsearch.cli.Command.mainWithoutErrorHandling(Command.java:112) ~[elasticsearch-cli-7.17.9.jar:7.17.9]  
at org.elasticsearch.cli.Command.main(Command.java:77) ~[elasticsearch-cli-7.17.9.jar:7.17.9]  
at org.elasticsearch.bootstrap.Elasticsearch.main(Elasticsearch.java:125) ~[elasticsearch-7.17.9.jar:7.17.9]  
at org.elasticsearch.bootstrap.Elasticsearch.main(Elasticsearch.java:80) ~[elasticsearch-7.17.9.jar:7.17.9]  
Caused by: java.lang.IllegalArgumentException: unknown setting [xpack.security.enrollment.enabled] did you mean any of [xpack.security.fips\_mode.enabled, xpack.security.dls\_fls.enabled, xpack.security.audit.enabled, xpack.security.authc.token.enabled, xpack.security.http.filter.enabled]?  
at org.elasticsearch.common.settings.AbstractScopedSettings.validate(AbstractScopedSettings.java:561) ~[elasticsearch-7.17.9.jar:7.17.9]  
at org.elasticsearch.common.settings.AbstractScopedSettings.validate(AbstractScopedSettings.java:507) ~[elasticsearch-7.17.9.jar:7.17.9]  
at org.elasticsearch.common.settings.AbstractScopedSettings.validate(AbstractScopedSettings.java:477) ~[elasticsearch-7.17.9.jar:7.17.9]  
at org.elasticsearch.common.settings.AbstractScopedSettings.validate(AbstractScopedSettings.java:447) ~[elasticsearch-7.17.9.jar:7.17.9]  
at org.elasticsearch.common.settings.SettingsModule.(SettingsModule.java:137) ~[elasticsearch-7.17.9.jar:7.17.9]  
at org.elasticsearch.node.Node.(Node.java:502) ~[elasticsearch-7.17.9.jar:7.17.9]  
at org.elasticsearch.node.Node.(Node.java:309) ~[elasticsearch-7.17.9.jar:7.17.9]  
at org.elasticsearch.bootstrap.Bootstrap$5.(Bootstrap.java:234) ~[elasticsearch-7.17.9.jar:7.17.9]  
at org.elasticsearch.bootstrap.Bootstrap.setup(Bootstrap.java:234) ~[elasticsearch-7.17.9.jar:7.17.9]  
at org.elasticsearch.bootstrap.Bootstrap.init(Bootstrap.java:434) ~[elasticsearch-7.17.9.jar:7.17.9]  
at org.elasticsearch.bootstrap.Elasticsearch.init(Elasticsearch.java:169) ~[elasticsearch-7.17.9.jar:7.17.9]  
... 6 more

---

<div class="post-metadata">

**Author:** ![Yang\_Wang](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/yang_wang/32/48857_2.png) [@Yang\_Wang](https://discuss.elastic.co/u/Yang_Wang)\
**Post date:** [March 5, 2023, 11:32pm UTC](https://discuss.elastic.co/t/elasticsearch-error-after-xpack-authencation-enabled/326743/2 "2023-03-05T23:32:41Z")

</div>

[Security autoconfiguration](https://www.elastic.co/guide/en/elasticsearch/reference/current/configuring-stack-security.html) is a feature for version 8.0+. The setting `xpack.security.enrollment.enabled` is part of it. Since you are using version 7.17.9, it does not understand this setting. You need remove it from the YAML configuration file.

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [April 2, 2023, 11:33pm UTC](https://discuss.elastic.co/t/elasticsearch-error-after-xpack-authencation-enabled/326743/4 "2023-04-02T23:33:21Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
