# Elasticsearch ERROR: Failed to verify bootstrap password ---

**URL:** https://discuss.elastic.co/t/elasticsearch-error-failed-to-verify-bootstrap-password/181732
**Category:** Elasticsearch
**Created:** [May 20, 2019, 3:42am UTC](https://discuss.elastic.co/t/elasticsearch-error-failed-to-verify-bootstrap-password/181732 "2019-05-20T03:42:40Z")
**Posts on this page:** 3
**Page:** 1

<div class="post-metadata">

### Author: ![hari.v](https://avatars.discourse-cdn.com/v4/letter/h/eb8c5e/32.png) [@hari.v](https://discuss.elastic.co/u/hari.v)
#### Post date: [May 20, 2019, 3:42am UTC](https://discuss.elastic.co/t/elasticsearch-error-failed-to-verify-bootstrap-password/181732/1 "2019-05-20T03:42:40Z")

</div>

Hi

after ii upgraded to platinum license and then reset the password in elasticsearch 7.0 (bin/elasticsearch-setup-passwords interactive). i could able to login in elastic user.

but i couldnt able to login using kibana user.

In browser shows "{"statusCode":403,"error":"Forbidden","message":"Forbidden"}"

and i tried to reset the password again in elasticsearch node.  
shows below error:

[root@elastic1 elasticsearch]# bin/elasticsearch-setup-passwords interactive

Failed to authenticate user 'elastic' against [http://192.168.x.x:9200/\_security/\_authenticate?pretty](http://192.168.x.x:9200/_security/_authenticate?pretty)  
Possible causes include:

- The password for the 'elastic' user has already been changed on this cluster
- Your elasticsearch node is running against a different keystore  
This tool used the keystore at /etc/elasticsearch/elasticsearch.keystore

ERROR: Failed to verify bootstrap password

[root@elastic1 elasticsearch]# curl -u elastic:elastic [http://192.168.x.x:9200/\_xpack/security/\_authenticate?pretty](http://192.168.x.x:9200/_xpack/security/_authenticate?pretty)  
{  
"username" : "elastic",  
"roles" : [  
"superuser"  
],  
"full\_name" : null,  
"email" : null,  
"metadata" : {  
"\_reserved" : true  
},  
"enabled" : true,  
"authentication\_realm" : {  
"name" : "reserved",  
"type" : "reserved"  
},  
"lookup\_realm" : {  
"name" : "reserved",  
"type" : "reserved"  
}  
}

how to fix this issue.

---

<div class="post-metadata">

### Author: ![hari.v](https://avatars.discourse-cdn.com/v4/letter/h/eb8c5e/32.png) [@hari.v](https://discuss.elastic.co/u/hari.v)
#### Post date: [May 20, 2019, 4:22am UTC](https://discuss.elastic.co/t/elasticsearch-error-failed-to-verify-bootstrap-password/181732/2 "2019-05-20T04:22:15Z")

</div>

i restarted elasticsearch service.. . shows

[2019-05-20T20:21:23,046][INFO][o.e.x.s.a.AuthenticationService] [node-1] Authentication of [kibana] was terminated by realm [reserved] - failed to authenticate user [kibana]

---

<div class="post-metadata">

### Author: ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)
#### Post date: [June 17, 2019, 4:23am UTC](https://discuss.elastic.co/t/elasticsearch-error-failed-to-verify-bootstrap-password/181732/3 "2019-06-17T04:23:20Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
