# Elasticsearch error :missing authentication credentials for REST request

**URL:** <https://discuss.elastic.co/t/elasticsearch-error-missing-authentication-credentials-for-rest-request/364941>\
**Category:** Elasticsearch\
**Tags:** elastic-stack-security\
**Created:** [August 15, 2024, 8:33am UTC](https://discuss.elastic.co/t/elasticsearch-error-missing-authentication-credentials-for-rest-request/364941 "2024-08-15T08:33:56Z")\
**Posts on this page:** 2\
**Page:** 1

<div class="post-metadata">

**Author:** ![Frank23](https://avatars.discourse-cdn.com/v4/letter/f/8e7dd6/32.png) [@Frank23](https://discuss.elastic.co/u/Frank23)\
**Post date:** [August 15, 2024, 8:33am UTC](https://discuss.elastic.co/t/elasticsearch-error-missing-authentication-credentials-for-rest-request/364941/1 "2024-08-15T08:33:56Z")

</div>

I installed version 8.11.1 of elasticsearch in the domain server. After the local configuration is complete, the web page can be opened normally.

But when you try to open a web page in an external browser, you are prompted with missing authentication credentials for REST request. As shown in the figure

 ![2](https://us1.discourse-cdn.com/elastic/original/3X/4/3/43013693b4ea8a506c873fe90581bfc277a6298f.png)

Why does this lead to a situation like this and how to fix it, thank you

---

<div class="post-metadata">

**Author:** ![TimV](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/timv/32/13162_2.png) [@TimV](https://discuss.elastic.co/u/TimV)\
**Post date:** [August 19, 2024, 3:24am UTC](https://discuss.elastic.co/t/elasticsearch-error-missing-authentication-credentials-for-rest-request/364941/2 "2024-08-19T03:24:26Z")

</div>

Elasticsearch is not intended to be used from a web browser. You _can_ but it won't be very useful.

I suspect the issue here is that you want to install & use Kibana on top of Elasticsearch. Kibana will give you tools to use and manage Elasticsearch including a real login page where you can enter credentials.
