# Elasticsearch - error while trying to start service on OpenShift

**URL:** <https://discuss.elastic.co/t/elasticsearch-error-while-trying-to-start-service-on-openshift/258088>\
**Category:** Elasticsearch\
**Created:** [December 9, 2020, 7:57am UTC](https://discuss.elastic.co/t/elasticsearch-error-while-trying-to-start-service-on-openshift/258088 "2020-12-09T07:57:40Z")\
**Posts on this page:** 9\
**Page:** 1

<div class="post-metadata">

**Author:** ![Aniket\_Salvi](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/aniket_salvi/32/45433_2.png) [@Aniket\_Salvi](https://discuss.elastic.co/u/Aniket_Salvi)\
**Post date:** [December 9, 2020, 7:57am UTC](https://discuss.elastic.co/t/elasticsearch-error-while-trying-to-start-service-on-openshift/258088/1 "2020-12-09T07:57:40Z")

</div>

Hi,

I got following error in Elasticsearch. Elasticsearch is installed on Openshift.  
Elasticsearch version - 6.4.3. OSS

**Elasticsearch logs:**

```
OpenJDK 64-Bit Server VM warning: Option UseConcMarkSweepGC was deprecated in version 9.0 and will likely be removed in a future release.
[2020-12-09T07:46:26,677][INFO][o.e.n.Node] [] initializing ...
[2020-12-09T07:46:26,714][WARN][o.e.b.ElasticsearchUncaughtExceptionHandler] [] uncaught exception in thread [main]
org.elasticsearch.bootstrap.StartupException: java.lang.IllegalStateException: failed to obtain node locks, tried [[/usr/share/elasticsearch/data/docker-cluster]] with lock id [0]; maybe these locations are not writable or multiple nodes were started without increasing [node.max_local_storage_nodes] (was [1])?
    at org.elasticsearch.bootstrap.Elasticsearch.init(Elasticsearch.java:140) ~[elasticsearch-6.4.3.jar:6.4.3]
    at org.elasticsearch.bootstrap.Elasticsearch.execute(Elasticsearch.java:127) ~[elasticsearch-6.4.3.jar:6.4.3]
    at org.elasticsearch.cli.EnvironmentAwareCommand.execute(EnvironmentAwareCommand.java:86) ~[elasticsearch-6.4.3.jar:6.4.3]
    at org.elasticsearch.cli.Command.mainWithoutErrorHandling(Command.java:124) ~[elasticsearch-cli-6.4.3.jar:6.4.3]
    at org.elasticsearch.cli.Command.main(Command.java:90) ~[elasticsearch-cli-6.4.3.jar:6.4.3]
    at org.elasticsearch.bootstrap.Elasticsearch.main(Elasticsearch.java:93) ~[elasticsearch-6.4.3.jar:6.4.3]
    at org.elasticsearch.bootstrap.Elasticsearch.main(Elasticsearch.java:86) ~[elasticsearch-6.4.3.jar:6.4.3]
Caused by: java.lang.IllegalStateException: failed to obtain node locks, tried [[/usr/share/elasticsearch/data/docker-cluster]] with lock id [0]; maybe these locations are not writable or multiple nodes were started without increasing [node.max_local_storage_nodes] (was [1])?
    at org.elasticsearch.env.NodeEnvironment.<init>(NodeEnvironment.java:247) ~[elasticsearch-6.4.3.jar:6.4.3]
    at org.elasticsearch.node.Node.<init>(Node.java:274) ~[elasticsearch-6.4.3.jar:6.4.3]
    at org.elasticsearch.node.Node.<init>(Node.java:256) ~[elasticsearch-6.4.3.jar:6.4.3]
    at org.elasticsearch.bootstrap.Bootstrap$5.<init>(Bootstrap.java:213) ~[elasticsearch-6.4.3.jar:6.4.3]
    at org.elasticsearch.bootstrap.Bootstrap.setup(Bootstrap.java:213) ~[elasticsearch-6.4.3.jar:6.4.3]
    at org.elasticsearch.bootstrap.Bootstrap.init(Bootstrap.java:326) ~[elasticsearch-6.4.3.jar:6.4.3]
    at org.elasticsearch.bootstrap.Elasticsearch.init(Elasticsearch.java:136) ~[elasticsearch-6.4.3.jar:6.4.3]
    ... 6 more

```

Thanks

---

<div class="post-metadata">

**Author:** ![dadoonet](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/dadoonet/32/137187_2.png) [@dadoonet](https://discuss.elastic.co/u/dadoonet)\
**Post date:** [December 9, 2020, 8:33am UTC](https://discuss.elastic.co/t/elasticsearch-error-while-trying-to-start-service-on-openshift/258088/2 "2020-12-09T08:33:21Z")

</div>

Please don't post unformatted code, logs, or configuration as it might be hard to read.

Instead, paste the text and format it with \</\> icon or pairs of triple backticks (```), and check the preview window to make sure it's properly formatted before posting it. This makes it more likely that your question will receive a useful answer.

It would be great if you could update your post to solve this.

Anyway. Some answers:

> [@Aniket\_Salvi](#):
>
> Elasticsearch version - 6.4.3. OSS

Please at least use the latest 6.8 version instead. Or better use the 7.10.0. 6.4 is already too old to start a project with.

> [@Aniket\_Salvi](#):
>
> Caused by: java.lang.IllegalStateException: failed to obtain node locks, tried [[/usr/share/elasticsearch/data/docker-cluster]] with lock id [0]; maybe these locations are not writable or multiple nodes were started without increasing [node.max\_local\_storage\_nodes] (was [1])?

This line indicates that a node is probably already running in this location. You need to stop it first.

---

<div class="post-metadata">

**Author:** ![Aniket\_Salvi](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/aniket_salvi/32/45433_2.png) [@Aniket\_Salvi](https://discuss.elastic.co/u/Aniket_Salvi)\
**Post date:** [December 9, 2020, 9:38am UTC](https://discuss.elastic.co/t/elasticsearch-error-while-trying-to-start-service-on-openshift/258088/3 "2020-12-09T09:38:52Z")

</div>

Thanks @dadoonet.

I tried your solution but facing same issue.

This is my Elasticsearch logs:

```
[2020-12-09T07:46:26,677][INFO][o.e.n.Node] [] initializing ...
[2020-12-09T07:46:26,714][WARN][o.e.b.ElasticsearchUncaughtExceptionHandler] [] uncaught exception in thread [main]
org.elasticsearch.bootstrap.StartupException: java.lang.IllegalStateException: failed to obtain node locks, tried [[/usr/share/elasticsearch/data/docker-cluster]] with lock id [0]; maybe these locations are not writable or multiple nodes were started without increasing [node.max_local_storage_nodes] (was [1])?
        at org.elasticsearch.bootstrap.Elasticsearch.init(Elasticsearch.java:140) ~[elasticsearch-6.4.3.jar:6.4.3]
        at org.elasticsearch.bootstrap.Elasticsearch.execute(Elasticsearch.java:127) ~[elasticsearch-6.4.3.jar:6.4.3]
        at org.elasticsearch.cli.EnvironmentAwareCommand.execute(EnvironmentAwareCommand.java:86) ~[elasticsearch-6.4.3.jar:6.4.3]
        at org.elasticsearch.cli.Command.mainWithoutErrorHandling(Command.java:124) ~[elasticsearch-cli-6.4.3.jar:6.4.3]
        at org.elasticsearch.cli.Command.main(Command.java:90) ~[elasticsearch-cli-6.4.3.jar:6.4.3]
        at org.elasticsearch.bootstrap.Elasticsearch.main(Elasticsearch.java:93) ~[elasticsearch-6.4.3.jar:6.4.3]
        at org.elasticsearch.bootstrap.Elasticsearch.main(Elasticsearch.java:86) ~[elasticsearch-6.4.3.jar:6.4.3]
Caused by: java.lang.IllegalStateException: failed to obtain node locks, tried [[/usr/share/elasticsearch/data/docker-cluster]] with lock id [0]; maybe these locations are not writable or multiple nodes were started without increasing [node.max_local_storage_nodes] (was [1])?
        at org.elasticsearch.env.NodeEnvironment.<init>(NodeEnvironment.java:247) ~[elasticsearch-6.4.3.jar:6.4.3]
        at org.elasticsearch.node.Node.<init>(Node.java:274) ~[elasticsearch-6.4.3.jar:6.4.3]
        at org.elasticsearch.node.Node.<init>(Node.java:256) ~[elasticsearch-6.4.3.jar:6.4.3]
        at org.elasticsearch.bootstrap.Bootstrap$5.<init>(Bootstrap.java:213) ~[elasticsearch-6.4.3.jar:6.4.3]
        at org.elasticsearch.bootstrap.Bootstrap.setup(Bootstrap.java:213) ~[elasticsearch-6.4.3.jar:6.4.3]
        at org.elasticsearch.bootstrap.Bootstrap.init(Bootstrap.java:326) ~[elasticsearch-6.4.3.jar:6.4.3]
        at org.elasticsearch.bootstrap.Elasticsearch.init(Elasticsearch.java:136) ~[elasticsearch-6.4.3.jar:6.4.3]
        ... 6 more
```

---

<div class="post-metadata">

**Author:** ![dadoonet](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/dadoonet/32/137187_2.png) [@dadoonet](https://discuss.elastic.co/u/dadoonet)\
**Post date:** [December 9, 2020, 10:34am UTC](https://discuss.elastic.co/t/elasticsearch-error-while-trying-to-start-service-on-openshift/258088/4 "2020-12-09T10:34:14Z")

</div>

Is that a new project? Are you running it with Docker?

---

<div class="post-metadata">

**Author:** ![Aniket\_Salvi](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/aniket_salvi/32/45433_2.png) [@Aniket\_Salvi](https://discuss.elastic.co/u/Aniket_Salvi)\
**Post date:** [December 9, 2020, 11:11am UTC](https://discuss.elastic.co/t/elasticsearch-error-while-trying-to-start-service-on-openshift/258088/5 "2020-12-09T11:11:18Z")

</div>

Hi @dadoonet,

Are you running it with Docker?  
Yes

Is that a new project?  
I am not getting your point but I think following description helps you.  
I have one project on open-shift. Inside that project I have one pod for Elasticsearch.

Thanks

---

<div class="post-metadata">

**Author:** ![Aniket\_Salvi](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/aniket_salvi/32/45433_2.png) [@Aniket\_Salvi](https://discuss.elastic.co/u/Aniket_Salvi)\
**Post date:** [December 9, 2020, 11:19am UTC](https://discuss.elastic.co/t/elasticsearch-error-while-trying-to-start-service-on-openshift/258088/6 "2020-12-09T11:19:41Z")

</div>

Hi @dadoonet,

I just created a new pod for Elasticsearch and my Elasticsearch service is running properly.

Thanks

---

<div class="post-metadata">

**Author:** ![dadoonet](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/dadoonet/32/137187_2.png) [@dadoonet](https://discuss.elastic.co/u/dadoonet)\
**Post date:** [December 9, 2020, 11:24am UTC](https://discuss.elastic.co/t/elasticsearch-error-while-trying-to-start-service-on-openshift/258088/7 "2020-12-09T11:24:05Z")

</div>

> [@Aniket\_Salvi](#):
>
> I just created a new pod for Elasticsearch and my Elasticsearch service is running properly.

I was asking that because in that case, you can just scratch the `data` dir. That will remove everything.  
If it's a new project, please use 7.10.0 instead.

---

<div class="post-metadata">

**Author:** ![Aniket\_Salvi](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/aniket_salvi/32/45433_2.png) [@Aniket\_Salvi](https://discuss.elastic.co/u/Aniket_Salvi)\
**Post date:** [December 9, 2020, 11:27am UTC](https://discuss.elastic.co/t/elasticsearch-error-while-trying-to-start-service-on-openshift/258088/8 "2020-12-09T11:27:38Z")

</div>

Hi @dadoonet,

No, It's not a new project.

Thanks

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [January 6, 2021, 11:27am UTC](https://discuss.elastic.co/t/elasticsearch-error-while-trying-to-start-service-on-openshift/258088/9 "2021-01-06T11:27:43Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
