# Elasticsearch errors while running

**URL:** <https://discuss.elastic.co/t/elasticsearch-errors-while-running/191321>\
**Category:** Elasticsearch\
**Created:** [July 19, 2019, 6:02am UTC](https://discuss.elastic.co/t/elasticsearch-errors-while-running/191321 "2019-07-19T06:02:07Z")\
**Posts on this page:** 19\
**Page:** 1

<div class="post-metadata">

**Author:** ![pharshil9697](https://avatars.discourse-cdn.com/v4/letter/p/34f0e0/32.png) [@pharshil9697](https://discuss.elastic.co/u/pharshil9697)\
**Post date:** [July 19, 2019, 6:02am UTC](https://discuss.elastic.co/t/elasticsearch-errors-while-running/191321/1 "2019-07-19T06:02:07Z")

</div>

After downloading and extracting the zip file, I tried to run the bat file. Now it is showing this error. I am kind of not able to figure this out. I checked the logs this is what it displays.  
Elasticsearch version : 7.2.2  
Plugins installed : None  
OS : Windows 8.1 Pro 64-bit(6.3, Build 9600)  
JAVA\_VERSION="12.0.1"  
I have not done any non-default configuration settings.

Caused by: org.elasticsearch.ElasticsearchException: Failed to create native process factories for Machine Learning  
at org.elasticsearch.xpack.ml.MachineLearning.createComponents(MachineLearning.java:455) ~[?:?]  
at org.elasticsearch.node.Node.lambda$new$9(Node.java:438) ~[elasticsearch-7.2.0.jar:7.2.0]  
at java.util.stream.ReferencePipeline$7$1.accept(ReferencePipeline.java:271) ~[?:?]  
at java.util.ArrayList$ArrayListSpliterator.forEachRemaining(ArrayList.java:1654) ~[?:?]  
at java.util.stream.AbstractPipeline.copyInto(AbstractPipeline.java:484) ~[?:?]  
at java.util.stream.AbstractPipeline.wrapAndCopyInto(AbstractPipeline.java:474) ~[?:?]  
at java.util.stream.ReduceOps$ReduceOp.evaluateSequential(ReduceOps.java:913) ~[?:?]  
at java.util.stream.AbstractPipeline.evaluate(AbstractPipeline.java:234) ~[?:?]  
at java.util.stream.ReferencePipeline.collect(ReferencePipeline.java:578) ~[?:?]  
at org.elasticsearch.node.Node.(Node.java:441) ~[elasticsearch-7.2.0.jar:7.2.0]  
at org.elasticsearch.node.Node.(Node.java:251) ~[elasticsearch-7.2.0.jar:7.2.0]  
at org.elasticsearch.bootstrap.Bootstrap$5.(Bootstrap.java:221) ~[elasticsearch-7.2.0.jar:7.2.0]  
at org.elasticsearch.bootstrap.Bootstrap.setup(Bootstrap.java:221) ~[elasticsearch-7.2.0.jar:7.2.0]  
at org.elasticsearch.bootstrap.Bootstrap.init(Bootstrap.java:349) ~[elasticsearch-7.2.0.jar:7.2.0]  
at org.elasticsearch.bootstrap.Elasticsearch.init(Elasticsearch.java:159) ~[elasticsearch-7.2.0.jar:7.2.0]  
... 6 more  
Caused by: java.io.FileNotFoundException: \.\pipe\controller\_log\_528 (The system cannot find the file specified)  
at java.io.FileInputStream.open0(Native Method) ~[?:?]  
at java.io.FileInputStream.open(FileInputStream.java:213) ~[?:?]  
at java.io.FileInputStream.(FileInputStream.java:155) ~[?:?]  
at java.io.FileInputStream.(FileInputStream.java:110) ~[?:?]  
at org.elasticsearch.xpack.ml.utils.NamedPipeHelper$PrivilegedInputPipeOpener.run(NamedPipeHelper.java:288) ~[?:?]  
at org.elasticsearch.xpack.ml.utils.NamedPipeHelper$PrivilegedInputPipeOpener.run(NamedPipeHelper.java:277) ~[?:?]  
at java.security.AccessController.doPrivileged(AccessController.java:310) ~[?:?]  
at org.elasticsearch.xpack.ml.utils.NamedPipeHelper.openNamedPipeInputStream(NamedPipeHelper.java:130) ~[?:?]  
at org.elasticsearch.xpack.ml.utils.NamedPipeHelper.openNamedPipeInputStream(NamedPipeHelper.java:97) ~[?:?]  
at org.elasticsearch.xpack.ml.process.ProcessPipes.connectStreams(ProcessPipes.java:131) ~[?:?]  
at org.elasticsearch.xpack.ml.process.NativeController.(NativeController.java:62) ~[?:?]  
at org.elasticsearch.xpack.ml.process.NativeControllerHolder.getNativeController(NativeControllerHolder.java:40) ~[?:?]  
at org.elasticsearch.xpack.ml.MachineLearning.createComponents(MachineLearning.java:440) ~[?:?]  
at org.elasticsearch.node.Node.lambda$new$9(Node.java:438) ~[elasticsearch-7.2.0.jar:7.2.0]  
at java.util.stream.ReferencePipeline$7$1.accept(ReferencePipeline.java:271) ~[?:?]  
at java.util.ArrayList$ArrayListSpliterator.forEachRemaining(ArrayList.java:1654) ~[?:?]  
at java.util.stream.AbstractPipeline.copyInto(AbstractPipeline.java:484) ~[?:?]  
at java.util.stream.AbstractPipeline.wrapAndCopyInto(AbstractPipeline.java:474) ~[?:?]  
at java.util.stream.ReduceOps$ReduceOp.evaluateSequential(ReduceOps.java:913) ~[?:?]  
at java.util.stream.AbstractPipeline.evaluate(AbstractPipeline.java:234) ~[?:?]  
at java.util.stream.ReferencePipeline.collect(ReferencePipeline.java:578) ~[?:?]  
at org.elasticsearch.node.Node.(Node.java:441) ~[elasticsearch-7.2.0.jar:7.2.0]  
at org.elasticsearch.node.Node.(Node.java:251) ~[elasticsearch-7.2.0.jar:7.2.0]  
at org.elasticsearch.bootstrap.Bootstrap$5.(Bootstrap.java:221) ~[elasticsearch-7.2.0.jar:7.2.0]  
at org.elasticsearch.bootstrap.Bootstrap.setup(Bootstrap.java:221) ~[elasticsearch-7.2.0.jar:7.2.0]  
at org.elasticsearch.bootstrap.Bootstrap.init(Bootstrap.java:349) ~[elasticsearch-7.2.0.jar:7.2.0]  
at org.elasticsearch.bootstrap.Elasticsearch.init(Elasticsearch.java:159) ~[elasticsearch-7.2.0.jar:7.2.0]  
... 6 more

---

<div class="post-metadata">

**Author:** ![Christian\_Dahlqvist](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/christian_dahlqvist/32/4617_2.png) [@Christian\_Dahlqvist](https://discuss.elastic.co/u/Christian_Dahlqvist)\
**Post date:** [July 19, 2019, 6:04am UTC](https://discuss.elastic.co/t/elasticsearch-errors-while-running/191321/2 "2019-07-19T06:04:48Z")

</div>

Please do not just provide a stack trace and expect help. Provide some information around how you got this error, e.g. how you installed it, what platform and operating system it is running on and any non-default configuration you may have applied.

If you can not spend the time to add useful information and context, why should anyone spend their time trying to help you based on the little information available? This forum is manned by volunteers, so the more information and structure you provide, the better the chance of getting help.

---

<div class="post-metadata">

**Author:** ![pharshil9697](https://avatars.discourse-cdn.com/v4/letter/p/34f0e0/32.png) [@pharshil9697](https://discuss.elastic.co/u/pharshil9697)\
**Post date:** [July 19, 2019, 6:17am UTC](https://discuss.elastic.co/t/elasticsearch-errors-while-running/191321/3 "2019-07-19T06:17:12Z")

</div>

Thanks Christian. I have edited it. I am new to this platform and want to learn by applying,but these errors I am not able to figure out.

---

<div class="post-metadata">

**Author:** ![Christian\_Dahlqvist](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/christian_dahlqvist/32/4617_2.png) [@Christian\_Dahlqvist](https://discuss.elastic.co/u/Christian_Dahlqvist)\
**Post date:** [July 19, 2019, 6:19am UTC](https://discuss.elastic.co/t/elasticsearch-errors-while-running/191321/4 "2019-07-19T06:19:08Z")

</div>

Which OS? What platform? Any non-default configuration settings?

---

<div class="post-metadata">

**Author:** ![Priya\_Jajam](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/priya_jajam/32/48693_2.png) [@Priya\_Jajam](https://discuss.elastic.co/u/Priya_Jajam)\
**Post date:** [July 19, 2019, 6:28am UTC](https://discuss.elastic.co/t/elasticsearch-errors-while-running/191321/5 "2019-07-19T06:28:57Z")

</div>

I have deployed elastic search as a container using docker-compose file on ubuntu 18.04. Here is my compose file  
version: '2.2'  
services:  
es01:  
image: [docker.elastic.co/elasticsearch/elasticsearch:7.0.1](http://docker.elastic.co/elasticsearch/elasticsearch:7.0.1)  
container\_name: es01  
environment:  
- node.name=10.x.x.01  
- discovery.seed\_hosts=10.x.x.02  
- discovery.zen.minimum\_master\_nodes=2  
- cluster.initial\_master\_nodes=10.x.x.01,10.x.x.02  
- cluster.name=docker-cluster  
- node.master=true  
- bootstrap.memory\_lock=true  
- "ES\_JAVA\_OPTS=-Xms512m -Xmx512m"  
ulimits:  
memlock:  
soft: -1  
hard: -1  
volumes:  
- esdata01:/usr/share/elasticsearch/data  
ports:  
- 9200:9200  
- 9300:9300  
networks:  
- esnet  
volumes:  
esdata01:  
driver: local  
networks:  
esnet:

docker container is created and working fine but cluster is not created. when check state of cluster i got an error

{  
"error" : {  
"root\_cause" : [  
{  
"type" : "master\_not\_discovered\_exception",  
"reason" : null  
}  
],  
"type" : "master\_not\_discovered\_exception",  
"reason" : null  
},  
"status" : 503  
}

could you please help me out from this  
Thanks in advance

---

<div class="post-metadata">

**Author:** ![dadoonet](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/dadoonet/32/137187_2.png) [@dadoonet](https://discuss.elastic.co/u/dadoonet)\
**Post date:** [July 19, 2019, 6:41am UTC](https://discuss.elastic.co/t/elasticsearch-errors-while-running/191321/6 "2019-07-19T06:41:12Z")

</div>

You're starting only one node but ask for 2 master nodes so that can't work.

---

<div class="post-metadata">

**Author:** ![Priya\_Jajam](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/priya_jajam/32/48693_2.png) [@Priya\_Jajam](https://discuss.elastic.co/u/Priya_Jajam)\
**Post date:** [July 19, 2019, 6:44am UTC](https://discuss.elastic.co/t/elasticsearch-errors-while-running/191321/7 "2019-07-19T06:44:02Z")

</div>

okay. but i want cluster with 2 nodes

---

<div class="post-metadata">

**Author:** ![Priya\_Jajam](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/priya_jajam/32/48693_2.png) [@Priya\_Jajam](https://discuss.elastic.co/u/Priya_Jajam)\
**Post date:** [July 19, 2019, 6:55am UTC](https://discuss.elastic.co/t/elasticsearch-errors-while-running/191321/8 "2019-07-19T06:55:28Z")

</div>

thank you @dadoonet cluster is created now. i have created one more compose file for elasticsearch in node 2 and want to add that to cluster.  
this is my compose file  
version: '2.2'  
services:  
es02:  
image: [docker.elastic.co/elasticsearch/elasticsearch:7.0.1](http://docker.elastic.co/elasticsearch/elasticsearch:7.0.1)  
container\_name: es02  
environment:  
- node.name=10.x.x.02  
- discovery.seed\_hosts=10.x.x.01  
#- discovery.zen.minimum\_master\_nodes=2  
- cluster.initial\_master\_nodes=10.x.x.01,10.x.x.02  
- cluster.name=docker-cluster  
#- node.master=true  
- bootstrap.memory\_lock=true  
#- bootstrap.system\_call\_filter: false  
#- http.cors.enabled=true  
#- http.cors.allow-origin=\*  
#- transport.profiles.default.port=9300  
#- transport.tcp.port=9300  
- "ES\_JAVA\_OPTS=-Xms512m -Xmx512m"  
- "discovery.zen.ping.unicast.hosts=10.x.x.01:9200"  
ulimits:  
memlock:  
soft: -1  
hard: -1  
volumes:  
- esdata02:/usr/share/elasticsearch/data

# ports:

```
  #- 9200:9200
  #- 9300:9300
networks:
  - esnet

```

volumes:  
esdata02:  
driver: local  
networks:  
esnet:

when i run docker-compose up i got following error  
message": "Native controller process has stopped - no new native processes can be started"

Thanks in advance

---

<div class="post-metadata">

**Author:** ![pharshil9697](https://avatars.discourse-cdn.com/v4/letter/p/34f0e0/32.png) [@pharshil9697](https://discuss.elastic.co/u/pharshil9697)\
**Post date:** [July 19, 2019, 7:01am UTC](https://discuss.elastic.co/t/elasticsearch-errors-while-running/191321/9 "2019-07-19T07:01:04Z")

</div>

HI, I have edited. Please help me with this issue

---

<div class="post-metadata">

**Author:** ![Christian\_Dahlqvist](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/christian_dahlqvist/32/4617_2.png) [@Christian\_Dahlqvist](https://discuss.elastic.co/u/Christian_Dahlqvist)\
**Post date:** [July 19, 2019, 7:03am UTC](https://discuss.elastic.co/t/elasticsearch-errors-while-running/191321/10 "2019-07-19T07:03:38Z")

</div>

Why does the stack trace say version 7.2 when your docket file launches 7.0?

---

<div class="post-metadata">

**Author:** ![Priya\_Jajam](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/priya_jajam/32/48693_2.png) [@Priya\_Jajam](https://discuss.elastic.co/u/Priya_Jajam)\
**Post date:** [July 19, 2019, 7:08am UTC](https://discuss.elastic.co/t/elasticsearch-errors-while-running/191321/11 "2019-07-19T07:08:37Z")

</div>

@dadoonet please help me out from this issue. what mistake i made in compose file for elasticsearch in node 2 to add to cluster in node 1.

---

<div class="post-metadata">

**Author:** ![pharshil9697](https://avatars.discourse-cdn.com/v4/letter/p/34f0e0/32.png) [@pharshil9697](https://discuss.elastic.co/u/pharshil9697)\
**Post date:** [July 19, 2019, 7:10am UTC](https://discuss.elastic.co/t/elasticsearch-errors-while-running/191321/12 "2019-07-19T07:10:17Z")

</div>

It is 7.2.0.

---

<div class="post-metadata">

**Author:** ![dadoonet](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/dadoonet/32/137187_2.png) [@dadoonet](https://discuss.elastic.co/u/dadoonet)\
**Post date:** [July 19, 2019, 7:28am UTC](https://discuss.elastic.co/t/elasticsearch-errors-while-running/191321/13 "2019-07-19T07:28:35Z")

</div>

Read [this](https://discuss.elastic.co/t/about-the-elasticsearch-category/21) and specifically the "Also be patient" part.

It's fine to answer on your own thread after 2 or 3 days (not including weekends) if you don't have an answer.

---

<div class="post-metadata">

**Author:** ![dadoonet](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/dadoonet/32/137187_2.png) [@dadoonet](https://discuss.elastic.co/u/dadoonet)\
**Post date:** [July 19, 2019, 7:29am UTC](https://discuss.elastic.co/t/elasticsearch-errors-while-running/191321/14 "2019-07-19T07:29:35Z")

</div>

So what is the **complete and exact** `docker-compose` file you are using?

Please [read this](https://discuss.elastic.co/t/about-the-elasticsearch-category/21) about how to format.

---

<div class="post-metadata">

**Author:** ![pharshil9697](https://avatars.discourse-cdn.com/v4/letter/p/34f0e0/32.png) [@pharshil9697](https://discuss.elastic.co/u/pharshil9697)\
**Post date:** [July 19, 2019, 8:50am UTC](https://discuss.elastic.co/t/elasticsearch-errors-while-running/191321/15 "2019-07-19T08:50:35Z")

</div>

```
elk:

  image: elasticsearch:latest

  ports:    
    - " 127.0.0.1:9200:9200"
    - "9300:9300"

  volumes:
    - ./Elasticsearch/data:/var/lib/elasticsearch
    - ./Elasticsearch/config/elasticsearch.yml:/etc/elasticsearch/config/elasticsearch.yml

  tty : true

Redis:
  image: redis:latest

  ports:
    - "6379:6379"

  volumes:
    - /Redis/redis.conf:/var/lib/redis

  restart: always`
```

---

<div class="post-metadata">

**Author:** ![dadoonet](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/dadoonet/32/137187_2.png) [@dadoonet](https://discuss.elastic.co/u/dadoonet)\
**Post date:** [July 19, 2019, 9:22am UTC](https://discuss.elastic.co/t/elasticsearch-errors-while-running/191321/16 "2019-07-19T09:22:26Z")

</div>

When I run it I have:

```auto
ERROR: The Compose file './docker-compose.yml' is invalid because:
elk.ports is invalid: Invalid port " 127.0.0.1:9200:9200", should be [[remote_ip:]remote_port[-remote_port]:]port[/protocol]

```

---

<div class="post-metadata">

**Author:** ![dadoonet](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/dadoonet/32/137187_2.png) [@dadoonet](https://discuss.elastic.co/u/dadoonet)\
**Post date:** [July 19, 2019, 9:23am UTC](https://discuss.elastic.co/t/elasticsearch-errors-while-running/191321/17 "2019-07-19T09:23:14Z")

</div>

When I then fix the space, I have:

```auto
Pulling elk (elasticsearch:latest)...
ERROR: manifest for elasticsearch:latest not found

```

---

<div class="post-metadata">

**Author:** ![richcollier](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/richcollier/32/115035_2.png) [@richcollier](https://discuss.elastic.co/u/richcollier)\
**Post date:** [July 19, 2019, 2:57pm UTC](https://discuss.elastic.co/t/elasticsearch-errors-while-running/191321/18 "2019-07-19T14:57:23Z")

</div>

See: [Elasticsearch 7.2.0 - Unable to run xpack ml libraries](https://discuss.elastic.co/t/elasticsearch-7-2-0-unable-to-run-xpack-ml-libraries/190383)

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [August 20, 2019, 6:44am UTC](https://discuss.elastic.co/t/elasticsearch-errors-while-running/191321/20 "2019-08-20T06:44:20Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
