# Elasticsearch failed immediately

**URL:** <https://discuss.elastic.co/t/elasticsearch-failed-immediately/196777>\
**Category:** Elasticsearch\
**Created:** [August 26, 2019, 1:31pm UTC](https://discuss.elastic.co/t/elasticsearch-failed-immediately/196777 "2019-08-26T13:31:08Z")\
**Posts on this page:** 3\
**Page:** 1

<div class="post-metadata">

**Author:** ![rvb\_n](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/rvb_n/32/53029_2.png) [@rvb\_n](https://discuss.elastic.co/u/rvb_n)\
**Post date:** [August 26, 2019, 1:31pm UTC](https://discuss.elastic.co/t/elasticsearch-failed-immediately/196777/1 "2019-08-26T13:31:08Z")

</div>

[6:49 PM] Keerthi B R  
org.elasticsearch.bootstrap.StartupException: java.lang.IllegalStateException: cannot downgrade a node from version [7.3.1] to version [7.3.0]  
at org.elasticsearch.bootstrap.Elasticsearch.init(Elasticsearch.java:163) ~[elasticsearch-7.3.0.jar:7.3.0]  
at org.elasticsearch.bootstrap.Elasticsearch.execute(Elasticsearch.java:150) ~[elasticsearch-7.3.0.jar:7.3.0]  
at org.elasticsearch.cli.EnvironmentAwareCommand.execute(EnvironmentAwareCommand.java:86) ~[elasticsearch-7.3.0.jar:7.3.0]  
at org.elasticsearch.cli.Command.mainWithoutErrorHandling(Command.java:124) ~[elasticsearch-cli-7.3.0.jar:7.3.0]  
at org.elasticsearch.cli.Command.main(Command.java:90) ~[elasticsearch-cli-7.3.0.jar:7.3.0]  
at org.elasticsearch.bootstrap.Elasticsearch.main(Elasticsearch.java:115) ~[elasticsearch-7.3.0.jar:7.3.0]  
at org.elasticsearch.bootstrap.Elasticsearch.main(Elasticsearch.java:92) ~[elasticsearch-7.3.0.jar:7.3.0]  
Caused by: java.lang.IllegalStateException: cannot downgrade a node from version [7.3.1] to version [7.3.0]  
at org.elasticsearch.env.NodeMetaData.upgradeToCurrentVersion(NodeMetaData.java:94) ~[elasticsearch-7.3.0.jar:7.3.0]  
at org.elasticsearch.env.NodeEnvironment.loadOrCreateNodeMetaData(NodeEnvironment.java:426) ~[elasticsearch-7.3.0.jar:7.3.0]  
at org.elasticsearch.env.NodeEnvironment.(NodeEnvironment.java:304) ~[elasticsearch-7.3.0.jar:7.3.0]  
at org.elasticsearch.node.Node.(Node.java:278) ~[elasticsearch-7.3.0.jar:7.3.0]  
at org.elasticsearch.node.Node.(Node.java:258) ~[elasticsearch-7.3.0.jar:7.3.0]  
at org.elasticsearch.bootstrap.Bootstrap$5.(Bootstrap.java:221) ~[elasticsearch-7.3.0.jar:7.3.0]  
at org.elasticsearch.bootstrap.Bootstrap.setup(Bootstrap.java:221) ~[elasticsearch-7.3.0.jar:7.3.0]  
at org.elasticsearch.bootstrap.Bootstrap.init(Bootstrap.java:349) ~[elasticsearch-7.3.0.jar:7.3.0]  
at org.elasticsearch.bootstrap.Elasticsearch.init(Elasticsearch.java:159) ~[elasticsearch-7.3.0.jar:7.3.0]

---

<div class="post-metadata">

**Author:** ![mbelaloui](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/mbelaloui/32/49140_2.png) [@mbelaloui](https://discuss.elastic.co/u/mbelaloui)\
**Post date:** [August 26, 2019, 2:02pm UTC](https://discuss.elastic.co/t/elasticsearch-failed-immediately/196777/2 "2019-08-26T14:02:19Z")

</div>

Hello @rvb_n,

Seems that you had the 7.3.1 and you want to came back to the 7.3.0, to start your node you can change or delete the data directory \< Warning : all the document in it will be lost \>

In elasticsearch.yml change :

`path.data: /var/elasticsearch`

NB: you will have to create a new directory tree that are owned by elasticsearch

Mehdi.

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [September 23, 2019, 2:02pm UTC](https://discuss.elastic.co/t/elasticsearch-failed-immediately/196777/3 "2019-09-23T14:02:21Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
