# Elasticsearch "failed to send ping" error

**URL:** <https://discuss.elastic.co/t/elasticsearch-failed-to-send-ping-error/55125>\
**Category:** Elasticsearch\
**Created:** [July 10, 2016, 1:18am UTC](https://discuss.elastic.co/t/elasticsearch-failed-to-send-ping-error/55125 "2016-07-10T01:18:35Z")\
**Posts on this page:** 9\
**Page:** 1

<div class="post-metadata">

**Author:** ![jsmith](https://avatars.discourse-cdn.com/v4/letter/j/df705f/32.png) [@jsmith](https://discuss.elastic.co/u/jsmith)\
**Post date:** [July 10, 2016, 1:18am UTC](https://discuss.elastic.co/t/elasticsearch-failed-to-send-ping-error/55125/1 "2016-07-10T01:18:35Z")

</div>

I am trying to create an Elasticsearch cluster in AWS (without success).  
Currently on two nodes I have the yml files below.

When I run "curl status" on the second node ( where master is false and data is true) the message "master\_not\_discovered\_exception"  
is returned.

In the log there are repeated messages  
**"failed to send ping to [{#zen\_unicast\_1#}{127.0.0.1}{127.0.0.1:9300}]**  
\*\*SendRequestTransportException[[][127.0.0.1:9300][internal:discovery/zen/unicast]]; nested: \*\*  
**NodeNotConnectedException[[][127.0.0.1:9300] Node not connected];"**

In addition, when I run "curl cluster health" on the first node (the one where master is true) the display returned shows the node total as 1.

How do I get these nodes to "see" each other?

Notes: elasticsearch 2.3.3 is installed on both nodes.  
the option "cloud.aws.region" has no effect

(Apology is these are somewhat basic questions. I am new to both AWS and Elasticsearch. However, I have not been  
able to find an online resolution.)

Thank you.

```auto
cluster.name: dev-lambda-elastic
node.name: dev-lambda-elastic-1
node.master: true
node.data: false
bootstrap.mlockall: true
network host: _ec2_
network.publish_host: _ec2_
http.port: 9200
discovery.type: ec2
discovery.zen.minimum_master_nodes: 1
cloud.aws.access_key: XXXXXXXXXXXXXXXXXXXXXXX
cloud.aws.secret_key: XXXXXXXXXXXXXXXXXXXXXXX
#cloud.aws.region: "us-east"

```

```auto
cluster.name: dev-lambda-elastic
node.name: dev-lambda-elastic-2
node.master: false
node.data: true
bootstrap.mlockall: true
network host: _ec2_
network.publish_host: _ec2_
http.port: 9200
discovery.type: ec2
discovery.ec2.ping_timeout: "30s"
discovery.zen.minimum_master_nodes: 1
cloud.aws.access_key: XXXXXXXXXXXXXXXXXXXXXXXXXXXX
cloud.aws.secret_key: XXXXXXXXXXXXXXXXXXXXXXXXXXXX
#cloud.aws.region: "us-east"

```

---

<div class="post-metadata">

**Author:** ![dadoonet](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/dadoonet/32/137187_2.png) [@dadoonet](https://discuss.elastic.co/u/dadoonet)\
**Post date:** [July 10, 2016, 6:03am UTC](https://discuss.elastic.co/t/elasticsearch-failed-to-send-ping-error/55125/2 "2016-07-10T06:03:26Z")

</div>

Please format your post so settings are more readable.

Could you provide the full logs of both instances (and format)?

---

<div class="post-metadata">

**Author:** ![jsmith](https://avatars.discourse-cdn.com/v4/letter/j/df705f/32.png) [@jsmith](https://discuss.elastic.co/u/jsmith)\
**Post date:** [July 10, 2016, 4:51pm UTC](https://discuss.elastic.co/t/elasticsearch-failed-to-send-ping-error/55125/3 "2016-07-10T16:51:23Z")

</div>

I also separately emailed this log with some additional information.  
This is the log for node 2 where master is false and data is true

 ![](https://us1.discourse-cdn.com/elastic/original/2X/8/859b455724f038134db04f06cb5bcda13745465c.jpg)

---

<div class="post-metadata">

**Author:** ![dadoonet](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/dadoonet/32/137187_2.png) [@dadoonet](https://discuss.elastic.co/u/dadoonet)\
**Post date:** [July 11, 2016, 8:43am UTC](https://discuss.elastic.co/t/elasticsearch-failed-to-send-ping-error/55125/4 "2016-07-11T08:43:48Z")

</div>

Please copy logs as text. Don't use screenshots for logs.

I edited your question so it's more readable.

Can you try to remove `network.publish_host` setting on both nodes?  
Restart both nodes and copy the 2 logs here. Format with `</>` icon please.

---

<div class="post-metadata">

**Author:** ![jsmith](https://avatars.discourse-cdn.com/v4/letter/j/df705f/32.png) [@jsmith](https://discuss.elastic.co/u/jsmith)\
**Post date:** [July 11, 2016, 3:49pm UTC](https://discuss.elastic.co/t/elasticsearch-failed-to-send-ping-error/55125/5 "2016-07-11T15:49:02Z")

</div>

I apologize - I have been trying to wrap the logs with html but nothing seems to render correctly on the preview screen.  
Log files when network.publish\_host is revamped from yml

(Sending in two pieces - size limitation of message)

Following is the log for the node where master is FALSE and data is True

[2016-07-11 09:58:28,365][WARN][bootstrap] unable to install syscall filter: seccomp unavailable: CONFIG\_SECCOMP not compiled into kernel, CONFIG\_SECCOMP and CONFIG\_SECCOMP\_FILTER are needed [2016-07-11 09:58:28,613][INFO][node] [dev-lambda-elastic-2] version[2.3.3], pid[7914], build[218bdf1/2016-05-17T15:40:04Z] [2016-07-11 09:58:28,613][INFO][node] [dev-lambda-elastic-2] initializing ... [2016-07-11 09:58:29,326][INFO][plugins] [dev-lambda-elastic-2] modules [reindex, lang-expression, lang-groovy], plugins [head, cloud-aws], sites [head] [2016-07-11 09:58:29,350][INFO][env] [dev-lambda-elastic-2] using [1] data paths, mounts [[/var (/dev/mapper/vg00-var)]], net usable\_space [8.9gb], net total\_space [9.7gb], spins? [no], types [ext4] [2016-07-11 09:58:29,350][INFO][env] [dev-lambda-elastic-2] heap size [989.8mb], compressed ordinary object pointers [true] [2016-07-11 09:58:29,351][WARN][env] [dev-lambda-elastic-2] max file descriptors [65535] for elasticsearch process likely too low, consider increasing to at least [65536] [2016-07-11 09:58:30,930][INFO][node] [dev-lambda-elastic-2] initialized [2016-07-11 09:58:30,930][INFO][node] [dev-lambda-elastic-2] starting ... [2016-07-11 09:58:30,988][INFO][transport] [dev-lambda-elastic-2] publish\_address {127.0.0.1:9300}, bound\_addresses {[::1]:9300}, {127.0.0.1:9300} [2016-07-11 09:58:30,992][INFO][discovery] [dev-lambda-elastic-2] dev-lambda-elastic/mJm17dThQoekzUjwUfZicw [2016-07-11 09:59:00,994][WARN][discovery] [dev-lambda-elastic-2] waited for 30s and no initial state was set by the discovery [2016-07-11 09:59:01,009][INFO][http] [dev-lambda-elastic-2] publish\_address {127.0.0.1:9200}, bound\_addresses {[::1]:9200}, {127.0.0.1:9200} [2016-07-11 09:59:01,009][INFO][node] [dev-lambda-elastic-2] started [2016-07-11 09:59:51,100][DEBUG][action.admin.indices.get] [dev-lambda-elastic-2] no known master node, scheduling a retry [2016-07-11 10:00:01,757][WARN][discovery.zen.ping.unicast] [dev-lambda-elastic-2] failed to send ping to [{#zen\_unicast\_6#}{::1}{[::1]:9300}] SendRequestTransportException[[][[::1]:9300][internal:discovery/zen/unicast]]; nested: NodeNotConnectedException[[][[::1]:9300] Node not connected]; at org.elasticsearch.transport.TransportService.sendRequest(TransportService.java:340) at org.elasticsearch.discovery.zen.ping.unicast.UnicastZenPing.sendPingRequestToNode(UnicastZenPing.java:440) at org.elasticsearch.discovery.zen.ping.unicast.UnicastZenPing.access$1000(UnicastZenPing.java:83) at org.elasticsearch.discovery.zen.ping.unicast.UnicastZenPing$3.run(UnicastZenPing.java:403) at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1142) at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:617) at java.lang.Thread.run(Thread.java:745) Caused by: NodeNotConnectedException[[][[::1]:9300] Node not connected] at org.elasticsearch.transport.netty.NettyTransport.nodeChannel(NettyTransport.java:1132) at org.elasticsearch.transport.netty.NettyTransport.sendRequest(NettyTransport.java:819) at org.elasticsearch.transport.TransportService.sendRequest(TransportService.java:329) ... 6 more [2016-07-11 10:00:21,102][DEBUG][action.admin.indices.get] [dev-lambda-elastic-2] timed out while retrying [indices:admin/get] after failure (timeout [30s]) [2016-07-11 10:00:21,109][WARN][rest.suppressed] /status Params: {index=status} MasterNotDiscoveredException[null] at org.elasticsearch.action.support.master.TransportMasterNodeAction$AsyncSingleAction$5.onTimeout(TransportMasterNodeAction.java:226) at org.elasticsearch.cluster.ClusterStateObserver$ObserverClusterStateListener.onTimeout(ClusterStateObserver.java:236) at org.elasticsearch.cluster.service.InternalClusterService$NotifyTimeout.run(InternalClusterService.java:804) at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1142) at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:617) at java.lang.Thread.run(Thread.java:745)

---

<div class="post-metadata">

**Author:** ![jsmith](https://avatars.discourse-cdn.com/v4/letter/j/df705f/32.png) [@jsmith](https://discuss.elastic.co/u/jsmith)\
**Post date:** [July 11, 2016, 3:49pm UTC](https://discuss.elastic.co/t/elasticsearch-failed-to-send-ping-error/55125/6 "2016-07-11T15:49:39Z")

</div>

Following is log for node where master is TRUE and data is FALSE

[2016-07-11 09:57:31,000][WARN][bootstrap] unable to install syscall filter: seccomp unavailable: CONFIG\_SECCOMP not compiled into kernel, CONFIG\_SECCOMP and CONFIG\_SECCOMP\_FILTER are needed [2016-07-11 09:57:31,254][INFO][node] [dev-lambda-elastic-1] version[2.3.3], pid[2233], build[218bdf1/2016-05-17T15:40:04Z] [2016-07-11 09:57:31,254][INFO][node] [dev-lambda-elastic-1] initializing ... [2016-07-11 09:57:31,899][INFO][plugins] [dev-lambda-elastic-1] modules [reindex, lang-expression, lang-groovy], plugins [cloud-aws], sites [] [2016-07-11 09:57:31,918][INFO][env] [dev-lambda-elastic-1] using [1] data paths, mounts [[/var (/dev/mapper/vg00-var)]], net usable\_space [8.9gb], net total\_space [9.7gb], spins? [no], types [ext4] [2016-07-11 09:57:31,918][INFO][env] [dev-lambda-elastic-1] heap size [989.8mb], compressed ordinary object pointers [true] [2016-07-11 09:57:31,918][WARN][env] [dev-lambda-elastic-1] max file descriptors [65535] for elasticsearch process likely too low, consider increasing to at least [65536] [2016-07-11 09:57:33,701][INFO][node] [dev-lambda-elastic-1] initialized [2016-07-11 09:57:33,701][INFO][node] [dev-lambda-elastic-1] starting ... [2016-07-11 09:57:33,797][INFO][transport] [dev-lambda-elastic-1] publish\_address {127.0.0.1:9300}, bound\_addresses {[::1]:9300}, {127.0.0.1:9300} [2016-07-11 09:57:33,803][INFO][discovery] [dev-lambda-elastic-1] dev-lambda-elastic/uKOibrh4S128wXfaOZhO-w [2016-07-11 09:57:38,901][INFO][cluster.service] [dev-lambda-elastic-1] new\_master {dev-lambda-elastic-1}{uKOibrh4S128wXfaOZhO-w}{127.0.0.1}{127.0.0.1:9300}{data=false, master=true}, reason: zen-disco-join(elected\_as\_master, [0] joins received) [2016-07-11 09:57:38,921][INFO][http] [dev-lambda-elastic-1] publish\_address {127.0.0.1:9200}, bound\_addresses {[::1]:9200}, {127.0.0.1:9200} [2016-07-11 09:57:38,921][INFO][node] [dev-lambda-elastic-1] started [2016-07-11 09:57:38,935][INFO][gateway] [dev-lambda-elastic-1] recovered [0] indices into cluster\_state

---

<div class="post-metadata">

**Author:** ![jsmith](https://avatars.discourse-cdn.com/v4/letter/j/df705f/32.png) [@jsmith](https://discuss.elastic.co/u/jsmith)\
**Post date:** [July 11, 2016, 3:52pm UTC](https://discuss.elastic.co/t/elasticsearch-failed-to-send-ping-error/55125/7 "2016-07-11T15:52:35Z")

</div>

Current YML files where network.publish\_host removed

cluster.name: dev-lambda-elastic node.name: dev-lambda-elastic-1 node.master: true node.data: false bootstrap.mlockall: true network host: \_ec2\_ http.port: 9200 discovery.type: ec2 discovery.zen.minimum\_master\_nodes: 1 cloud.aws.access\_key: XXXXXXXXXXXXXXXXXX cloud.aws.secret\_key: XXXXXXXXXXXXXXXXXXX

cluster.name: dev-lambda-elastic node.name: dev-lambda-elastic-2 node.master: false node.data: true bootstrap.mlockall: true network host: \_ec2\_ http.port: 9200 discovery.type: ec2 discovery.ec2.ping\_timeout: "30s" discovery.zen.minimum\_master\_nodes: 1 cloud.aws.access\_key: IIIIIIIIIIIIIIIIII cloud.aws.secret\_key: IIIIIIIIIIIIIIIIII

---

<div class="post-metadata">

**Author:** ![dadoonet](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/dadoonet/32/137187_2.png) [@dadoonet](https://discuss.elastic.co/u/dadoonet)\
**Post date:** [July 11, 2016, 7:48pm UTC](https://discuss.elastic.co/t/elasticsearch-failed-to-send-ping-error/55125/8 "2016-07-11T19:48:55Z")

</div>

Your posts are not formatted using `</>`.  
That may explain the limit.

I don't understand what is happening. You set `network host: _ec2_` but got:

```auto
[2016-07-11 09:57:33,797][INFO][transport] [dev-lambda-elastic-1] publish_address {127.0.0.1:9300}, bound_addresses {[::1]:9300}, {127.0.0.1:9300}

```

It does not make sense. Are you sure that your configuration is applied?

What happens if you set:

```auto
network host: 192.168.0.1

```

It should fail.

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [July 5, 2017, 10:36pm UTC](https://discuss.elastic.co/t/elasticsearch-failed-to-send-ping-error/55125/9 "2017-07-05T22:36:27Z")

</div>


