# Elasticsearch - failed to turn off translog retention

**URL:** <https://discuss.elastic.co/t/elasticsearch-failed-to-turn-off-translog-retention/245060>\
**Category:** Elasticsearch\
**Created:** [August 14, 2020, 7:37pm UTC](https://discuss.elastic.co/t/elasticsearch-failed-to-turn-off-translog-retention/245060 "2020-08-14T19:37:32Z")\
**Posts on this page:** 2\
**Page:** 1

<div class="post-metadata">

**Author:** ![gferrette](https://avatars.discourse-cdn.com/v4/letter/g/bbce88/32.png) [@gferrette](https://discuss.elastic.co/u/gferrette)\
**Post date:** [August 14, 2020, 7:37pm UTC](https://discuss.elastic.co/t/elasticsearch-failed-to-turn-off-translog-retention/245060/1 "2020-08-14T19:37:32Z")

</div>

Hello!

I've made an upgrade from ES 7.0.1 to ES 7.6.1 and after that, on nodes startup, its appearing on the logs the message below:

```auto
[2020-08-14T10:54:21,893][WARN][o.e.i.s.IndexShard] [machine] [.tasks][0] failed to turn off translog retention
org.apache.lucene.store.AlreadyClosedException: engine is closed
        at org.elasticsearch.index.shard.IndexShard.getEngine(IndexShard.java:2528) ~[elasticsearch-7.6.1.jar:7.6.1]
        at org.elasticsearch.index.shard.IndexShard.trimTranslog(IndexShard.java:1106) ~[elasticsearch-7.6.1.jar:7.6.1]
        at org.elasticsearch.index.shard.IndexShard$3.doRun(IndexShard.java:1944) [elasticsearch-7.6.1.jar:7.6.1]
        at org.elasticsearch.common.util.concurrent.ThreadContext$ContextPreservingAbstractRunnable.doRun(ThreadContext.java:692) [elasticsearch-7.6.1.jar:7.6.1]
        at org.elasticsearch.common.util.concurrent.AbstractRunnable.run(AbstractRunnable.java:37) [elasticsearch-7.6.1.jar:7.6.1]
        at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1128) [?:?]
        at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:628) [?:?]
        at java.lang.Thread.run(Thread.java:830) [?:?]

```

The cluster is green health, and all my indexes are green too.  
Is there any way to solve this message?

Thanks in advance!

Gabriel.

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [September 11, 2020, 7:37pm UTC](https://discuss.elastic.co/t/elasticsearch-failed-to-turn-off-translog-retention/245060/2 "2020-09-11T19:37:53Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
