# Elasticsearch failing to start after upgrading to V5.0.2 from V2.4

**URL:** <https://discuss.elastic.co/t/elasticsearch-failing-to-start-after-upgrading-to-v5-0-2-from-v2-4/67793>\
**Category:** Elasticsearch\
**Created:** [December 1, 2016, 4:50pm UTC](https://discuss.elastic.co/t/elasticsearch-failing-to-start-after-upgrading-to-v5-0-2-from-v2-4/67793 "2016-12-01T16:50:42Z")\
**Posts on this page:** 5\
**Page:** 1

<div class="post-metadata">

**Author:** ![jinal.shah](https://avatars.discourse-cdn.com/v4/letter/j/3da27b/32.png) [@jinal.shah](https://discuss.elastic.co/u/jinal.shah)\
**Post date:** [December 1, 2016, 4:50pm UTC](https://discuss.elastic.co/t/elasticsearch-failing-to-start-after-upgrading-to-v5-0-2-from-v2-4/67793/1 "2016-12-01T16:50:43Z")

</div>

Hello

I am having trouble starting elasticsearch after it was upgraded to V5.0.2 from version V2.4 (Running on Centos 6.7)

```
sudo service elasticsearch start
Starting elasticsearch: [2016-12-01T16:45:32,801][WARN][o.e.c.l.LogConfigurator] ignoring unsupported logging configuration file [/etc/elasticsearch/shield/logging.yml], logging is configured via [/etc/elasticsearch/shield/log4j2.properties]
                                                           [OK]

```

I get this when I check the status:

```
sudo service elasticsearch status
elasticsearch dead but subsys locked

```

I've also checked /etc/elasticsearch/shield/log4j2.properties (this file does't exist). is it something that I need to create?

I've updated the permissions on /etc/elasticsearch to elasticsearch:elasticsearch  
I've also updated the permissions on: /usr/share/elasticsearch to elasticsearch:elasticsearch

Also when I run it manually, I get the following:

```
 ./elasticsearch
Exception in thread "main" org.elasticsearch.bootstrap.BootstrapException: java.nio.file.NoSuchFileException: /usr/share/elasticsearch/config
Likely root cause: java.nio.file.NoSuchFileException: /usr/share/elasticsearch/config
        at sun.nio.fs.UnixException.translateToIOException(UnixException.java:86)
        at sun.nio.fs.UnixException.rethrowAsIOException(UnixException.java:102)
        at sun.nio.fs.UnixException.rethrowAsIOException(UnixException.java:107)
        at sun.nio.fs.UnixFileAttributeViews$Basic.readAttributes(UnixFileAttributeViews.java:55)
        at sun.nio.fs.UnixFileSystemProvider.readAttributes(UnixFileSystemProvider.java:144)
        at sun.nio.fs.LinuxFileSystemProvider.readAttributes(LinuxFileSystemProvider.java:99)
        at java.nio.file.Files.readAttributes(Files.java:1737)
        at java.nio.file.FileTreeWalker.getAttributes(FileTreeWalker.java:225)
        at java.nio.file.FileTreeWalker.visit(FileTreeWalker.java:276)
        at java.nio.file.FileTreeWalker.walk(FileTreeWalker.java:322)
        at java.nio.file.Files.walkFileTree(Files.java:2662)
        at org.elasticsearch.common.logging.LogConfigurator.configure(LogConfigurator.java:100)
        at org.elasticsearch.common.logging.LogConfigurator.configure(LogConfigurator.java:83)
        at org.elasticsearch.bootstrap.Bootstrap.init(Bootstrap.java:254)
        at org.elasticsearch.bootstrap.Elasticsearch.init(Elasticsearch.java:121)
        at org.elasticsearch.bootstrap.Elasticsearch.execute(Elasticsearch.java:112)
        at org.elasticsearch.cli.SettingCommand.execute(SettingCommand.java:54)
        at org.elasticsearch.cli.Command.mainWithoutErrorHandling(Command.java:96)
        at org.elasticsearch.cli.Command.main(Command.java:62)
        at org.elasticsearch.bootstrap.Elasticsearch.main(Elasticsearch.java:89)
        at org.elasticsearch.bootstrap.Elasticsearch.main(Elasticsearch.java:82)
Refer to the log for complete error details.

```

Any help will be much appreciated!

---

<div class="post-metadata">

**Author:** ![warkolm](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/warkolm/32/39224_2.png) [@warkolm](https://discuss.elastic.co/u/warkolm)\
**Post date:** [December 4, 2016, 7:49am UTC](https://discuss.elastic.co/t/elasticsearch-failing-to-start-after-upgrading-to-v5-0-2-from-v2-4/67793/2 "2016-12-04T07:49:58Z")

</div>

If you install via RPM+yum then you don't need to chown anything.

Check `/var/log/elasticsearch/`.

---

<div class="post-metadata">

**Author:** ![jinal.shah](https://avatars.discourse-cdn.com/v4/letter/j/3da27b/32.png) [@jinal.shah](https://discuss.elastic.co/u/jinal.shah)\
**Post date:** [December 5, 2016, 11:04am UTC](https://discuss.elastic.co/t/elasticsearch-failing-to-start-after-upgrading-to-v5-0-2-from-v2-4/67793/3 "2016-12-05T11:04:59Z")

</div>

Awesome, I reinstalled it but now I'm seeing the following errors on the logstash logs:

```
[2016-12-05T11:03:02,748][WARN][logstash.outputs.elasticsearch] UNEXPECTED POOL ERROR {:e=>#<LogStash::Outputs::ElasticSearch::HttpClient::Pool::NoConnectionAvailableError: No Available connections>}
[2016-12-05T11:03:02,749][ERROR][logstash.outputs.elasticsearch] Attempted to send a bulk request to elasticsearch, but no there are no living connections in the connection pool. Perhaps Elasticsearch is unreachable or down? {:error_message=>"No Available connections", :class=>"LogStash::Outputs::ElasticSearch::HttpClient::Pool::NoConnectionAvailableError", :will_retry_in_seconds=>64}
[2016-12-05T11:03:02,750][WARN][logstash.outputs.elasticsearch] UNEXPECTED POOL ERROR {:e=>#<LogStash::Outputs::ElasticSearch::HttpClient::Pool::NoConnectionAvailableError: No Available connections>}
[2016-12-05T11:03:02,750][ERROR][logstash.outputs.elasticsearch] Attempted to send a bulk request to elasticsearch, but no there are no living connections in the connection pool. Perhaps Elasticsearch is unreachable or down? {:error_message=>"No Available connections", :class=>"LogStash::Outputs::ElasticSearch::HttpClient::Pool::NoConnectionAvailableError", :will_retry_in_seconds=>64}
[2016-12-05T11:03:02,752][WARN][logstash.outputs.elasticsearch] UNEXPECTED POOL ERROR {:e=>#<LogStash::Outputs::ElasticSearch::HttpClient::Pool::NoConnectionAvailableError: No Available connections>}
[2016-12-05T11:03:02,752][ERROR][logstash.outputs.elasticsearch] Attempted to send a bulk request to elasticsearch, but no there are no living connections in the connection pool. Perhaps Elasticsearch is unreachable or down? {:error_message=>"No Available connections", :class=>"LogStash::Outputs::ElasticSearch::HttpClient::Pool::NoConnectionAvailableError", :will_retry_in_seconds=>64}
[2016-12-05T11:03:03,777][WARN][logstash.outputs.elasticsearch] UNEXPECTED POOL ERROR {:e=>#<LogStash::Outputs::ElasticSearch::HttpClient::Pool::NoConnectionAvailableError: No Available connections>}
[2016-12-05T11:03:03,778][WARN][logstash.outputs.elasticsearch] Elasticsearch output attempted to sniff for new connections but cannot. No living connections are detected. Pool contains the following current URLs {:url_info=>{}}
[2016-12-05T11:03:04,950][WARN][logstash.shutdownwatcher]
```

---

<div class="post-metadata">

**Author:** ![jinal.shah](https://avatars.discourse-cdn.com/v4/letter/j/3da27b/32.png) [@jinal.shah](https://discuss.elastic.co/u/jinal.shah)\
**Post date:** [December 5, 2016, 12:09pm UTC](https://discuss.elastic.co/t/elasticsearch-failing-to-start-after-upgrading-to-v5-0-2-from-v2-4/67793/4 "2016-12-05T12:09:14Z")

</div>

Solved it by setting sniffing =\> false in the output configuration under elasticsearch.

It works now

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [January 2, 2017, 12:09pm UTC](https://discuss.elastic.co/t/elasticsearch-failing-to-start-after-upgrading-to-v5-0-2-from-v2-4/67793/5 "2017-01-02T12:09:18Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
