# Elasticsearch failing to start on centos

**URL:** <https://discuss.elastic.co/t/elasticsearch-failing-to-start-on-centos/148075>\
**Category:** Elasticsearch\
**Created:** [September 11, 2018, 7:38am UTC](https://discuss.elastic.co/t/elasticsearch-failing-to-start-on-centos/148075 "2018-09-11T07:38:58Z")\
**Posts on this page:** 4\
**Page:** 1

<div class="post-metadata">

**Author:** ![Nikesh](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/nikesh/32/86579_2.png) [@Nikesh](https://discuss.elastic.co/u/Nikesh)\
**Post date:** [September 11, 2018, 7:38am UTC](https://discuss.elastic.co/t/elasticsearch-failing-to-start-on-centos/148075/1 "2018-09-11T07:38:58Z")

</div>

Sep 11 07:35:17 [blrsearch.ultria.com](http://blrsearch.ultria.com) systemd[1]: elasticsearch.service: main process exited, code=exited, status=1/FAILURE  
Sep 11 07:35:17 [blrsearch.ultria.com](http://blrsearch.ultria.com) systemd[1]: Unit elasticsearch.service entered failed state.  
Sep 11 07:35:17 [blrsearch.ultria.com](http://blrsearch.ultria.com) systemd[1]: elasticsearch.service failed.  
Sep 11 07:35:19 [blrsearch.ultria.com](http://blrsearch.ultria.com) sudo[2056]: karthikm : TTY=pts/1 ; PWD=/home/karthikm ; USER=root ; COMMAND=/bin/journalctl -f  
My Configuration file screenshot

 ![Screenshot%20(11)](https://us1.discourse-cdn.com/elastic/original/3X/5/6/565b191e89d4e718ba8ed075850b3512ab2b90e9.png)  
My Configuration file is in text format:-  
cluster.name: verdantis  
node.name: DATA-${10.4.1.254}  
node.data: true  
node.master: true  
path.data: /var/lib/elasticsearch  
path.logs: /var/log/elasticsearch  
#path.repo: ["/home/data\_ElasticSearchBackup"]  
bootstrap.memory\_lock: true  
bootstrap.seccomp: false  
network.host:10.4.1.254  
http.port:9200  
transport.tcp.port: 9300  
discovery.zen.ping.unicast.hosts: ["10.4.1.254","10.4.1.138","10.4.1.169"]  
discovery.zen.minimum\_master\_nodes:3

---

<div class="post-metadata">

**Author:** ![warkolm](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/warkolm/32/39224_2.png) [@warkolm](https://discuss.elastic.co/u/warkolm)\
**Post date:** [September 11, 2018, 7:50am UTC](https://discuss.elastic.co/t/elasticsearch-failing-to-start-on-centos/148075/2 "2018-09-11T07:50:25Z")

</div>

Please don't post pictures of text, they are difficult to read and some people may not be even able to see them.

Please check your Elasticsearch logs as well.

---

<div class="post-metadata">

**Author:** ![Nikesh](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/nikesh/32/86579_2.png) [@Nikesh](https://discuss.elastic.co/u/Nikesh)\
**Post date:** [September 11, 2018, 8:24am UTC](https://discuss.elastic.co/t/elasticsearch-failing-to-start-on-centos/148075/4 "2018-09-11T08:24:19Z")

</div>

Hi,  
Thanks for your time and answer. I am new to Elasticsearch and centOS. Could you please let me know what is wrong in my configuration file(I have added my configuration file in text format) and reason for failure of Elasticsearch start.

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [October 9, 2018, 8:24am UTC](https://discuss.elastic.co/t/elasticsearch-failing-to-start-on-centos/148075/5 "2018-10-09T08:24:23Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
