# Elasticsearch Failing to start

**URL:** https://discuss.elastic.co/t/elasticsearch-failing-to-start/363879
**Category:** Elasticsearch
**Created:** [July 26, 2024, 5:03pm UTC](https://discuss.elastic.co/t/elasticsearch-failing-to-start/363879 "2024-07-26T17:03:14Z")
**Posts on this page:** 4
**Page:** 1

<div class="post-metadata">

### Author: ![erikg](https://avatars.discourse-cdn.com/v4/letter/e/91b2a8/32.png) [@erikg](https://discuss.elastic.co/u/erikg)
#### Post date: [July 26, 2024, 5:03pm UTC](https://discuss.elastic.co/t/elasticsearch-failing-to-start/363879/1 "2024-07-26T17:03:14Z")

</div>

Hello I attempt to install elasticsearch on new node, but its failling to start

Any help would be great:

```auto
Jul 26 09:54:04 <> systemd-entrypoint[1933]: Exception in thread "main" org.apache.lucene.index.CorruptIndexException: codec footer mismatch (file truncated?): actual footer=680781824 vs expected footer=-1071082520 (resource=BufferedChecksumIndexInput(NIOFSIndexInput(path="/etc/elasticsearch/elasticsearch.keystore")))
Jul 26 09:54:04 <> systemd-entrypoint[1933]: at org.apache.lucene.codecs.CodecUtil.validateFooter(CodecUtil.java:585)
Jul 26 09:54:04 <> systemd-entrypoint[1933]: at org.apache.lucene.codecs.CodecUtil.checkFooter(CodecUtil.java:433)
Jul 26 09:54:04 <> systemd-entrypoint[1933]: at org.elasticsearch.common.settings.KeyStoreWrapper.load(KeyStoreWrapper.java:293)
Jul 26 09:54:04 <> systemd-entrypoint[1933]: at org.elasticsearch.server.cli.KeyStoreLoader.load(KeyStoreLoader.java:26)
Jul 26 09:54:04 <> systemd-entrypoint[1933]: at org.elasticsearch.server.cli.ServerCli.execute(ServerCli.java:81)
Jul 26 09:54:04 <> systemd-entrypoint[1933]: at org.elasticsearch.common.cli.EnvironmentAwareCommand.execute(EnvironmentAwareCommand.java:54)
Jul 26 09:54:04 <> systemd-entrypoint[1933]: at org.elasticsearch.cli.Command.mainWithoutErrorHandling(Command.java:85)
Jul 26 09:54:04 <> systemd-entrypoint[1933]: at org.elasticsearch.cli.Command.main(Command.java:50)
Jul 26 09:54:04 <> systemd-entrypoint[1933]: at org.elasticsearch.launcher.CliToolLauncher.main(CliToolLauncher.java:64)
Jul 26 09:54:04 <> systemd[1]: elasticsearch.service: Main process exited, code=exited, status=1/FAILURE

```

---

<div class="post-metadata">

### Author: ![Christian\_Dahlqvist](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/christian_dahlqvist/32/4617_2.png) [@Christian\_Dahlqvist](https://discuss.elastic.co/u/Christian_Dahlqvist)
#### Post date: [July 26, 2024, 7:05pm UTC](https://discuss.elastic.co/t/elasticsearch-failing-to-start/363879/2 "2024-07-26T19:05:21Z")

</div>

> [@erikg](#):
>
> `org.apache.lucene.index.CorruptIndexException: codec footer mismatch (file truncated?): actual footer=680781824 vs expected footer=-1071082520`

Seems like you have a corrupt shard similar to the case reported [in this thread](https://discuss.elastic.co/t/shard-allocation-failed/363881/2). As outlined there it is likely due to faulty or inappropriate storage.

---

<div class="post-metadata">

### Author: ![erikg](https://avatars.discourse-cdn.com/v4/letter/e/91b2a8/32.png) [@erikg](https://discuss.elastic.co/u/erikg)
#### Post date: [July 26, 2024, 7:36pm UTC](https://discuss.elastic.co/t/elasticsearch-failing-to-start/363879/3 "2024-07-26T19:36:56Z")

</div>

okay I read this:  
[Troubleshooting corruption | Elasticsearch Guide [8.14] | Elastic](https://www.elastic.co/guide/en/elasticsearch/reference/current/corruption-troubleshooting.html)

I don't think its that.  
More context:  
I was planning on making this a dedicated ingest node, it was previously a logstash node. I don't need to store data.

---

<div class="post-metadata">

### Author: ![Christian\_Dahlqvist](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/christian_dahlqvist/32/4617_2.png) [@Christian\_Dahlqvist](https://discuss.elastic.co/u/Christian_Dahlqvist)
#### Post date: [July 26, 2024, 7:57pm UTC](https://discuss.elastic.co/t/elasticsearch-failing-to-start/363879/4 "2024-07-26T19:57:53Z")

</div>

What is the configuration of the node (or what was it when you got the error)? What type of storage are you using?
