# Elasticsearch Failing to start

**URL:** https://discuss.elastic.co/t/elasticsearch-failing-to-start/363879
**Category:** Elasticsearch
**Created:** [July 26, 2024, 5:03pm UTC](https://discuss.elastic.co/t/elasticsearch-failing-to-start/363879 "2024-07-26T17:03:14Z")
**Posts on this page:** 1
**Showing post:** 2

<div class="post-metadata">

### Author: ![Christian\_Dahlqvist](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/christian_dahlqvist/32/4617_2.png) [@Christian\_Dahlqvist](https://discuss.elastic.co/u/Christian_Dahlqvist)
#### Post date: [July 26, 2024, 7:05pm UTC](https://discuss.elastic.co/t/elasticsearch-failing-to-start/363879/2 "2024-07-26T19:05:21Z")

</div>

> [@erikg](#):
>
> `org.apache.lucene.index.CorruptIndexException: codec footer mismatch (file truncated?): actual footer=680781824 vs expected footer=-1071082520`

Seems like you have a corrupt shard similar to the case reported [in this thread](https://discuss.elastic.co/t/shard-allocation-failed/363881/2). As outlined there it is likely due to faulty or inappropriate storage.

---

_[View the full topic](https://discuss.elastic.co/t/elasticsearch-failing-to-start/363879)._
