# Elasticsearch fails to start after elasticsearch.yml is changed

**URL:** <https://discuss.elastic.co/t/elasticsearch-fails-to-start-after-elasticsearch-yml-is-changed/133897>\
**Category:** Elasticsearch\
**Created:** [May 30, 2018, 2:56pm UTC](https://discuss.elastic.co/t/elasticsearch-fails-to-start-after-elasticsearch-yml-is-changed/133897 "2018-05-30T14:56:18Z")\
**Posts on this page:** 4\
**Page:** 1

<div class="post-metadata">

**Author:** ![DanV](https://avatars.discourse-cdn.com/v4/letter/d/e9c0ed/32.png) [@DanV](https://discuss.elastic.co/u/DanV)\
**Post date:** [May 30, 2018, 2:56pm UTC](https://discuss.elastic.co/t/elasticsearch-fails-to-start-after-elasticsearch-yml-is-changed/133897/1 "2018-05-30T14:56:18Z")

</div>

Hello,

i'm changing my elasticsearch.yml connfig so he can replicate data in other machines. The problem appear when im defining my path.data and path.logs, after i save the new paths and restart the service i get this error:

Elastic node1:

 ![image](https://us1.discourse-cdn.com/elastic/original/3X/a/f/afc364313bc0e36b4e622052b25b7943ba0d4a7c.png)

Elastic node2:

 ![image](https://us1.discourse-cdn.com/elastic/original/3X/6/6/66cd740cfe0e604a48d5d6bfe82c431a0418294b.png)

I dont think is a matter of permissions since i gave a 666 permission set to the data and logs directory.

What could be the problem?

---

<div class="post-metadata">

**Author:** ![pjanzen](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/pjanzen/32/13756_2.png) [@pjanzen](https://discuss.elastic.co/u/pjanzen)\
**Post date:** [May 30, 2018, 3:18pm UTC](https://discuss.elastic.co/t/elasticsearch-fails-to-start-after-elasticsearch-yml-is-changed/133897/2 "2018-05-30T15:18:50Z")

</div>

HI,

Please dont post pictures, the text is not searchable. the path.data should be owned by elasticsearch and 666 is not correct. It should have 755 at a minimum so the owner (elasticsearch) can enter the directory and its subdirectories.

Paul.

---

<div class="post-metadata">

**Author:** ![DanV](https://avatars.discourse-cdn.com/v4/letter/d/e9c0ed/32.png) [@DanV](https://discuss.elastic.co/u/DanV)\
**Post date:** [May 30, 2018, 6:26pm UTC](https://discuss.elastic.co/t/elasticsearch-fails-to-start-after-elasticsearch-yml-is-changed/133897/3 "2018-05-30T18:26:48Z")

</div>

Thanks, that solved it! Sorry for the pics !

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [June 27, 2018, 6:26pm UTC](https://discuss.elastic.co/t/elasticsearch-fails-to-start-after-elasticsearch-yml-is-changed/133897/4 "2018-06-27T18:26:58Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
